Welcome to Multi-Rotor UK. Please login or sign up.

Sunday,August 18, 2019, 16:49:20

Login with username, password and session length

Shoutbox

Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Gaza07:
09 Jul 2019 18:10:30
Hope you all have a great day  :beer2:
Andy7:
09 Jul 2019 14:05:28
BFU#8 details locked in for this saturday - see the head of the forum thread for all details.
hoverfly:
05 Jul 2019 21:51:05
Good for genital warts as well......or so I'm told.. :hmm
DarkButterfly:
05 Jul 2019 21:48:24
Just fixed a busted SMA connector on my TBS unity pigtail, it suffered badly in a recent crash and split in two, nothing a touch of the soldering iron couldn't fix  :D
DarkButterfly:
05 Jul 2019 19:44:08
 :D
Members
Stats
  • Total Posts: 196548
  • Total Topics: 19799
  • Online Today: 48
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 1
Guests: 37
Total: 38

Theme Changer





3d - Printworx

Printing 3d Forum

AIOP V2 Wiring Setup and Help

Started by brandnick, Wednesday,January 30, 2013, 03:12:25

Previous topic - Next topic

brandnick

Wednesday,January 30, 2013, 03:12:25 Last Edit: Wednesday,January 30, 2013, 14:55:14 by brandnick
Ok after about 4 hours and reading and a headache i got the following working

Quad Setup
-Flight Board: Rctimer Crius AIOPv2
-GPS : Ublox NEO 6M
-Telemetry:  Radio Telemetry Kit 915Mhz

See link to Package
http://www.rctimer.com/index.php?gOo=goods_details.dwt&goodsid=820&productname=

Use this great manual http://www.multi-rotor.co.uk/index.php?topic=595.0 the manual will help to get the megapirateNg firmware uploaded to your board.

 
1) Followed the setups from manual and uploaded megapirateNg 2.8R3 to flight board

- I only need to change the following in APM_config.h

#define PIRATES_SENSOR_BOARD PIRATES_CRIUS_AIO_PRO_V2
#define GPS_PROTOCOL GPS_PROTOCOL_UBLOX 

I didnt need to change anything else since i using Quad X and everything was already preset

Verify and uploaded to the flight board

To ensure everything was working i did the following
- Open mission planner 1.2.32
- Connected and all worked(Since the updated version in Mission Planner I was unable to use the accelerometer calibration (Found if you click Calibration >>>> Arducopter Level) so I did the following
* Click on terminal
* type setup
* type level

All done ( Reconnected to the mission planner and all was fine)

2) Installing the GPS
- You will need download and installed the latest Ublox software called U-center.
- You will also need an FTDI cable to connect the GPS to your computer. http://www.ebay.com/itm/FTDI-Basic-6-PIN-3-3-5V-For-Arduino-Free-USB-Cable-/230820610037?pt=LH_DefaultDomain_0&hash=item35bdfafff5

- Once you have the FTDI cable connect the GPS to the USB FTDI 
- Import note (when connecting to GPS to the FTDI I did GND to GND/ TX to RX/RX to TX/ VCC to VCC)

- You will need to download and upload a file called 3DR-Ublox.txt this due to the baud rate preinstalled on the GPS is 9600 will not work so follow these steps here  ( http://code.google.com/p/arducopter/wiki/UBlox )
 
- That will upload the new config

3) Now time to connect the GPS to the Flight Board
I used the S1-3 for my connection

[attach=1]

- I just followed the color code (red to red)-vcc (black to black)-gnd (yellow to yellow)-tx (green to green)rx

Thats all she wrote, plugged in the USB and watched the lights on the board flight A-LED(red) and C-LED(green) flashing, waited about 30 sec and the C led(green light become steady- GOT GPS 3D FIX) while the A-LED(red) continued to flash since it was not armed just to double check connected to the mission planer and saw that i had got a GPS 3D Fix

4) Connecting 913 or 433 Mhz telemetry
- I used S1-3 again for my connection( see picture above for location - turn over the board and you will see the labels)
Used the Rx3(blue) and Tx3(purple) and connect to the 913mhz transmitter (RX3 to TX)(TX3 to RX)     
     
This is where it gets crazy i used the VVC and GND from I2C since i already used S1-3 VCC and GND for the GPS

Thank was for it

Plugged 913mhz in the receiver to the PC. Although windows found the driver i had to still update the driver with correct driver  http://www.ftdichip.com/Drivers/D2XX.htm

Once done, i connected the battery(no PROPs) and changed the connect rate to 57600 and pick the correct com port and click connected

That was it .

I hope my setup help someone else .

Thanks
   

 





Gaza07

Excellent post brandnick I';m sure it will help others who have the same or similar gear  :bravo:

Ross

Wednesday,January 30, 2013, 08:09:03 #2 Last Edit: Wednesday,January 30, 2013, 08:25:07 by Ross
I';ll second that for sure.......great step by step for newbies.....Thanks a million  ~~ ~~

Let's be careful out there.
SAFETY is.. NO accident.

QuadBod


Well done brandnick, it can be a bit fiddly, especially the first time.

Quote from: brandnick on Wednesday,January 30, 2013, 03:12:25
Once connected i needed to download and upload the 3Drconfig file (called 3DR-Ublox.txt) just google it


You also have this option: http://www.multi-rotor.co.uk/index.php?topic=1177.0

Quote from: brandnick on Wednesday,January 30, 2013, 03:12:25
This is where it gets crazy i used the VVC and GND from I2C since i already used S1-3 VCC and GND for the GPS


I agree it';s a bit crazy - and in a future version they should move the seldom used analog ports to pads to free up space on the edge of the board for 3 separate 4 pin molex sockets for s1 to s3, rather than having them crammed together on one plug. At the very least they should supply a breakout cable with the kit to connect from the 8 way molex to GPS and 3DR, rather than including bare wire ends on the 8pin  cable, and cables terminated for the APM 2.0 / arduflyer with the GPS and 3DR, leaving us to figure out our own solution.

Quote from: brandnick on Wednesday,January 30, 2013, 03:12:25

Could i have used the same GND and VCC to connect the GPS and 913 mhz Telemetry instead of using I2C GND/Vcc ?


Yes you could - that';s what I';ve done.

Something else you may want to do is update the 3DR firmware through the Mission Planner. To update the non-usb "Air" module you can connect it to your PC with your FTDI board (the USB one just has a built in FTDI, it';s the same radio module on both boards). Yours probably came with 1.5, 1.6 adds temperature control to prevent the radio overheating with heavy use (unlikely with flight-controller telemetry, but still no harm!), and a few other minor changes.

You might also want to check if the settings are optimal (and legal) for your country (no idea what that means for Jamaica!). There';s a ton of info here on what you can change and why:

http://code.google.com/p/ardupilot-mega/wiki/3DRadio

You can use the Mission Planner, or there';s also a standalone configuration tool here:

http://vps.oborne.me/3drradioconfig.zip

Regards,
Matt.