Welcome to Multi-Rotor UK. Please login or sign up.

Wednesday,August 21, 2019, 14:50:58

Login with username, password and session length

Shoutbox

Andy7:
21 Aug 2019 12:15:41
Gaza - can you make the subject line section in the forum topic list wider? It's cutting off the subject field really short.
Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Gaza07:
09 Jul 2019 18:10:30
Hope you all have a great day  :beer2:
Andy7:
09 Jul 2019 14:05:28
BFU#8 details locked in for this saturday - see the head of the forum thread for all details.
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196563
  • Total Topics: 19802
  • Online Today: 38
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 2
Guests: 35
Total: 37

Theme Changer





3d - Printworx

Printing 3d Forum

Help Needed with Twitchy Quad: FIXED

Started by eyeflying, Saturday,November 17, 2012, 15:00:21

Previous topic - Next topic

eyeflying

Saturday,November 17, 2012, 15:00:21 Last Edit: Sunday,November 18, 2012, 16:00:06 by eyeflying
Just built this quad on a 450 frame with a MultiWii board but got a problem which I hope someone can help with.

The quad seems to fly fine but then starts twitching and will suddenly drop (or flip - see vid). I';ve played with the PID';s, changed the board for another identical board (same problem though). I put the board in another quad - Turnigy HAL - and it flies fine.

This is starting to look like a hradware issue to me?? - Any advice before I just it as a leaf blower  :smiley:




Gaza07

Cant really tell in the video if its the same motor stopping each time, could it be a dodgy esc or motors, is the cut off disabled in all the esc';s
Hold the quad out at arms length with a bit of throttle and rock it to make the motors work and see if the same one packs up all the time, if it does change the esc and test again if its not cured try changing the motor, its just a process of elimination  ~~

eyeflying

Hmmm... It does seem like a dodgy motor or ESC. I';ve fitted one of those Skywalker Quattro ESC';s (4 in 1) - never tried this before. I';ll do what you suggest and keep you posted on the result

eyeflying

Fixed the ';twitch and drop'; problem.

There were 3 problems with the setup - all software related. Firstly I modified the Yaw PID';s to a really low value P=3. Then lowered the Gyros Lo Pass Filter. Then isolated the control board to reduce vibration.

The quad now seems really stable but probably still needs a couple of minor tweaks to get it perfect.

Frustration over  :smiley:

Gaza07

Glad to hear you got t sorted and thanks for posting what the problem was it could help some one else at some point  ~~