Welcome to Multi-Rotor UK. Please login or sign up.

Monday,August 19, 2019, 07:46:14

Login with username, password and session length

Shoutbox

DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Gaza07:
09 Jul 2019 18:10:30
Hope you all have a great day  :beer2:
Andy7:
09 Jul 2019 14:05:28
BFU#8 details locked in for this saturday - see the head of the forum thread for all details.
hoverfly:
05 Jul 2019 21:51:05
Good for genital warts as well......or so I'm told.. :hmm
DarkButterfly:
05 Jul 2019 21:48:24
Just fixed a busted SMA connector on my TBS unity pigtail, it suffered badly in a recent crash and split in two, nothing a touch of the soldering iron couldn't fix  :D
Members
Stats
  • Total Posts: 196552
  • Total Topics: 19801
  • Online Today: 51
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 3
Guests: 49
Total: 52

Theme Changer





3d - Printworx

Printing 3d Forum

NEO-6 V2 GPS & 3DR Config file

Started by Jumpy07, Thursday,November 15, 2012, 17:26:12

Previous topic - Next topic

Jumpy07

Managed to upload the 3DR configuration text file to the NEO-6 V2 GPS, gave an error as below.. but proceeded and it change the setting, without going through everyone,, it did seem to configure the NE0 6 in a similar way to the LEA-6 for which the configuration file was written for..

The text file appears to make a number of changes to the GPS, one of the most noticeable is that it turns off a lot of erroneous sentences, once you have uploaded the file you will also find that Ucentre does not display the Sat info... it will display a fix, lat long, HDOP etc..     but it seems to wait for 3D fix only.. which takes a little longer..
the configuration is set for aeronautical etc..

To load the 3DR text file its the same process as the LEA-6

Download the 3DR config from here http://ardupilot-mega.googlecode.com/git-history/ArduPlane-2.50/libraries/AP_GPS/config/3DR-Ublox.txt

Download Ucentre  http://www.u-blox.com/images/Support/Support_Products/EvaluationSoftware/u-centersetup-7.0.2.1.zip

Connect the NEO-6 to and FTDi adapter..


To upload the text file to the GPS you can do this from the MENU.. as shown below





Send file to the GPS.. you will get and error as below.. ignore.. hit proceed...




You then hit "Send to GPS", you will get some errors, and eventually it will complete, then go back into U-Centre and make sure you save the config in the configuration view to EEPROM. The baud rate will now have bene changed to 38400.

After this has been done, you will no longer see stats on number of Sats etc, but should see a position fix.

You can now connect the GPS to the APM 2.5..
BNUC-S Pilot with PfCo /PFAW.
UAQ / CAA PfCo Instructor / Flight Assessor

"All that is necessary for the triumph of evil is that good men do nothing"

Gaza07

Great post been waiting to see if this works  ~~

neagron

Many thanks for that,Jumpy,yours Marty. :scotland:

Gaza07

I';ve just flashed a Crius cn-06 v2 with this config file and all went well, the only thing I will add is that when you get the errors and you will, its because the speed is changed to 38400 as the config file is loaded so the end of the file fails to transfer properly, the way round this is once you have uploaded the file and see the errors, change the speed in the ucentre app to 38400 and then re upload the config file, this time it will complete with no errors, I';m not saying you need to upload twice but if you do it will finish with no errors which has to be a good thing, job done  connect it to your APM and you should get a fix ~~

Note as mentioned above with the 3dr config loaded you will not be able to see the same graphics on the ucentre screen as you did before this is because the 3dr config is written for the APM  ~~

titeuf007

i have lea module does it the same txt file that i need to use to tune my gps?

Gaza07

The 3dr gps is a LEA6 Gps so you should be able to load the 3dr file with no problems,
ignore the errors, once its done change your port speed to 38400 and then do the upload again this time it will go through with out errors,
It only gets the errors because it turns up the speed as the file loads and because ucentre is still set to 9600 it shows the errors, once you up the speed all works fine,
Note though that all the stuff you see in ucentre will no longer show once the 3dr config is loaded  ~~


Quote from: titeuf007 on Saturday,April 20, 2013, 17:44:43
i have lea module does it the same txt file that i need to use to tune my gps?


drtuvoc



    I have the Ublox 6M-Neo GPS which I got form RCTimer and have used previous for my CRIUS AIOP v2 board, and I was wanting to use it on a APM 2.5 board. I';m having problems flashing my board with the ublox.txt file provided in this thread with the u-center software.

    I made a usb-FTDI cable with a FTDI adapter, wired it as I was supposed to, but can';t tell if I am really connected to the GPS. The com port created when I attach my cable to the computer running windows 7 is recognized by the u-center software... Though, I';m a little dyslexic and for some reason have problems with the whole TX-RX reversal thing, but I sketched out the wire layout so I';m pretty sure I got it right.

    When my cable is connected through the header pins to the GPS it powers, the red RX led on the FTDI adapter flashes about once every one to two seconds. There is no GPS fix indoors or out indicated by the u-center software.

    When sending commands or a file to the GPS, the green TX led flashes ever so briefly. In the configuration upload window in the u-center software (v 7.02,) I get timeout errors saying the receiver isn';t acknowledging as the file uploads a line at a time.

    Some threads say this the error is normal, but when I connect the GPS to APM 2.5 board it is not recognized. I';m not confident anything has happened.

    Oh yeah, the com connection indicator at the bottom of the board does flash green when the GPS is connected and I have tried various baud rates, making sure the com port in Windows device manager is configured at the same speed.  I have tried the configuration file upload process with the TX-RX line reversed, just in case my dyslexia has gotten the better of me. Still no joy... Is there any other way to confirm connection of the GPS to the u-center software or other software?

    I';m building my first quad and would just buy a compatible GPS to the APM 2.5 but burned up $65 worth of ESCs, somehow, and I need to replace them first, but I';m getting really frustrated.

Any help is appreciated. Thanks.

here are my cable setups
[attach=1][attach=2]
and ucenter screen shots
[attach=3][attach=4]

Gaza07

The default baud rate is 9600 try setting it to that and see if you get any activity on the ucentre screen if you do then upload the config file, if you get an error on the upload then change to 38400 and re upload and it should go through the second time with no errors  ~~

KK1W

Quote from: drtuvoc on Tuesday,April 30, 2013, 18:38:11

    I have the Ublox 6M-Neo GPS which I got form RCTimer and have used previous for my CRIUS AIOP v2 board, and I was wanting to use it on a APM 2.5 board. I';m having problems flashing my board with the ublox.txt file provided in this thread with the u-center software.



It sounds like the FTDI adapter is recognized by Windows and the u-enter program but the FTDI adapter is not talking to the GPS. Since the LED is lighting on the GPS (should be a solid green) about the only other problem can be baud rate or RX/TX need to be swapped (assuming the GPS and/or the FTDI adapter are actually working and not defective).

This is what I see when I connect my NEO-6 V2.0 to u-center version 7.02:

Baud rate: 38,400
Comport: (Com 8, that';s where my FTDI adapter sits).

The status bar along the bottom shows:
COM8 38400 and the little plugs are blinking green.
u-blox 5
No file open
UBX
And two clock windows - the first one is the total time the GPS has been connected I think, the one on the far right is UTC (GMT) time.

If I unplug the GPS from the FTDI adapter the little COM8 icon goes dark and stops flashing green

I would go to the ';Receiver'; menu item and check ';autobauding'; in the dropdown list. My testing shows this works for the basic connection as well as upload/download. With ';autobauding'; checked it will find the correct setting for your GPS. If you';re still not getting a flashing green connection in the status bar try swapping the RX/TX connections. I don';t believe changing the baud rate in the windows properties box has any effect on the process by the way, I have never resorted to making any changes in there.

There';s also good info in this thread from Matt that could possibly shed some light on the issue.
http://www.multi-rotor.co.uk/index.php?topic=1177.0
The file in Matt';s thread is the one I uploaded to my GPS.

This probably isn';t much help but I thought at least I would let you know what the program looks like when it is actually connected.

Jim


Jim/KK1W

Gaza07

The Gps wont talk to the ftdi at 38400 untill after its flashed the default speed is 9600  ~~

Droidling

I had the exact same issue. Setting the baud rate fixed it for me.

If your not sure about the FTDI adapter or your wiring you could try doing a loopback test. 

Terry

drtuvoc

Quote from: Droidling on Wednesday,May 01, 2013, 06:55:05
I had the exact same issue. Setting the baud rate fixed it for me.

If your not sure about the FTDI adapter or your wiring you could try doing a loopback test. 

Terry


I ending up buying a new FTDI breakout adapter, that solved my problem immediately. Flashed my CN-02 in 4secs... Man i was dealing with this problem for a while, never thought that board was bad because windows and mac saw it...

optiplex

i flashed the config file, what does it give me ? is it suppose to improve something in the flight ? loiter ? something ?

Jumpy07

Optimises GPS, ups refresh rate, speeds up Lock and minimises overhead on FC as sentences are reduced.
BNUC-S Pilot with PfCo /PFAW.
UAQ / CAA PfCo Instructor / Flight Assessor

"All that is necessary for the triumph of evil is that good men do nothing"

rokit5

Hey Craig.
I';ve flashed a gps module but wanted to flash it back to be used as it was originally, I remember trying to log the original firmware but it came back with errors so I just flashed it with the 3DR anyway. Do you know where I can get the default firmware from or what should I google?
"If at first you don't succeed, skydiving is not for you"

QuadBod

It';s a config file rather than firmware. Reset instructions are at the bottom of the first post here: http://www.multi-rotor.co.uk/index.php?topic=1177.0

motofox

hi, is this new config file worth it for a neo 6m, i mean is there actually any noticeable difference ? ive got a old fy31ap ftdi cable i think,,, will that work to upload the file?

cheers

martin

jasdall

Hi all. Need some help on my GPS. Gps used on my arduflyer 2.5 is not getting gps fix. Today managed to connect with the ublox center and uploaded the 3dr .txt file. Am I suppose to get some sort of graph or amount of satelites locked? Atm I am trying it inside but earlier after the firmware has been done I connected the GPS back to my apm 2.5 and still waited for more than 5 minutes outside in a wide open area where usually manage to lock 9 stats and today no gps lock. Anyone can help pls?

HowDoIfly

Quote from: jasdall on Sunday,February 16, 2014, 20:09:56
Hi all. Need some help on my GPS. Gps used on my arduflyer 2.5 is not getting gps fix. Today managed to connect with the ublox center and uploaded the 3dr .txt file. Am I suppose to get some sort of graph or amount of satelites locked? Atm I am trying it inside but earlier after the firmware has been done I connected the GPS back to my apm 2.5 and still waited for more than 5 minutes outside in a wide open area where usually manage to lock 9 stats and today no gps lock. Anyone can help pls?


replied in other thread
Ifly4 no more, Hubsan X4, R550v2, X650F-V4

ther0x

Hi Guys

I have bought a CRIUS (v3.1) UBlox NEO 6m GPS but I have a lot of problems
My quad, often, fly away when I use GPS modes (loiter and so on..)

Is there a right configuration for it? I have leaved it with original setup...

PS I use MegaPirateNG 3.1.5r2 on a crius v2

Thanks!


N.B. I forgot, number of GPS (11) and hdop (< 2) are ok...