Welcome to Multi-Rotor UK. Please login or sign up.

Monday,February 17, 2020, 16:32:50

Login with username, password and session length

Shoutbox

Andy777:
14 Feb 2020 16:14:59
Hi there. Im new. Having problems with my tarot landing gear. Its plugged into ch7 on futaba receiver. When i flick switch on transmitter i can hear a faint click on both legs but no movement. My flight controller is a mini px4 with no aux out terminals.
sh0wtime:
09 Feb 2020 16:57:32
and another :smiley:
Gaza07:
09 Feb 2020 10:22:04
Time for a new shoutbox post   ;)
Rares Gosav:
17 Jan 2020 17:44:22
Hi guys and happy new year!!!
ched:
01 Jan 2020 00:12:50
Happy new year everyone, happy flying.  :beer2: :beer2:
Gaza07:
31 Dec 2019 17:06:13
Happy new year all hope 2020 is a cracking year for you  :beer2:
ched:
25 Dec 2019 00:00:49
Happy Christmas to everyone.
apollo7:
24 Dec 2019 13:50:56
Seasons greetings to all on this forum have a good one ;)
ched:
21 Dec 2019 17:58:42
Have a great time DB. Look forward your projects in 2020.  :beer2:
hoverfly:
21 Dec 2019 16:59:17
Have a good one D.B. ~~ :beer2: :beer2: :beer2:
Members
Stats
  • Total Posts: 197687
  • Total Topics: 19953
  • Online Today: 48
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 1
Guests: 32
Total: 33

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

Hubsan X4 drifting gyro?

Started by HowDoIfly, Saturday,April 05, 2014, 14:15:28

Previous topic - Next topic

HowDoIfly

My X4 seems to lose it';s senses while I';m flying. It';ll start off perfectly level but over the duration of the flight, it begins to need right roll (and sometimes back pitch) corrections more and more until I';m at full stick deflection just to keep it hovering in one spot.

When I swap batteries, all seems right again but within a minute or so the drifting gets progressively worse again. Rinse and repeat.

I';ve tried recalibrating both the controller and the quad multiple times. I';ve physically checked the frame and motors and props etc but as it';s a gradual and increasing loss of level over the duration of one charge cycle, I can only assume it';s the controller going off-spec or something? I dunno, it';s putting me off using it.

I';ve tried adding trim but it';s impossible to counter as it just drifts more.  :shrug:

Suggestions welcome.
Ifly4 no more, Hubsan X4, R550v2, X650F-V4

Biffa

Steve

HowDoIfly

Saturday,April 05, 2014, 16:38:04 #2 Last Edit: Saturday,April 05, 2014, 16:57:50 by HowDoIfly
Quote from: Biffa on Saturday,April 05, 2014, 15:13:48
New batteries ~~


New AAA';s in TX and I got three lipo';s that all give same behaviour. I';ve even tried calibrating gyro';s with card under right side and it still drifts right.
Ifly4 no more, Hubsan X4, R550v2, X650F-V4

Biffa

I meant new LiPo packs. I know the smaller helicopters suffer from gyro drift as the packs fail.
Steve

HowDoIfly

Ok, thanks Steve. Bit disappointed if all three lipo';s are failing, but they';re cheap enough I guess.

Make some changes yesterday and initial hover was improved, need to test fly it longer though to be sure.
Ifly4 no more, Hubsan X4, R550v2, X650F-V4

HowDoIfly

New lipo arrived today. Fully charged it and did sitck level calibration before trying to fly. The problem remains. With just throttle up the quad starts off ok but begins to progressively drift right as it reaches waist height (from floor) and by the time it';s three feet to my right full left stick deflection (in normal mode) almost brings it to a hover but not quite so I landed and put the kettle on.

Ifly4 no more, Hubsan X4, R550v2, X650F-V4

jomk63

HowDo, mine did the same - and even went in different directions each time I changed battery  :embarrassed

I ';fixed'; it by adjusting trim on the Tx each time.  Take off and see which way it';s drifting, land it and adjust opposite trim.  Repeat a couple of times, then it will take off completely vertically. Well, it works for me.

Totally screwed my brain though when I moved to the F450 and didnt need to touch the trim on the Tx  :hmm:

good luck.

HowDoIfly

When the problem originally manifested trim was my first "fix" but that soon shone light on this being a progressive problem. ie, fresh lipo and it will be off by the trim added. At some point it will progress to hover but soon drift off the opposite direction. It';s weird.
Ifly4 no more, Hubsan X4, R550v2, X650F-V4

quadfather

FWIW, all my X4s do that.  I have given up on fine trimming.  By the time I had it perfect the lipo was dead.  Replaced with a fresh one and I had to start all over again.

I also noticed that flying it indoors amplifies the problem.  It seems to be very susceptible to its own downwash.
-rw-rw-rw-  -  The Number of the Beast

HowDoIfly

I';ve been prompted to consider a "lazy" motor as the cause. I had gotten used to these little motors putting up with abuse (tangled hair and grass and dust ingress) and soldiering on admirably after a clean out but as this one happens to be the right rear (the direction of unwanted drift) it';s worth changing. Not sure I';ve got a spare but I';ll post back results when it';s changed. Now, where';s my microscope....
Ifly4 no more, Hubsan X4, R550v2, X650F-V4

HowDoIfly

Motor replaced and it';s better. It still drifts though not as bad. More work needed but feel I';m on the way to a fix.  ~~ More soon.
Ifly4 no more, Hubsan X4, R550v2, X650F-V4