Welcome to Multi-Rotor UK. Please login or sign up.

Tuesday,August 20, 2019, 21:11:59

Login with username, password and session length

Shoutbox

Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Gaza07:
09 Jul 2019 18:10:30
Hope you all have a great day  :beer2:
Andy7:
09 Jul 2019 14:05:28
BFU#8 details locked in for this saturday - see the head of the forum thread for all details.
hoverfly:
05 Jul 2019 21:51:05
Good for genital warts as well......or so I'm told.. :hmm
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196558
  • Total Topics: 19801
  • Online Today: 46
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 1
Guests: 42
Total: 43

Theme Changer





3d - Printworx

Printing 3d Forum

CRIUS AIOP v2 setup + MPNG 2.8R3 + MP 1.2.46 : NO CLI / LEDS / BUZZER

Started by Phil1970, Sunday,September 08, 2013, 12:02:13

Previous topic - Next topic

Phil1970

Hi everyone,

For two weeks have I been struggling with COPTER_LEDS, without succes. I tried different versions of MPNG, 2.9.1R8 gave me the motor rev-up twitch (known problem). So I reverted back to the last known stable version, 2.8R3.

Please note that in order to succesfully upload 2.8R3 to the AIOPv2 you must not use Ardupilot-Arduino 1.0.3 or higher. That would fail and return a long list of errors. For some reason, 2.8R3 can only be uploaded while using Arduino 1.0.1.. I got just one problem, CLI (terminal) in MP doesn';t return the version number and unable to enter setup in terminal. All the rest works, radio calibration, pids, etc...   I did';nt have this when using MPNG 2.9.6.

If someone has a solution for this, please let me know. My current version of MP is 1.2.46

So yes, I finetuned APM_Config.h for the V2, baro and gps following GAZA';s guide. So far so good. I even got the copter leds working (partially....). I followed LAKIS instructions and got green and red leds flashing after booting the AOIPv2, but when my hexa has gps lock, green leds go out. Also when I arm the hexa, red leds go out.

If someone would be so kind to review my coding, I';d apreciate it. Here it is: http://www.easycash.be/files/ArduCopter.zip

For the record, this is how I did my LEDS: two left arms: reds leds, two right arms green leds.
All the positive terminals of the (4strips) 12V leds are on the positive terminal of a 3S lipo
The negative terminals of the green leds are on port 17 of a ULN2803A
The negative terminals of the red leds are on port 18 of the same ULN2803A
Port 1 of the ULN2803A go to analogue pin A5 of the AIOPv2
Port 2 of the ULN2803A go to analogue pin A4 of the AIOPv2
ULN2803A goes to negative terminal of the 3S lipo.

I got an arduino buzzer from HK (3 wires); the negative wire is on the negative pin of a spare motor pinout
The positive and signal wire are together on the AIOPv2 analogue wire A6.

Copter_leds are enabled and I put ';127'; in MP.

I have a feeling I am so close to a working led config,  but with my nose on it, I maybe missing something...

sevet

http://www.rcgroups.com/forums/showpost.php?p=24469344&postcount=5309

Negative of battery goes to ULN 9  (you probably have this)
Also, some configuration need to be made,

I almost got it working on MPNG 3.0.1-R2, GPS and ARM leds work, couldn';t get buzzer working.... yet...

Phil1970

I am currently on MPNG 3.0.1 R1. I read that Sir Alex is working on the copter_leds and this issue will be fixed with 3.0.1-R3. Maybe I should wait. But if you have a working code for R1 or R2, I am willing to give it a try.

Of course, this is a community effort, so thanks and respect to all contributors and testers of the MPNG project.