Welcome to Multi-Rotor UK. Please login or sign up.

Thursday,August 22, 2019, 14:10:46

Login with username, password and session length

Shoutbox

Andy7:
22 Aug 2019 10:27:36
Sure. But basically, all the subjects are getting cut off.
Gaza07:
21 Aug 2019 18:14:54
Can you pm me a screen shot of what you mean
Andy7:
21 Aug 2019 12:15:41
Gaza - can you make the subject line section in the forum topic list wider? It's cutting off the subject field really short.
Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196576
  • Total Topics: 19804
  • Online Today: 44
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 1
Guests: 33
Total: 34

Theme Changer





3d - Printworx

Printing 3d Forum

A Naza Fly away.... Or was it?

Started by SimonS, Saturday,September 07, 2013, 19:36:18

Previous topic - Next topic

SimonS

I';ve been using 3.14 on my Naza v2 for a while and was happy with it but the arrival of the BTU required a change to 3.16.  Friday the QAV540G was flown with the BTU and very nice it is to.  It certainly makes changing parameters simpler with no need to land between changes.  (I';ll put up a full review soon).

Today I was trying to get rid of an annoying vibration on the gimbal.  As part of this I was putting the quad up to about 100ft and while in the hover, slowly rotating on the spot.  I found that after about 270degrees the quad would stop and sit on the current heading.  A dab more rudder would see it jerk further around the panorama.
I wondered if this was a control issue as I was directly under the quad and possibly no getting the best signal up to the quad.  I bought the quad down to about 25ft and off to the side of me and tried again and got the same result - 270degrees of yaw and then holding the heading.  Again, a dab more rudder moved it on again but I had lost the smooth panorama that I was after. The telemetry told me that it was time to think about landing so I had time to try it once more.  Round it went and again sat on the heading. This time I kept the stick in the same position to see what it would do.  After a couple of seconds it started to climb!  That was not in the script.  By now the Telemetry was telling me that I ought to be on the ground already and the quad was slowly climbing away.  No response to stick inputs.  No response to switching to ATTI. No response to RTH. Not even a response to the ';disarm motors'; command.  Bugger!!!

I tried the RTH again and it seemed to work.  The quad started to come back.  Great.  Put the RTH switch back to normal, switch GPS/ATTI/GPS and control is bac... not back!  By now it was obvious that it was either stuck in RTH or the battery was about empty as it had started descending but towards a tree.  A last attempt at GPS/ATTI/Manual and I managed to get control and steer it away from the tree and into a bush.  Fortunately there was no damage so It was time to review the flight and see what happened.

Having sat and thought thing through and consulted the Naza Manual (again) I have realised that the fault lies with the organic lump attached to the transmitter sticks.  Me!  The Naza did exactly what it was set up to do.

One of the new features of the Naza v2 is ';Receiver Advanced Protection';. I quote:-

If you choose enable it, the FailSafe will be triggered if the following situations occur during flight.

According to the difference of the aircraft height, there are two situations.

a) Lower than 100m, the A/E/R channel is not at the mid point.
b) Higher than 100m, the A/E/R channel is not at the mid point or the throttle stick is above the mid point.

In the GPS Mode or ATTI. Mode, if the requirement a) or b) is satisfied, and the output data of four channels
A/E/R/T have not changed for 20 seconds, then the aircraft will hover automatically. After that, if the output data
of four channels A/E/R/T still do not any changes and last for 10 seconds, the autopilot system will think that the
data from receiver is abnormal, and then enter the FailSafe Mode.

Brief introduction of how to quit the FailSafe Mode

If there is any command change from the receiver, the autopilot system thinks that the receiver is regained. In ATTI.
Mode and Manual Mode, it will quit the FailSafe Mode automatically. In GPS Mode, please toggle the control mode
switch to the ATTI. Mode and Manual Mode position to regain the control. Refer to the FailSafe section for more details.
(Page 20 in the current manual)

So, a slow spin in the hover was taking about 20 seconds to do 270 degrees.  On all but the last occaision I did something else with the sticks within 10 seconds.  On the last occasion I did not so it went into Failsafe.  The standard RTH failsafe only requires switching between GPS and ATTI to regain control.  In this case you must switch GPS to ATTI & to Manual to gain control.

If you have a Naza-M or v2 and have set your 3 position switch to GPS/ATTI/RTH then do not enable Receiver Advanced Protectionas if you invoke it, you will not be able to regain control.

flybywire

Useful post Simon.
I had read that bit myself, and as I';ve set my switches as you have GPS-atti/Atti/RTH was concerned that I would not be able to disengage autopilot if the need arose.  I';ll disable that feature, as I don';t really need it anyhow, I just saw it as a belt & brace feature and left it ';ticked';.  If my controller loses radio contact RTH is activated anyhow, that';s all I need.
Thanks again for the heads up, glad you made a safe landing!
I';ll change it tonight, as I need to change the distance limit to something stupid until they fix the possible issue with v 4.
:beer2:
Edit: DJI instructions do need some ';picking'; through, and several re-reads before the proverbial pennies start dropping do they not?
Andy
Blog: http://ajwillis303.wix.com/stuff
The spiritual home of fpv large
Keep it emax, capiche?
Hardware? sure, I got hardware!

dazza22

not sure if you all have seen this video or are aware of the issues .But thought I post it  .  https://www.youtube.com/watch?v=n3icOejm62k.
it looks like this quad as some very serious firmware issues , that maybe related to your problems

cheers darren

flybywire

Quote from: dazza22 on Wednesday,September 18, 2013, 08:54:37
not sure if you all have seen this video or are aware of the issues .But thought I post it  .  https://www.youtube.com/watch?v=n3icOejm62k.
it looks like this quad as some very serious firmware issues , that maybe related to your problems

cheers darren


No, they';re not related, as Simon said in his post, it was just doing what it should have under the circumstances.
The guy in the clip is a grade ';A'; plonker, who doesn';t read his release notes!  :slap:
Blog: http://ajwillis303.wix.com/stuff
The spiritual home of fpv large
Keep it emax, capiche?
Hardware? sure, I got hardware!

SimonS

It is sort of related.  With the Phantom the 3 position switch is set as standard to GPS/ATTI/ATTI.  You can change that in the Assistant to GPS/ATTI/RTH or GPS/ATTI/MAN.

The RTH is still supposed to work independently of the Flight limits.  Flight limits do not work in Manual.  I suspect that he either still had the switch set to GPS/ATTI/ATTI or GPS/ATTI/RTH and somehow the bug affected the RTH too.

I would suggest that anyone with a Phantom sets the switch to GPS/ATTI/MAN and invokes RTH if required by turning off the tx.

powerlord

Rthevproblem with that is the quite long delay before it kicks in though.  That could be too long depending on the reason.  Personally I';d drop atti.  I never use it on my naza - what';s the point? Gps,  manual,  rtl is a better setup IMHO.

Sent from my HTC One using Tapatalk 4


Gearymeister

Thats what happened to me a couple of weeks ago. I panicked and tried everything notvhaving a clue what to do. Ended up lowering the throttle to 0, flicked the switches, then the quad just fell out of the sky smashing the arms.

After this I figured that it must have regained control in manual amd because throttle was set to 0 the motors just cut out.

Wish I had seen your post weeks ago.
Thanks
I started off with nothing... I still have most of it left.

XH558

The original post is what forums are all about .... topping post ...both helpful and thought provoking  ~~