Welcome to Multi-Rotor UK. Please login or sign up.

Tuesday,August 20, 2019, 09:08:55

Login with username, password and session length

Shoutbox

Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Gaza07:
09 Jul 2019 18:10:30
Hope you all have a great day  :beer2:
Andy7:
09 Jul 2019 14:05:28
BFU#8 details locked in for this saturday - see the head of the forum thread for all details.
hoverfly:
05 Jul 2019 21:51:05
Good for genital warts as well......or so I'm told.. :hmm
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196558
  • Total Topics: 19801
  • Online Today: 39
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 30
Total: 30

Theme Changer





3d - Printworx

Printing 3d Forum

problem setting up Naza M Lite with Turnigy 9x Radio - RX-ERROR

Started by raymondkerr, Friday,September 06, 2013, 17:54:05

Previous topic - Next topic

raymondkerr

I am new to multi rotors and this is the first upgrade to my basic F450. It came setup with a cheap i86 FC which I have swapped out for a Naza M Lite. The 9x Turnigy radio was setup on model 1 with the Throttle and Rudder channels reversed. Every other setting on the radio was standard. when connect the naza to the computer and loading the assistant software, I get a flashing red RX-ERROR at the bottom of the screen. My radio is PPM, but I have also tried traditional and I know that it isn';t S-BUS. all it tells me on the help, that there is a problem with communication from the receiver to the radio. ??

The radio and quad flew fine before. I have updated the firmware on the assistant software, still says version 1.0, and I';m using the latest software too. I do get some stick movement feedback on the software so there is some sort of link/communication but its not letting me calibrate ? I tried a new model memory on the radio without much success, and I have removed and replugged all the servo leads from the naza to the turnigy 9x8C receiver. It is just a standard (stock) 9x radio, not a firmware updated one.

Don';t know where else to turn to for help.  :(

Raymond

TBS Discovery - Naza M Lite
GoPRO Hero 3 Silver Edition
ImmersionRC Tx with Fatshark Attitude
FrSky Taranis
http://www.youtube.com/user/macmondo74/videos

Jumpy07

Ok, your RX needs to be setup for traditional channels, and you need a cable for each channel from your RX to the Naza .. as below.



Your TX should be setup for a plane..

Check that first and report back..   pop in to chat and someone will help
BNUC-S Pilot with PfCo /PFAW.
UAQ / CAA PfCo Instructor / Flight Assessor

"All that is necessary for the triumph of evil is that good men do nothing"

raymondkerr

TBS Discovery - Naza M Lite
GoPRO Hero 3 Silver Edition
ImmersionRC Tx with Fatshark Attitude
FrSky Taranis
http://www.youtube.com/user/macmondo74/videos

raymondkerr

Tried the cable layout as above and checked that my radio is in aeroplane mode which it is on PPM, still getting the RX-ERROR, tried both traditional and PPM settings.

The firmware update worked but it still tells me it is version 1.0 same as before ?

Raymond.

TBS Discovery - Naza M Lite
GoPRO Hero 3 Silver Edition
ImmersionRC Tx with Fatshark Attitude
FrSky Taranis
http://www.youtube.com/user/macmondo74/videos

Jumpy07

BNUC-S Pilot with PfCo /PFAW.
UAQ / CAA PfCo Instructor / Flight Assessor

"All that is necessary for the triumph of evil is that good men do nothing"

Smeagol

Are the leads into the naza correctly orientated, mine were upside down until some kind soul pointed me in the right direction.


raymondkerr

I have checked the binding and it is working fine, I have plugged the leads in with the black/brown negative lead furtherest away from the notch which is signal and centre is positive.

I think it is something to do with the radio.  I only have an online manual for the Turnigy 9x which isn';t really that helpful.  I have selected a new model memory on the radio so that I can be sure none of the previous FC settings are causing problems.  When I do manage to get it to recognise with the software in traditional mode, all the channels appear to be  mixed up, I have even tried reversing channels.  it would appear that my throttle is on the righthand stick which would suggest the radio is in mode 1 and not mode 2, but I can';t see how to change this within the settings.  The radio was setup and worked fine for my hobbywing i86 controller and it is defo a mode 2 (throttle lefthand) radio.

confused.com   :cry
TBS Discovery - Naza M Lite
GoPRO Hero 3 Silver Edition
ImmersionRC Tx with Fatshark Attitude
FrSky Taranis
http://www.youtube.com/user/macmondo74/videos