Welcome to Multi-Rotor UK. Please login or sign up.

Monday,August 19, 2019, 07:12:30

Login with username, password and session length

Shoutbox

DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Gaza07:
09 Jul 2019 18:10:30
Hope you all have a great day  :beer2:
Andy7:
09 Jul 2019 14:05:28
BFU#8 details locked in for this saturday - see the head of the forum thread for all details.
hoverfly:
05 Jul 2019 21:51:05
Good for genital warts as well......or so I'm told.. :hmm
DarkButterfly:
05 Jul 2019 21:48:24
Just fixed a busted SMA connector on my TBS unity pigtail, it suffered badly in a recent crash and split in two, nothing a touch of the soldering iron couldn't fix  :D
Members
Stats
  • Total Posts: 196550
  • Total Topics: 19800
  • Online Today: 44
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 5
Guests: 48
Total: 53

Theme Changer





3d - Printworx

Printing 3d Forum

Crius V2 Weird flashing sequence on "A" + "B" lights

Started by charosenz, Monday,September 02, 2013, 20:45:51

Previous topic - Next topic

charosenz

Monday,September 02, 2013, 20:45:51 Last Edit: Monday,September 02, 2013, 21:13:16 by charosenz
Flashing A+B lights odd sequence

I am using a Crius V2 board, MPNG 2.8R3 and MP 1.2.73 and Arduino 1.0.5 with a 450mm quad.....

I am not getting any response from the radio. It will not arm and I am seeing an odd sequence where the "A" light flashes red about 16 times, then the "A+B flash alternately 6 or 7 times then back to the "A" light flashing about 16 times.

I would appreciate some help.

Even thought the receiver is bound, it will not cause any motors to operate.  I thought it might be an ESC issue, but they all operate fine when I connect them directly to the receiver.

I am getting a good solid lock on the 3dr radio, but the GPS green light is not on anymore.

I have recompiled and reflashed with the MPNG firmware 3 times and no change.

I';m stuck.....needing some help.

Thanks.

Gaza07

Hi charosenz have you calibrated your radio n the planer ? if you have no response in the planner with your radio you will probably have to go for a older version of the planner that is more compatible to your firmware  ~~

charosenz

Gaza,

I have not tried going back a few versions on MP but I will definitely try that.    Thank you for the suggestion and for a great manual you produced - I have read it many times.....

charosenz

Gaza,

I reverted back to 1.2.55 MP and I now have full control over the motors.   Yea!

Bad news is that I still have not regained my GPS, and the Google earth photo disappeared and now there is a 404 warning saying there is no map at this zoom level, but it stays there no matter what zoom level I choose.  I suspect this will resolve when the GPS is back.

I had used NONE on the config.h in the past successfully, but then I had to change it to UBLOX.   (I am using a UBLOX CN-06).   I may change it back to NONE just to see if that fixes the GPS signal issue.    I may even have a loose wire with all that testing.....

Gaza07

Hi charosenz pleased to hear you got it going  ~~ right as for the gps on the CN-06 v1 and v2 you should be set for ublox in the config file, the green led is power only and doesnt show if you have a fix, if your green led is not lit your gps is either not powered or dead, check the power to the gps if you cant find a problem you may need a new one, how are you powering our board ?  :beer2:

charosenz

Gaza,

I have a 5v UBEC going to the +/- (#6 and #7) pins.  I have the jumper (JP1?)  removed.  There is power coming from the ESC to the 3 pin motor power row.  I am using a power (+/-) from that row (motor pins) to power the receiver (with an iron core on it). 

I am hoping to find a loose Tx or Rx wire from my GPS antenna.  But.....would that cause the Green "C" light on the board not to light?

Also, I have not been able to perform the Accel calibratoin.  It just states the baro is calibrated and does nothing more????  I think it also fashes with something like "ground start"....

Gaza07

The Rx / Tx wires on the Cn-06 shouldnt affect the green led at all its power only I';m afraid,
are you calibrating your Acc in the CLI ? because the acc calibrate button doesnt work right with megapirate,

Incase you dont know here is what you need to do

click the terminal button
you should then enter the CLI (command line interface)
at the prompt type setup then hit enter
the prompt should now be setup
type level and hit enter this should then calibrate your acc make sure your copter is level and still

hope this helps

charosenz

Gaza,

WOW, I did not know that the accel calibration in MP doesnot work with MPNG....I did the CLI Setup and level and I think it worked fine.  It gives a "G" and an "A" value. I will add a screen shot, would you please tell me what these mean?

Also, is there any way to learn what parts of MP are not functional with MPNG?

I know in the "Initial Seup" there is a firmware tab.  Sometimes this launches an install automatically and I am not sure if this is a problem or not.

I am also not real clear on the 3dr tab, but I do load and save this and it seems to work.  There is an additional "Install firmware on this page next to the "Save" button and I am not sure if this "install firmware" serves the same purpose as the install firmware tab on the left just above the 3dr tab.   I hope this makes sense to you and I hate to trouble you but I am really looking for help.   I believe I am very close to a successful install and I am willing to persevere to get it done - and thanks to many people like yourself for helping...


charosenz

For the record, I did find a loose connector pin in my GPS wiring.   GPS is back and 100%.    My accel seems to be performing great.  I still would like to know what those "G" and "A" values really mean in the CLI after using the LEVEL command,  but I guess it is not important if the machine is stable.   Sure appreciate all the help.

As far as the original weird flashing "A" and "B" lights, I believe it was an incompatibility between the MP version and the MPNG versions.   Although I am back at MPNG 2.8R3 and the current MP 1.2.74  so go figure.   I plan to move up in MPNG soon but I want to get all the set up issues resolved first.   Not sure if that really makes sense, but just a gut feeling.   

The help I have received on this group has been great.

Good flying to all.