Welcome to Multi-Rotor UK. Please login or sign up.

Tuesday,August 20, 2019, 21:12:32

Login with username, password and session length

Shoutbox

Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Gaza07:
09 Jul 2019 18:10:30
Hope you all have a great day  :beer2:
Andy7:
09 Jul 2019 14:05:28
BFU#8 details locked in for this saturday - see the head of the forum thread for all details.
hoverfly:
05 Jul 2019 21:51:05
Good for genital warts as well......or so I'm told.. :hmm
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196558
  • Total Topics: 19801
  • Online Today: 46
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 1
Guests: 40
Total: 41

Theme Changer





3d - Printworx

Printing 3d Forum

RTL not working - help!!!

Started by DarrellW, Sunday,July 21, 2013, 18:11:20

Previous topic - Next topic

DarrellW

The past few times I';ve tried to use the RTL my quad has climbed and then gone anywhere but where it should have gone resulting in 1 crash that broke an arm, one that ended up in a big patch of brambles fortunately unharmed (more than I can say for me!) and finally one today where I was ready for it so quickly flicked switch off and got it back on the right course.
I';ve tried re-routing the wiring so it';s not too close to any other wires, let it find the satellites for a good 5 mins before I tried to fly it but still no joy. I am still on 2.8 firmware but didn';t have this problem until about a month ago, anyone got any ideas  :shrug:  :frantic:  :help:
I think..........I think I am........therefore I am.............I think!

kilby

Would suggest hooking it up to a computer and leaving it running for a while to see if it loses the signals after being switched on for a while

If its one of the newer ublox models could the antenna be suffering disconnects?
Not much kit, but what I have I like
Armattan Tilt 2, Morphite 180, Quark 150, Decapitated NanoQX
Taranis+

DarrellW

Having spoken to Peter King last night (who built my quad) it looks likely that the magnetometer has lost calibration so I am now going to upgrade my firmware from 2.7 to 2.9 add ons and recalibrate the magnetometer. I am also going to rebuild it putting the FC on the top plate as he has suggested rather than in the middle - so watch this space!
I will report my findings in case anyone else has the same problems in the future.
I think..........I think I am........therefore I am.............I think!

DarrellW

Moved my FC onto the top plate tonight but got interrupted by a knock at the door - delivery of another new toy as it happens; lost my train of thought and forgot the exact location of the last terminal to go on the board.
See pic below, is this correct or should it be one pin to the right?
I think..........I think I am........therefore I am.............I think!

firey1

the two yellow pins at end are for your 5v into board
and assume the cable you have plugged on one of the pins is from your receiver it shouldnt be on the yellow pin but back one 
MIKE

550 RC Spider quad for FPV
550 Alien quad (my sons now)
F450 quad
450 size bell 212, MD500,Augusta 109
600 size Huey running apm 2.5  3 planes  Taranis and 9xr  radios Skyzone FPV goggles

DarrellW

Tuesday,July 23, 2013, 22:31:47 #5 Last Edit: Tuesday,July 23, 2013, 22:36:12 by DarrellW
Quote from: firey1 on Tuesday,July 23, 2013, 21:31:48
the two yellow pins at end are for your 5v into board
and assume the cable you have plugged on one of the pins is from your receiver it shouldnt be on the yellow pin but back one

The cable plugged into the two yellow pins is from one of the esc';s and is split black/red as in picture and white into the group of terminals the rest of the esc';s go to, but one of that group has all three wires in the plug the other two have the red wire cut short and not connected. The overhead view shows that it is in line with AIO Pro on the board. The plugs to the right of it are the receiver plugs.
I think..........I think I am........therefore I am.............I think!

firey1

Sorry was hard to tell by picture but closer look it seems that you have it right
the positive and negative to yellow pins third is empty just make sure you have the pos / neg right way round lol

also i see that the cut red is exposed would pay to cover it incase it finds its way to the board
if one set of esc has all 3 wires connected to board and your powering through the yellow pins  make sure the  jumper 1  is removed otherwise you will fry the board
MIKE

550 RC Spider quad for FPV
550 Alien quad (my sons now)
F450 quad
450 size bell 212, MD500,Augusta 109
600 size Huey running apm 2.5  3 planes  Taranis and 9xr  radios Skyzone FPV goggles

DarrellW

Thanks, that';s all I needed to know all I have to do now is load 2.9 add ons and set it all up again, done the complete rebuild tonight including fitting new dji arms and I';m now having the battery underslung instead of on the top, should make it more stable I hope!
I think..........I think I am........therefore I am.............I think!

DarrellW

Just to check thins were correct I plugged a battery in last night and fired it up - no magic smoke  ~~ armed it and ran the motors - all is good  :beer2: firey 1 for your help; next thing to do is the firmware upgrade etc.  :cool:
I think..........I think I am........therefore I am.............I think!

firey1

what firmware are you going to load Darrell
MIKE

550 RC Spider quad for FPV
550 Alien quad (my sons now)
F450 quad
450 size bell 212, MD500,Augusta 109
600 size Huey running apm 2.5  3 planes  Taranis and 9xr  radios Skyzone FPV goggles

DarrellW

Wednesday,July 24, 2013, 07:18:22 #10 Last Edit: Wednesday,July 24, 2013, 07:21:24 by DarrellW
Quote from: firey1 on Wednesday,July 24, 2013, 07:14:41
what firmware are you going to load Darrell

I';m loading 2.9 add ons from Peter Kings website along with his config file, watched his video of how to do it all and think it looks pretty straight forward.
When I calibrate the magnetometer I am going to run the motors while I';m doing it, I think I should get a better result that will take into account any effects of interference from the motors.
The only other thing I';m thinking about is relocating the GPS sensor - at the moment it';s sitting on one of the arms directly above an esc so I';m wondering about making a bracket for it to raise it a couple of cms and also protecting it with some heat shrink.
I think..........I think I am........therefore I am.............I think!

firey1

i made a gps stand out of some carbon rod and 4 arm servo arms
MIKE

550 RC Spider quad for FPV
550 Alien quad (my sons now)
F450 quad
450 size bell 212, MD500,Augusta 109
600 size Huey running apm 2.5  3 planes  Taranis and 9xr  radios Skyzone FPV goggles

DarrellW

Very happy bunny, upgrades done and test flight done - fanbloodytastic!!!
Everything feels so much more stable and locked in even though it was a bit windy for me to be flying a maiden.
Special thanks to Fiery 1 for help when it was needed, absolutely over the moon - next job to make a mount for the gps sensor and build my new flying wing (a Mini bee) but with a nice brushless motor instead of the brushed can motor that came with it!
I think..........I think I am........therefore I am.............I think!

DarrellW

Just a few pics of the rebuild - specially for barneyg
Now need to find a cover for the FC, hmm tuperware.......
I think..........I think I am........therefore I am.............I think!

barneyg

is that a 450 or 550 sized landing gear ?

DarrellW

It';s the 500/550 TRex landing gear, cost me £8 from lms - much better for landing on grass strips with the extra ground clearance!
I think..........I think I am........therefore I am.............I think!

firey1

they sure do make good landing skids nice and solid no flexing on a hard landing
im running 600 size had a spare set from my huey build
MIKE

550 RC Spider quad for FPV
550 Alien quad (my sons now)
F450 quad
450 size bell 212, MD500,Augusta 109
600 size Huey running apm 2.5  3 planes  Taranis and 9xr  radios Skyzone FPV goggles

DarrellW

Just out of interest, what I';ve done with the red wires from the esc';s that have been cut off is just applied a small bead of hot melt glue to the very end so they are now insulated, nice and simple!
I think..........I think I am........therefore I am.............I think!

DarrellW

This will be my final post on this thread unless anyone has any questions.
Here is what my 450 Flamewheel looks like now - now has  bonnet improvised of course, it';s part of a disposable fruit desert dish!
I think..........I think I am........therefore I am.............I think!