Welcome to Multi-Rotor UK. Please login or sign up.

Monday,August 19, 2019, 10:36:20

Login with username, password and session length

Shoutbox

Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Gaza07:
09 Jul 2019 18:10:30
Hope you all have a great day  :beer2:
Andy7:
09 Jul 2019 14:05:28
BFU#8 details locked in for this saturday - see the head of the forum thread for all details.
hoverfly:
05 Jul 2019 21:51:05
Good for genital warts as well......or so I'm told.. :hmm
Members
Stats
  • Total Posts: 196555
  • Total Topics: 19801
  • Online Today: 51
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 3
Guests: 35
Total: 38

Theme Changer





3d - Printworx

Printing 3d Forum

Crius aiop v2 Am I ready and baro problem

Started by Bking1340, Friday,July 19, 2013, 12:09:02

Previous topic - Next topic

Bking1340

Have posted this at rcgroups with no reply

Good day all

Okay I have managed to install software/firmware with arduino(megapirate) on my v2 board - Am going to leave the gps/bluetooth for later - Just want to see if my X quad will fly.

I struggled with esc calibration for 4 hours, seems like I moved the throttle stick too slow from 100% to 0% - fixed now

What I did so far: Uploaded megapirate using arduino with correct programming lines enabled/disabled, baro sensor, x quad, gps disabled etc.
In mission planner i did - rx/acc calibration, flight modes - which are just stabilization and acro mode for now. Compass calibration.

If I give right rudder - activates board, motors speed up in correct direction when throttle are increased. When I tilt the quad front/back/left/right, the opposite motors increase speed. The same goes with tx ail/elev input - correct motors increase speed.
Do you think I`m ready for a test flight?

One problem I see is that I dont get a altitude reading in mission planner - It just indicates 0.00. Is there maybe a way to activate the baro somewhere - I made sure that the correct baro are indicated in arduino software - If I move the quad around I can see the horizon changing correctly in mission planner and seems like compass are working, but no altitude reading. Am I missing something?

Thanks all

Jumpy07

 Note: normally you have to reverse ELE in Mission Planner..

Baro is always active ..  you should be able to see changes in the raw data from it in Mission Planner.. make sure you have a bit of foam over it... could be you haven';t edited the sketch properly to define the correct baro.. 



BNUC-S Pilot with PfCo /PFAW.
UAQ / CAA PfCo Instructor / Flight Assessor

"All that is necessary for the triumph of evil is that good men do nothing"

Bking1340

Yes when I spooled up and gave elev input my motors were not behaving correctly, so I reversed elev.
I left the sketch as is where you define the baro, as it seems like it was the correct one for my RCtimer Crius aiop v2 as per your .pdf guide (#define CONFIG_BARO AP_BARO_MS5611_I2C). Thanks by the way for that guide, it helped me a lot.
Is there maybe a way I can test if the baro is not faulty?

Jumpy07

Cheers, good to get some feedback..

If you connect the USB and fire up mission planner.. go into Command Line Interface... at the cursor type test hit return, then type altitude hit return.. this will display the baro readings  .. if you lift the multi up and down it should change.


BNUC-S Pilot with PfCo /PFAW.
UAQ / CAA PfCo Instructor / Flight Assessor

"All that is necessary for the triumph of evil is that good men do nothing"

Bking1340

Jumpy I tried that, but it did nothing. Think I have found my solution:
I have just deleted mission planner 1.2.60 mav 1.0 (1.2.55 asked me a few days earlier if I want to update to the latest version - I did) and installed 1.2.55 mav 1.0 and now my barometer and everything else are working perfectly.
Am I missing something in the latest 1.2.60 mav 1.0?


jivy43

Bking. I have the same issue. I too tried various versions of mission planner and the altitude did not show in the flight data. When I installed 1.2.55 the altitude was displayed but even at rest it was constantly changing, much like the gps was. So after reading Jumpy';s post I went to the cli (terminal) and ran test altitude. No data was displayed at all. I then ran test gps and I received a constant updating of data. I will sometime tonight run a test compass the verify that data. I know both the gps and compass works in the flight data display.
If you have run the cli test altitude and received data good. If you have not run the test I would do so just to confirm the baro works.

Gaza07

Its normal for the baro to vary even when sat on the floor  ~~

jivy43

Quote from: Gaza07 on Tuesday,August 27, 2013, 06:09:44
Its normal for the baro to vary even when sat on the floor  ~~


Glad the hear that. I did run the compass test in cli a received "unhealthy" scrolling very rapidly. I have not calibrated the compass, so the message is correct. It does show me that data is being received from the compass.

I still do not get data from the baro as I should. Will continue to find a solution.

jivy43

I finally verified my baro was working by disconnecting the gps and then checking the flight data in mission planner. Altitude values were displayed. Now I am trying to solve why no data is shown in the cli when I run test - altitude.

gvzb19

I had the same problem with the baro not working.  Just read zero for all the altitude readings.

The following sequence solved it for me - I have no idea why.

I tried to follow the CLI test procedure but the CLI seemed to freeze and report nothing.  It did not respond to <Enter>
I pressed "Connect APM" to reconnect
I typed "test" and then "gps" and go the expected "not healthy" message
When I hit <Enter> to exit the Mission Planner seemed to update the EEPROM and intialize iteslf and the now all is working!  See the log below.

The only problem is that when I go back to flght data in the MP the USB disconnects and when I press reconnect the altitude readings do no come through again.  It seems that the MP is not correctly initializing the AIO in the following way?

3Initialising APM...R
Q`';fQ
`';?3barometer calibration complete+
Ready to FLY QBQ



I will try to downgrade the MP to a previous version.

Here is the log:


not healthy
not healthy
not healthy
not healthy
not healthy
not

Init MegaPirateNG V2.8 R3

Free RAM: 1955
FW Ver: 120
----------------------------------------


Firmware change: erasing EEPROM...
done.

Press ENTER 3 times for CLI

3GROUND START?Init GyroQ`';?*QC^`';*Q.P`';PQ`';?IMU
----------------------------------------
G_off: 0.01, 0.01, -0.01
A_off: 0.00, 0.00, 0.00


3Initialising APM...R
Q`';fQ
`';?3barometer calibration complete+
Ready to FLY QBQ
Q@uQ~?Q?Q?Q?QQ-{Q?Q#?QQgMegaPirateNG V2.8 R3]
MegaPirateNG V2.8 R3] test
test] altitude
Hit Enter to exit.

Qp`';r3Initialising APM...{?QN `';.?3!barometer calibration completeA?alt: -21cm, pres: 98818mbar, temp: 311/100degC, raw pres: 8282790, raw temp: 8502030
alt: -17cm, pres: 98818mbar, temp: 311/100degC, raw pres: 8282786, raw temp: 8502043
alt: -13cm, pres: 98817mbar, temp: 311/100degC, raw pres: 8282740, raw temp: 8502136
alt: -8cm, pres: 98818mbar, temp: 311/100degC, raw pres: 8282739, raw temp: 8502186
alt: -2cm, pres: 98818mbar, temp: 311/100degC, raw pres: 8282721, raw temp: 8502219

Lars

Hi
I have the same problem.
It';s getting a little too many unresolved problems with this card. It is probably because I do not have enough knowledge of electronics and programming. It is simply too complicated to get all functions to work while independent of specific software. Leave the dying ship and look for another card.
Feels a little bitter to give up when I bought all the accessories and then you are forced to abandon the latest software.
I put CRIUS AIOP aside and retrieve it again in another project if it finds that there has been progress. :cry

/Lars

barneyg

Can I suggest trying Multi wii on this board rather than MegaPirate.  Not quite as fully featured in the Mission planner stakes but you can still do RTH and loiter with a GPS and I found it nicer to fly with for my quad.