Welcome to Multi-Rotor UK. Please login or sign up.

Tuesday,August 20, 2019, 08:07:43

Login with username, password and session length

Shoutbox

Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Gaza07:
09 Jul 2019 18:10:30
Hope you all have a great day  :beer2:
Andy7:
09 Jul 2019 14:05:28
BFU#8 details locked in for this saturday - see the head of the forum thread for all details.
hoverfly:
05 Jul 2019 21:51:05
Good for genital warts as well......or so I'm told.. :hmm
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196558
  • Total Topics: 19801
  • Online Today: 39
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 1
Guests: 35
Total: 36

Theme Changer





3d - Printworx

Printing 3d Forum

Struggling to get into calibration mode & arming motors

Started by Riggsbie, Sunday,June 23, 2013, 09:19:59

Previous topic - Next topic

Riggsbie

Guys,

Just finishing building my TBS Discovery.....

I am using my cheap Devil7 - Devo 7 RX/TX......it is frustratingly hard to get it into GPS calibration mode (Naza M v1 & GPS).....I have configured my 3 position switch (GPS-Atti-M) and I flick it 10 times and nothing much happens......just get the struggling to get GPS lock (indoors).....

I managed to get it into calibration mode once and did the rotating thingy and had a solid green light etc....

Also cannot get the motor to arm to figure out motor directions......nothing seems to work.....

I was under the impression the Naza M was supposed to be easy to setup, my APM 2.5 was a piece of cake to setup.....

Any suggestions anyone ?

Thanks

Paul

callaghan48

Hi,
Set the gps at height -10 in your software then try to calibrate, had the same problem last year,

Riggsbie

Thanks for the tip, I actually measured the height and set it at -12cm but will try -10cm......

SimonS

Which firmware are you running?  If it is v3.12 you have to wait for the triple flashing to stop and change to double flashes before the motors will arm. If you are getting continuous orange flashing then there is a problem either between Tx and Rx or Rx and Naza.

Riggsbie

Just been through all the updates for the firmware, so running the latest and greatest !

I can now get into calibration mode OK and have calibrated the compass, woo hoo !

The motors still do not want to arm......but will watch the for the green light sequence.......why is it so complex compared to APM ? It is rather annoying !

turkuss

Just a note I to had the failing to enter the calibration mode and tried the suggestion that Riggsbie gave and it worked a treat , Many thanks  ~~ just goes to show how good the sharing of knowledge and experience  is

Now that';s just one more thing to solve off my list . :banghead:
I'd rather have a full bottle in front of me than a full frontal labotamy

Riggsbie

Spent another hour last night but just cannot get the motors to arm.....

I had to walk away !

I wonder if there is a feature due to my crappy Walkera Devil 7 (Devo7) Tx ??

Any ideas anyone ? Just wondering if this is the kick I need to buy a new Tx/Rx just for the TBS Disco......

SimonS

What is the LED flashing when you are trying to arm? (Red/yellow/orange/green and number of flashes?)

rsmith21

Do you have servos that you can connect to the receiver just to see that the stick actions are sending the correct command.
KK2, NAZA M/V2 ugrade, Spektrum DX 8, Hubsan X4
Immersion 25Mw vtx, GoPro 4, Black Pearl Display
Walkera 2 axis gimbal

bunnygirl80

Hi Paul,

Sounds like its a problem with your travel. I would recommend that you connect your disco to your PC and launch NAZA Assistant and calibrate your transmitter making sure all the stick movements are moving the correct way. If not reverse in the assistant using the REV button on the TX monitor screen. Once you';ve done this you should be able to arm and disarm your disco. I would recommend you take outdoors where it can get a GPS lock as this is needed before arming with the new firmware. Wait about 3 minutes before you even try and then arm by pushing your left and right sticks down and inwards.

www.isojed.nl/blog/wp-content/uploads/2012/02/DJI-Naza-TxCali.jpg

Hope this helps.
Always smile because you never know who could be falling in love with it. :) Drone Operator in North Wales. www.aerialworx.co.uk

Riggsbie

I have calibrated the Tx in the assistant software on my pc, everything calibrated well....

My 3 position switches are set ok for GPS-Atti-Man and they go blue when flicked.....my other 3 position switch I have configured for home lock, headlock, ios....etc....

I did leave it outside and I had full GPS lock but will got through that process again.....

I';ll let you know what colours and patterns I get :-)

Thanks everyone !

ChrisH

Sounds much like the problem I';ve got with latest build. Travels are Ok as its same Tx as other model and looks fine in the Assistant. Left GPS off for now to avoid the indoor problem. Get the one or two amber flashes (depends where throttle is) but no arming. A bit if a problem as I have no idea yet which direction the motors are spinning!!

Ho hum. I';ll try the advanced IMU calibrate later as not done it yet on this FC and think I read that this can give probs.

:hmm:
Chris
Hubsan X4
DJI F450, Naza, GPS, DX8,
Tarot FY680 Naza, GPS, Hero3 Silver, 5.8 FPV with screen
 :england:

Riggsbie

Woo hoo.....

Just fired up the Disco.....

Right, first off got the red/yellow/green boot up sequence.

Then got 4 green flashes

Then a series of fast yellow flashes

So cycled my Tx off/on

Flashed green fast

Then 2 green and 2 red (in GPS mode)

Left it outside for 2 minutes and I got steady flashing green.....

Went through the arming steps and bingo Elevator on Tx needed reversing.....got the idling motors on zero throttle :-)

The motors stopped as I did not touch the throttle, so all good....then re-armed and applied throttle and nothing happened until greater than 50%, so all good.....

Assessed motor direction and had to swap wires on M1 & M3 to get them rotating anti clockwise.....

So now going to recalibrate the compass when I have some time and then might try a flight......

Thanks guys !  You are all awesome !

Riggsbie

Right......update.....

I still have issues when first powering up the Naza in the Discovery.....after the boot sequence I then get the yellow flashes.....

If I switch off my Tx I get the slow flashing yellow lights and then on repowering it seems to get happier and applying the throttle stick the lights go green ?

Anyway maybe a feature of the Devil7 Tx ?

Calibrated the ESCs, props fitted, recalibrated the GPS/compass and then had a good flight in the back garden.....

Very stable and nicely damped ! I like !

Thanks everyone for the help/suggestions.....a great knowledge base here !!

Paul

ChrisH

Are they continuous flashes or groups of four? If in groups, its the IMU warming up and can take five minutes to finish.
Chris
Hubsan X4
DJI F450, Naza, GPS, DX8,
Tarot FY680 Naza, GPS, Hero3 Silver, 5.8 FPV with screen
 :england:

Riggsbie

I have had both......

But the last yellow flashes were the fast four flashes then a short gap and then four fast flashes etc......

It seemed to sort itself out after a bit of time and then went green slow flashing.....then green and reds (getting GPS fix).....

The calibration mode is still a bit tricky to get into.....but it think that is just getting the ';knack'; of not flicking my 3 way switch too fast or too slow......

Even my neighbour commented on how stable it looked ! He was impressed !

ChrisH

The four and four and four are the IMU warm-up. You must let that finish and it may do it every time you connect your lipo! Normal for V3.12.

Sounds like you';ve got it nailed.  :smiley:
Chris
Hubsan X4
DJI F450, Naza, GPS, DX8,
Tarot FY680 Naza, GPS, Hero3 Silver, 5.8 FPV with screen
 :england:

Riggsbie

Going to take it to work tomorrow and drop by the Youyangs reserve on the way home......GoPro mounted on moongel.....

Hopefully I can get a flight or two in if it';s not windy !

KK1W

Quote from: ChrisH on Tuesday,June 25, 2013, 08:11:23
Are they continuous flashes or groups of four? If in groups, its the IMU warming up and can take five minutes to finish.


+1 on what Chris said. It is described in the latest quick start guide v1.08, buried on page 12.

http://www.dji-innovations.com/download/naza-m-downloads/

Mine takes anywhere from 1 to 3 minutes  :(  I did the same thing, kept plugging and unplugging the power, then magically it would work  :banghead:  Now I turn on the TX, put the quad on the ground, plug it in and do something else until I see the double green flashes (or double yellow for atti). It takes just as long but not as frustrating!

Jim
Jim/KK1W

Riggsbie

Latest update....

Got to fly for 25 minutes after work at work.... I work at a car test facility so had to take the GoPro off....so no video....

The initiation did take a good 3 minutes or so, even going onto my second LiPO it wanted another 90 seconds to be happy.....

Flew really nicely, no wind, the home lock mode works a treat.... Again very impressed with the stability out of the box.....

Got 15 minutes on a 5000mAh and 9 minutes on 2500 mAh LiPO batteries swapped when voltage dropped to 10.8V.....so decent flight time !!

I am a happy bunny !!

Riggsbie

Another 2 dusk flights with the Disco.....really starting to get a good feel for it now.....can';t wait for my new 4s batteries arrive from HK.....

Was flying with the RC plane guys and we ended up flying and chatting for almost 2 hours......they were very impressed with the Disco/Naza......

They had a nice 1400 T28 flying about......