Welcome to Multi-Rotor UK. Please login or sign up.

Tuesday,August 20, 2019, 06:50:58

Login with username, password and session length

Shoutbox

Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Gaza07:
09 Jul 2019 18:10:30
Hope you all have a great day  :beer2:
Andy7:
09 Jul 2019 14:05:28
BFU#8 details locked in for this saturday - see the head of the forum thread for all details.
hoverfly:
05 Jul 2019 21:51:05
Good for genital warts as well......or so I'm told.. :hmm
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196558
  • Total Topics: 19801
  • Online Today: 39
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 1
Guests: 37
Total: 38

Theme Changer





3d - Printworx

Printing 3d Forum

Multwii Lite V1 & FTDI not communicating with PC

Started by FlyinMarty, Thursday,June 20, 2013, 19:31:27

Previous topic - Next topic

FlyinMarty

Have recently purchased a teslaquad, which runs use MultiwiiLite V1 FC running MuliWii V2.2 with a Turnigy FTDI.

However I can not get the multwii to communicate with my PC - Windows 7 Home Premium, FTDI VCP 2.08.28 driver.

The TX light on the FTDI is light (after pressing start on multiwii conf), but nothing on the PC.

Anyone got any ideas?  :help:
Blade Nano QX
Immersion Vortex 285
 Blade mCPx Heli

teslahed

In order to trouble shoot this issue the first thing i would do would be to try a different PC. There are potential driver issues etc which you could easily sidestep this way.

Other than that i';m at a bit of a loss now. I';ve never had problems getting my FTDIs to connect.
One circlip short of a quadcopter.
 1 lobe short of an antenna.

JWHess

I have the same problem. I';ve tried 5 different FTDI adapters with no luck. I can get bluetooth to work with my android phone, but not to the PC.

ChrisH

Although I';m not familiar with this controller it sounds like the same problem as the RCT brushless gimbal. Recommendation is to load the FTDI VCP 2.08.24 driver after uninstalling and deleting the FTDI VCP 2.08.28

May be worth a try as that is described as a Win7 problem. :hmm:
Chris
Hubsan X4
DJI F450, Naza, GPS, DX8,
Tarot FY680 Naza, GPS, Hero3 Silver, 5.8 FPV with screen
 :england:

FlyinMarty

Tried 2.0.24 as well now, after removing it with the FTDI driver removal tool - still no joy.  Have ordered a RC Timer BT module so I can connect my phone to it.

Have found the old XP laptop - will try on that, once I have found the power lead.
Blade Nano QX
Immersion Vortex 285
 Blade mCPx Heli

FlyinMarty

Hmmmm.....

Just tried again - no luck  :banghead:

What I did notice, as the drivers installed, very quickly a message popped up with a message saying

                  "64 bit system detected, loading 64 bit driver"

or something to that effect - so I tried the MultiWii conf - 64 bit version & it will not run on my PC.
Blade Nano QX
Immersion Vortex 285
 Blade mCPx Heli

Riggsbie

Oooo.....

I am also having issues with driver';s and MultiWii......

I';ll watch this thread for progress !

JT

Quote from: FlyinMarty on Saturday,June 22, 2013, 07:32:05
Hmmmm.....

Just tried again - no luck  :banghead:

What I did notice, as the drivers installed, very quickly a message popped up with a message saying

                  "64 bit system detected, loading 64 bit driver"

or something to that effect - so I tried the MultiWii conf - 64 bit version & it will not run on my PC.



Marty, I don';t know what is causing your trouble, multiwii GUI works fine on my windows 7 64 bit but multiwii conf 64 bit doesn';t, however the 32 bit version does, might be an idea to try that(if you haven';t already)

Gaza07

I have never had any success running the 64 bit conf either always stick to the 32 bit vesion  ~~

bunnygirl80

Most of the PC based software for MultiWii are 32 bit software and for that reason I would recommend that you always install the 32 bit drivers. The 64 bit drivers will only work with applications which have been written to work with 64 bit! In our case, I';m not aware of any!

The new version of the FTDI drivers is a combined pack and contains the ftdibus drivers and the ftdiport drivers. If you are prompted, I would recommend that you don';t install the ftdibus drivers and only the ftdiport ones.

Okay, my first recommendation would be for you to uninstall the drivers. Full instructions on uninstalling and reinstalling are available in this useful guide...

http://www.ftdichip.com/Support/Documents/AppNotes/AN_119_FTDI_Drivers_Installation_Guide_for_Windows7.pdf

Then reinstall the latest FTDI PORT drivers following the instructions in this guide. You can download the drivers from here...

http://www.ftdichip.com/Drivers/VCP.htm

I am running Windows 7 64 bit Professional and have no problems whatsoever. The only thing which is sometimes a pain is identifying the port that the FTDI adaptor is connected to. So, here are some steps for that.

1. Click on your Start Globe bottom left corner. Make sure your FTDI adaptor is plugged in.
2. Right click on computer and select manage.
3. Click Device Manager in the Computer Management Window which has appeared.
4. Scroll down in the main window to Ports (COM and LPT)
5. You should see USB Serial Port (COM???). You might have many of these and you may have to select each in turn to work out which is your FTDI adaptor. If you are still having problems after this, I would recommend you unplug any other external devices which may be using any other ports.
6. Right click the USB Serial Port (COM14) in my case and select properties.
7. You should now see the properties.
8. It sometimes helps to make sure the speed of your FTDI adaptor is the same as the program you';re trying to connect to. You can set that on the Port Settings tab.
9. Press ok and try connecting from your software WinGUI etc.

If the above fails, try the FTDI drivers which come with Arduinio in the Arduinio drivers folder. I can give you more steps on this if you';re still having problems.



Always smile because you never know who could be falling in love with it. :) Drone Operator in North Wales. www.aerialworx.co.uk

Riggsbie

Something weird happened tonite......

My MultiWii (in fact NanoWii) was detected and the driver finally worked ?

Nothing has changed on my old beat up lapdog but somehow by some miracle it detected the new hardware and as I have done many many times I pointed it to look at the drivers folder in the Arduino folder and it worked...?

This is probably the 15th time I have tried and now it works.....WinGui works Multi_conf works but I don';t know why.....

Hurrah !

I am a happy bunny !

FlyinMarty

Really getting annoyed now, tried three different pc';s two win 7 and one Vista and various different versions of the FTDI drivers. 

Tempted to get hold of another FC and FTDI and start from scratch (wondering if I have ruined the FC with all my messing about with it)
Blade Nano QX
Immersion Vortex 285
 Blade mCPx Heli

teslahed

If you post the Multiwii flight controller back to me i will install the latest multwii firmware on it and make sure it responds properly. If the FC itself is faulty i will replace it with a spare i have.
One circlip short of a quadcopter.
 1 lobe short of an antenna.