Welcome to Multi-Rotor UK. Please login or sign up.

Friday,September 20, 2019, 11:29:18

Login with username, password and session length

Shoutbox

ched:
31 Aug 2019 20:37:03
Looking forward to BFU #9 footage  :D Hope you all had a great time
Gaza07:
31 Aug 2019 04:46:44
Hope you all have a great day today at the BFU 9  :beer2:
dp106:
29 Aug 2019 11:19:07
try again now, hopefully it should be resolved...
Gaza07:
29 Aug 2019 11:17:40
Should be fixed now
hoverfly:
29 Aug 2019 11:12:33
replies with only a few words are being rejected as file too big.. :hmm:
dp106:
29 Aug 2019 11:09:33
3D Site also affected
dp106:
29 Aug 2019 11:09:11
Gaza is on the case
dp106:
29 Aug 2019 11:09:03
there are currently issues with the forum
dp106:
29 Aug 2019 11:06:07
test
ched:
28 Aug 2019 17:28:19
Cheers Andy7.
Members
Stats
  • Total Posts: 196830
  • Total Topics: 19836
  • Online Today: 30
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 2
Guests: 50
Total: 52

Theme Changer





3d - Printworx

Printing 3d Forum

Bluetooth joy!!

Started by Yosser70, Monday,June 17, 2013, 06:23:38

Previous topic - Next topic

Yosser70

Right think I have this sussed! I did what everyone was telling me and checked all the baud rates were set correctly at 115200 in the port settings and in flight  planner. Now like most I still could get the bluetooth paired up but still no connection in flight planner, just getting a "connection failed" or "no heartbeat" sign, very frustrating to say the least! I carried on digging and found half a solution and worked out the rest myself. The first and main thing you have to do is turn off your laptops firewall, make sure you have all the baud rates set properly (if you aren';t using a crius bluetooth device I think you have change things on the bluetooth first but I have the crius one so it';s set to 115200 by default). Now everything is checked open up flight planner and then disconnect the bluetooth by taking out the lead from the bluetooth module, click connect in flight planner and wait till the box appears saying mavlink connecting and the second it does plug the bluetooth module back in and it should connect! If you disconnect you';ll have to do this over again. I think it';s something to do with the connection timing out between the Bluetooth module and the AIOP v1.1. I know it all sounds a pain but hey it working for me and hope it does for you, it might save you pulling all your hair out like I think most do while trying to sort this out lol

cgcrute

You Sir, are a genius! :notworthy:

Spent most of this evening trying to work that out!

Does anyone else know if there is a way to fix this either in the Crius GPS or Mission planner to reduce wear on the lead?

ZMR250
Naze32
Micro Titan Motors
SN02a ESCs
Mobius
Runcam Sky (with servo adjustable tilt)

Cheerson CX-10 ;-)

Taranis Transmitter

Hands0n

I gave up and opted for a 3DR clone telemetry kit - arrived today, plugged in and it worked.

In my case, the main issue seems to be the BT in the laptop itself. Totally screwed up Mission Planner';s ability to connect via USB, massive 30-40 seconds wait before it would start the connection sequence.  Found an obscure reference on one of the forums to disable the BT in the laptop and instantly the USB works again. 

So if you can';t get it working it may just be the laptop/PC';s own BT at fault and not the little adapter board at all.
--
Danny
"Its better than bad, its good"

Current FCs: Pixhawk, APM 2.6, Naza M V2, Naze32, Flip32+ CC3D, KK2.1.5
Aircraft: miniMax Hex, DJI 550 (clone) TBS Disco, 450 Firefly, 250 Pro, ZMR250, Hubsan X4, Bixler 2

cgcrute

More Bluetooth joy, this time of the Android variety. I couldn';t get anything to connect my Galaxy S3 to the Quad, until I found this:

https://code.google.com/r/xcl0100-copter-gcs/source/browse/#git%2Fcopter-gcs%2Frelease

It';s a modded version of Copter GCS which works fine (a little buggy on connection but workable).
ZMR250
Naze32
Micro Titan Motors
SN02a ESCs
Mobius
Runcam Sky (with servo adjustable tilt)

Cheerson CX-10 ;-)

Taranis Transmitter

Biffa

Quote from: Hands0n on Monday,September 02, 2013, 22:15:32
I gave up and opted for a 3DR clone telemetry kit - arrived today, plugged in and it worked.


Exactly what I did when I had my Crius board.
Steve