Welcome to Multi-Rotor UK. Please login or sign up.

Sunday,August 18, 2019, 15:54:47

Login with username, password and session length

Shoutbox

Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Gaza07:
09 Jul 2019 18:10:30
Hope you all have a great day  :beer2:
Andy7:
09 Jul 2019 14:05:28
BFU#8 details locked in for this saturday - see the head of the forum thread for all details.
hoverfly:
05 Jul 2019 21:51:05
Good for genital warts as well......or so I'm told.. :hmm
DarkButterfly:
05 Jul 2019 21:48:24
Just fixed a busted SMA connector on my TBS unity pigtail, it suffered badly in a recent crash and split in two, nothing a touch of the soldering iron couldn't fix  :D
DarkButterfly:
05 Jul 2019 19:44:08
 :D
Members
Stats
  • Total Posts: 196548
  • Total Topics: 19799
  • Online Today: 48
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 2
Guests: 44
Total: 46

Theme Changer





3d - Printworx

Printing 3d Forum

Getting annoyed now

Started by DarrenG, Sunday,June 16, 2013, 17:03:41

Previous topic - Next topic

DarrenG

Re-built my quad after it';s first crash. First test flight on Friday and there was clearly something wrong, very twitchy, any roll input seemed to send it mental. Never got it in the air as it was so bad I didn';t dare risk it.

Came home, checked everything and the Flight Data screen was not reflecting any movement of the quad at all. This despite all the CLI tests showing all was well. This was 2.91B

Foolishly I installed v3.0 RC5 and reset everything. The Flight Data page now worked again and I did the compassmot and all the tests checked out.

So I went back the flying field today. This time it wanted to tip backwards when power was applied. Couldn';t fathom why. I';d stripped it back to basics, no gimbal, 3DR radio unplugged.  Balance and COG was all correct, props on right way, motors spinning in the right directions.

And then it flipped onto one end and, being a twerp, I righted it without disarming the motors.  And as I leant down I caught he throttle. What a fecking eejut!

So now I have another prop broken and a lacerated hand. And I still don';t have a quad that is anywhere closer to flying.

Can anyone suggest where I look to diagnose why it';s being such a bar steward?  I';ve got plenty of thinking time whilst my hand heals!
Darren Griffin
@DarrenGriffin, @TheMacFixer & @PocketGPSWorld
Sky-Hero Little Spyder with Naza V2, Arducopter Quad with Pixhawk and Emax 250 with Naze32

dp106

If everything else seems ok maybe there';s an issue with the flight controller? Was it a hard crash?

DarrenG

Pretty hard but all the sensors pass muster and clear the tests OK.  Wondering if it could be a dodgy ESC that';s the issue?

I have some spares so will swap out the ESCs one by one and see if that resolves the issue. Major ball ache to do though as it means stripping the quad to get at them. Still, I';m not flying until it';s done I guess!
Darren Griffin
@DarrenGriffin, @TheMacFixer & @PocketGPSWorld
Sky-Hero Little Spyder with Naza V2, Arducopter Quad with Pixhawk and Emax 250 with Naze32

optiplex

remove the fc and try it alone at the table without anything else that might interfere it
i suggest also erase and reset, re-calibrate everything from scratch
make sure the FC is 100% working, so u know where to continue checking

DarrenG

Quote from: optiplex on Sunday,June 16, 2013, 21:04:59
remove the fc and try it alone at the table without anything else that might interfere it
i suggest also erase and reset, re-calibrate everything from scratch
make sure the FC is 100% working, so u know where to continue checking

Thanks, I did all that except the erase, when I installed v3.0.  Did the full recalibration, compass dance, compass mot, ran CLI tests against all the sensors and all OK.

I';ll try a full erase and reset.  Nothing to lose by trying that and re-loading v3.0 rc6 and retrying.  Also got a full set of ESCs inbound from HK, if all else fails I';ll swap the lot.
Darren Griffin
@DarrenGriffin, @TheMacFixer & @PocketGPSWorld
Sky-Hero Little Spyder with Naza V2, Arducopter Quad with Pixhawk and Emax 250 with Naze32

DarrenG

Right, took her apart, pulled the ESC that I repaired after the crash and replaced with a new flashed Blue Series 30A.

Done the compassmot with her weighted down and this time she appears to be responding to stick inputs correctly, tipping forwards/backards and to each side when the sticks are stirred.

So now I';m off to the flying field to test, complete with bandaged hand!  Fingers crossed that this works or there may be some parts for sale in the classifieds later and I';ll be off to buy a Phantom instead!
Darren Griffin
@DarrenGriffin, @TheMacFixer & @PocketGPSWorld
Sky-Hero Little Spyder with Naza V2, Arducopter Quad with Pixhawk and Emax 250 with Naze32

DarrenG

Getting very close to throwing in the towel with this and smashing the lot to bits. Went out earlier and tried to fly her but she was vibrating so badly that I thought she';d self destruct. I thought maybe I';d not tightened everything up after re-assembly so returned home, stripped it down and re-built with thread lock on ever metal to metal screw. Everything feels nice and tight as it was when first built.

So I popped out again but it';s no better. Above 40% throttle you can visibly see the motors shaking and, whilst it will fly, it';s all over the place and flies like a bag of nails.

I';m lost as to what the cause can be. One motor is brand new yet all four are vibrating so I can';t have damaged them all in the crash and damage was only to one side anyway.

These are new props and I';ve balanced them as best I can but I';d never bothered before and never had issues like this.

Can anyone suggest what might be the cause of this, or advise where I look in the logs for help before I give up. Wasted hours and hours on this and really pi**ed off now.
Darren Griffin
@DarrenGriffin, @TheMacFixer & @PocketGPSWorld
Sky-Hero Little Spyder with Naza V2, Arducopter Quad with Pixhawk and Emax 250 with Naze32

powerlord

No help - but sometimes it';s good to give in to the rage... Years ago I had an nitro rc car - I had problems starting it, then I got a drill starter, then the clutch went, the a steering arm broke, etc, etc.

The last straw was when for the umpteenth time I had it in bits to fix something or other, and I broke something else taking it apart...

I calmly took the thing into the garage, laid it in the middle if garage floor, retrieved a large claw hammer, and spend the next several minutes battering the thing into as many bits as I could while swearing at it.

Felt wonderful.

fruitsalad

Quote from: powerlord on Monday,June 17, 2013, 19:54:59
No help - but sometimes it';s good to give in to the rage... Years ago I had an nitro rc car - I had problems starting it, then I got a drill starter, then the clutch went, the a steering arm broke, etc, etc.

The last straw was when for the umpteenth time I had it in bits to fix something or other, and I broke something else taking it apart...

I calmly took the thing into the garage, laid it in the middle if garage floor, retrieved a large claw hammer, and spend the next several minutes battering the thing into as many bits as I could while swearing at it.

Felt wonderful.



similar story with a fms mini spitfire v1,an absolute ****** to get it to fly right,ended up giving up on it,the pleasure i felt in smashing the thing to pieces-----priceless!!!!!
one of the worst planes i owned that thing,got plenty other fms mini warbirds,no probs after a few tweaks here and there...
dont grow up,just buy bigger toys!!!!

Tango21Delta

Hi Darren, sorry to read you are having a nightmare with the Q650. If you decide not to send it to the great quad graveyard in the sky a few things came to mind,

did you manually recalibrate each of the esc';s after the post crash esc repair?
have you got IMU logs enabled? if so, what x y z vibrations are you seeing in the logs?
have you considered flashing the APM back to 2.9.1b?

I can send you my 2.9.1b param file if you would like to have something to compare.
Not as good as I once was, but as good once as I ever was

DarrenG

Quote from: Tango21Delta on Monday,June 17, 2013, 21:01:49
did you manually recalibrate each of the esc';s after the post crash esc repair?

I did the auto calibrate of all four, will try a manual calibrate of them individually in the morning.
Quotehave you got IMU logs enabled? if so, what x y z vibrations are you seeing in the logs?

yes, IMU enabled and vibration for Z axis was very bad. Will post a screen grab tomorrow.
Quotehave you considered flashing the APM back to 2.9.1b?

Do you think this could be software related?  I hadn';t considered it but right now I';d install MS-DOS if I thought it would help  :laugh:
QuoteI can send you my 2.9.1b param file if you would like to have something to compare.

That would be great thanks. Going to start afresh tomorrow and see what';s what. I';ll hide the mallet for now  ::)

Darren Griffin
@DarrenGriffin, @TheMacFixer & @PocketGPSWorld
Sky-Hero Little Spyder with Naza V2, Arducopter Quad with Pixhawk and Emax 250 with Naze32

Tango21Delta

Monday,June 17, 2013, 23:15:44 #11 Last Edit: Tuesday,June 18, 2013, 07:18:16 by Tango21Delta
2.9.1b Param data for comparison,

#NOTE: 06/05/2013 10:17:07 Frame : Q650
ACRO_BAL_PITCH,200
ACRO_BAL_ROLL,200
ACRO_P,4.5
ACRO_TRAINER,1
AHRS_BARO_USE,0
AHRS_GPS_GAIN,0
AHRS_GPS_USE,1
AHRS_RP_P,0.1
AHRS_TRIM_X,0.01
AHRS_TRIM_Y,0.01
AHRS_TRIM_Z,0
AHRS_WIND_MAX,0
AHRS_YAW_P,0.1
AMP_PER_VOLT,54.645
AUTO_SLEW,30
AUTO_VELZ_MAX,125
AUTO_VELZ_MIN,-125
AXIS_ENABLE,1
BATT_CAPACITY,5000
BATT_CURR_PIN,2
BATT_MONITOR,4
BATT_VOLT_PIN,1
CAM_DURATION,10
CAM_SERVO_OFF,1100
CAM_SERVO_ON,1300
CAM_TRIGG_TYPE,0
CH7_OPT,4
CIRCLE_RADIUS,3
COMPASS_AUTODEC,0
COMPASS_DEC,-0.046
COMPASS_LEARN,0
COMPASS_OFS_X,-52.166
COMPASS_OFS_Y,28.047
COMPASS_OFS_Z,24.264
COMPASS_USE,1
ESC,0
FLOW_ENABLE,0
FLTMODE1,0
FLTMODE2,0
FLTMODE3,2
FLTMODE4,2
FLTMODE5,5
FLTMODE6,5
FRAME,1
FS_BATT_ENABLE,0
FS_THR_ENABLE,1
FS_THR_VALUE,975
HLD_LAT_I,0
HLD_LAT_IMAX,3000
HLD_LAT_P,0.2
HLD_LON_I,0
HLD_LON_IMAX,3000
HLD_LON_P,0.2
INAV_ACORR_X,-91.159
INAV_ACORR_Y,-21.073
INAV_ACORR_Z,3.262
INAV_TC_XY,3
INAV_TC_Z,7
INPUT_VOLTS,5.1
INS_ACCOFFS_X,-0.067
INS_ACCOFFS_Y,0.472
INS_ACCOFFS_Z,1.058
INS_ACCSCAL_X,1.004
INS_ACCSCAL_Y,1
INS_ACCSCAL_Z,0.973
INS_GYROFFS_X,-0.017
INS_GYROFFS_Y,0.094
INS_GYROFFS_Z,0.032
INS_MPU6K_FILTER,20
INS_PRODUCT_ID,88
LAND_SPEED,50
LED_MODE,1
LIM_ALT_MAX,0
LIM_ALT_MIN,0
LIM_ALT_ON,0
LIM_ALT_REQ,0
LIM_CHANNEL,0
LIM_DEBUG,0
LIM_ENABLED,0
LIM_FNC_ON,0
LIM_FNC_RAD,0
LIM_FNC_REQ,0
LIM_FNC_SMPL,0
LIM_FNC_TOT,0
LIM_GPSLCK_ON,1
LIM_GPSLCK_REQ,1
LIM_RECMODE,0
LIM_REQUIRED,0
LIM_SAFETIME,0
LOG_BITMASK,510
LOITER_LAT_D,0.4
LOITER_LAT_I,0.04
LOITER_LAT_IMAX,3000
LOITER_LAT_P,4
LOITER_LON_D,0.4
LOITER_LON_I,0.04
LOITER_LON_IMAX,3000
LOITER_LON_P,4
LOW_VOLT,14.4
MAG_ENABLE,1
MNT_ANGMAX_PAN,4500
MNT_ANGMAX_ROL,1500
MNT_ANGMAX_TIL,2400
MNT_ANGMIN_PAN,-4500
MNT_ANGMIN_ROL,-2500
MNT_ANGMIN_TIL,-2400
MNT_CONTROL_X,0
MNT_CONTROL_Y,0
MNT_CONTROL_Z,0
MNT_JSTICK_SPD,0
MNT_MODE,3
MNT_NEUTRAL_X,0
MNT_NEUTRAL_Y,0
MNT_NEUTRAL_Z,0
MNT_RC_IN_PAN,0
MNT_RC_IN_ROLL,0
MNT_RC_IN_TILT,6
MNT_RETRACT_X,0
MNT_RETRACT_Y,0
MNT_RETRACT_Z,0
MNT_STAB_PAN,0
MNT_STAB_ROLL,1
MNT_STAB_TILT,1
MOT_TB_RATIO,1
MOT_TCRV_ENABLE,1
MOT_TCRV_MAXPCT,93
MOT_TCRV_MIDPCT,52
NAV_LAT_D,0
NAV_LAT_I,0.17
NAV_LAT_IMAX,1800
NAV_LAT_P,2.4
NAV_LON_D,0
NAV_LON_I,0.17
NAV_LON_IMAX,1800
NAV_LON_P,2.4
OF_PIT_D,0.12
OF_PIT_I,0.5
OF_PIT_IMAX,100
OF_PIT_P,2.5
OF_RLL_D,0.12
OF_RLL_I,0.5
OF_RLL_IMAX,100
OF_RLL_P,2.5
PILOT_VELZ_MAX,250
RATE_PIT_D,0.004
RATE_PIT_I,0.1
RATE_PIT_IMAX,500
RATE_PIT_P,0.11
RATE_RLL_D,0.004
RATE_RLL_I,0.1
RATE_RLL_IMAX,500
RATE_RLL_P,0.11
RATE_YAW_D,0
RATE_YAW_I,0.015
RATE_YAW_IMAX,800
RATE_YAW_P,0.13
RC_SPEED,400
RC1_DZ,30
RC1_MAX,1917
RC1_MIN,1118
RC1_REV,1
RC1_TRIM,1515
RC10_DZ,0
RC10_FUNCTION,8
RC10_MAX,1919
RC10_MIN,1120
RC10_REV,1
RC10_TRIM,1514
RC11_DZ,0
RC11_FUNCTION,7
RC11_MAX,1919
RC11_MIN,1120
RC11_REV,1
RC11_TRIM,1500
RC2_DZ,30
RC2_MAX,1919
RC2_MIN,1122
RC2_REV,1
RC2_TRIM,1522
RC3_DZ,30
RC3_MAX,1919
RC3_MIN,1115
RC3_REV,1
RC3_TRIM,1119
RC4_DZ,40
RC4_MAX,1915
RC4_MIN,1118
RC4_REV,1
RC4_TRIM,1516
RC5_DZ,0
RC5_FUNCTION,1
RC5_MAX,1919
RC5_MIN,1120
RC5_REV,1
RC5_TRIM,1523
RC6_DZ,0
RC6_FUNCTION,0
RC6_MAX,1919
RC6_MIN,1120
RC6_REV,1
RC6_TRIM,1523
RC7_DZ,0
RC7_FUNCTION,0
RC7_MAX,1919
RC7_MIN,1118
RC7_REV,1
RC7_TRIM,1526
RC8_DZ,0
RC8_FUNCTION,1
RC8_MAX,1919
RC8_MIN,1118
RC8_REV,1
RC8_TRIM,1500
RSSI_PIN,-1
RTL_ALT,1500
RTL_ALT_FINAL,199
RTL_LOIT_TIME,5000
SERIAL3_BAUD,57
SIMPLE,0
SONAR_ENABLE,0
SONAR_TYPE,0
SR0_EXT_STAT,2
SR0_EXTRA1,5
SR0_EXTRA2,5
SR0_EXTRA3,3
SR0_PARAMS,50
SR0_POSITION,3
SR0_RAW_CTRL,0
SR0_RAW_SENS,5
SR0_RC_CHAN,3
SR3_EXT_STAT,2
SR3_EXTRA1,5
SR3_EXTRA2,5
SR3_EXTRA3,3
SR3_PARAMS,0
SR3_POSITION,0
SR3_RAW_CTRL,0
SR3_RAW_SENS,5
SR3_RC_CHAN,0
STB_PIT_I,0
STB_PIT_IMAX,800
STB_PIT_P,5
STB_RLL_I,0
STB_RLL_IMAX,800
STB_RLL_P,5
STB_YAW_I,0
STB_YAW_IMAX,800
STB_YAW_P,8
SUPER_SIMPLE,0
SYSID_MYGCS,255
SYSID_SW_MREV,120
SYSID_SW_TYPE,10
SYSID_THISMAV,1
TELEM_DELAY,1
THR_ACC_ENABLE,1
THR_ACCEL_D,0
THR_ACCEL_I,1
THR_ACCEL_IMAX,500
THR_ACCEL_P,0.5
THR_ALT_I,0
THR_ALT_IMAX,300
THR_ALT_P,2
THR_MAX,1000
THR_MID,600
THR_MIN,130
THR_RATE_D,0.2
THR_RATE_I,0
THR_RATE_IMAX,300
THR_RATE_P,6
TILT,54
TOY_RATE,1
TRIM_THROTTLE,209
TUNE,0
TUNE_HIGH,1000
TUNE_LOW,0
VOLT_DIVIDER,15.701
WP_INDEX,0
WP_RADIUS,3
WP_SPEED_MAX,500
WP_TOTAL,3
XTRK_GAIN_SC,0.2
XTRK_MIN_DIST,15
YAW_OVR_BEHAVE,0
Not as good as I once was, but as good once as I ever was

DarrenG

Well after much head scratching, quite a bit of swearing, and a lot of work I finally have her flying properly again.

First I binned the new props, an eBay purchase. They were so far out of balance that I didn';t want to waste the time sorting them, blades and hubs were way out of whack.

I';d also recently added a 12v DC- DC regulator to supply the brushless gimbal with 12v. So i removed that in case it was causing some interference. 

I then balanced and fitted Gemfan 10 x 4.5';s. That made a big difference to the vibe but the motors still sounded angry when pitch and yaw changes were being made so it was a time for my first attempt at tuning.

I worked on tweaking Rate P for both Roll and Pitch and after a few test flights she is now much happier, holds a lovely hover and feels really smooth.  I even bit the bullet and upgraded (after downgrading to v2.91B) to v3.0 RC6 and she';s still flying.

All this is without a gimbal as I wanted to get back to basics, get her flying properly stripped down and then start adding back kit.

I love the Q650 frame for clean looks but it';s a royal PITA to work on if you need to strip. And simple things like changing out an ESC mean a complete disassembly, which I';ve now done more times than I care to recall!  And those damn 2mm hex screws have left me with a growing collection of knackered allen keys!

Still, she flies, I';m going to be a lot more careful about flying her until my abilities are more in line with the quads capability!  :laugh:
Darren Griffin
@DarrenGriffin, @TheMacFixer & @PocketGPSWorld
Sky-Hero Little Spyder with Naza V2, Arducopter Quad with Pixhawk and Emax 250 with Naze32