Welcome to Multi-Rotor UK. Please login or sign up.

Friday,August 23, 2019, 10:55:36

Login with username, password and session length

Shoutbox

Andy7:
23 Aug 2019 10:29:15
Nice! Looks loads better.  :beer2:
Gaza07:
22 Aug 2019 22:47:32
Sorted mate  ~~
Andy7:
22 Aug 2019 10:27:36
Sure. But basically, all the subjects are getting cut off.
Gaza07:
21 Aug 2019 18:14:54
Can you pm me a screen shot of what you mean
Andy7:
21 Aug 2019 12:15:41
Gaza - can you make the subject line section in the forum topic list wider? It's cutting off the subject field really short.
Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196581
  • Total Topics: 19804
  • Online Today: 39
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 1
Guests: 38
Total: 39

Theme Changer





3d - Printworx

Printing 3d Forum

Multi Wii Win Gui 2.2 help needed

Started by baldone53, Wednesday,June 12, 2013, 01:18:23

Previous topic - Next topic

baldone53

Hi to all,
I am just starting and somehow got drawn to the Multi Wii PRO 2.0 Flight Controller w/ G.P.S. from ready to fly quads.
I run Multi Wii Win Gui 2.2, and in RC control settings I selected Aux1 and choose the LEVEL option H and highlighted it, then I linked it to channel 5 receiver and chose one of the my RC Transmitter switch to activate it. When I stay in RC Control Settings and flip the chosen switch on and off on my Transmitter, I';ll see the highlighted H changing from H to L and back, but when I return to the Real Time screen, the red Level status light don';t reflect the switch actions.
My quad is powered on with the Lipo battery installed, Connected to my laptop over 3DR radio telemetry(wifi). The quad is fully functional, I am able to control the quad and let it lift for an five or so inches and see the motors actions on the Multi Wii Gui 2.2. So as you can see every thing is connected correctly, when I arm the quad with my RC Transmitter, The ARM red light turns on as it should.
I am stock her and hope that someone would be kindly enough to help me.

Thanks,

Gaza07

Do you save the changes once you have made the selection in the rc setup ?

baldone53

 :cry  yes I do save every things after setting up.
Thinking about it , even though I have almost no knowledge how everything';s works,  is it possible that the LEVEL command will activate and shown at the status lights console only when the quad has been taken up?

Gaza07

I have taken a couple of pics of mine in the wingui angle is on my gear switch which is plugged into aux1 on the board


Here the switch is off and Auto Level (Angle) is off

[attach=1]

here my gear switch is on and angle is lit up the copter is on the bench and connected via usb cable

[attach=2]

My rc settings screen

[attach=3]


This is it working the same through the 433mhz module at 57600bps

[attach=4]

baldone53

I really appreciate your help.
picture 1, when I flip the switch on my Transmitter, the bar top right Aux1 goes from low to high, but Angle not lit
RC settings are the same as yours, like I said, when I flip the switch on my Transmitter while I in RC settings,  the from L  to H and back.
I have a 900mhz data link, because I am resident ion the U.S , but don';t know the baud rate at this time, I don';t see any other problems with data link, all other operations seem to be working fine.

Gaza07

Do you have a link to the specs for the board which board define did you use when you uploaded the sketch ?
are all the green boxes lit like mine are ?

baldone53

http://witespyquad.gostorego.com/flight-controllers/multiwii-pro-2-0-flight-controller.html
that';s the board I got

I downloaded
https://www.dropbox.com/sh/7vge5qajwjx6lq0/O2QIqf2Que
MultiWii_MEGA2_GPS.zip and then uploaded the sketch.

The Flight controller was ordered with pre-installed Sketch, but had already the Angle issue. I then downloaded  and uploaded the sketch, above but did not erase the pre-installed sketch, is that a problem?

Yes the green boxes are like yours