Welcome to Multi-Rotor UK. Please login or sign up.

Saturday,January 25, 2020, 11:22:50

Login with username, password and session length

Shoutbox

Rares Gosav:
17 Jan 2020 17:44:22
Hi guys and happy new year!!!
ched:
01 Jan 2020 00:12:50
Happy new year everyone, happy flying.  :beer2: :beer2:
Gaza07:
31 Dec 2019 17:06:13
Happy new year all hope 2020 is a cracking year for you  :beer2:
ched:
25 Dec 2019 00:00:49
Happy Christmas to everyone.
apollo7:
24 Dec 2019 13:50:56
Seasons greetings to all on this forum have a good one ;)
ched:
21 Dec 2019 17:58:42
Have a great time DB. Look forward your projects in 2020.  :beer2:
hoverfly:
21 Dec 2019 16:59:17
Have a good one D.B. ~~ :beer2: :beer2: :beer2:
DarkButterfly:
21 Dec 2019 16:14:27
 :beer2:
DarkButterfly:
21 Dec 2019 16:13:44
Tbh I've been really busy, not had much time to fly anything and with conditions being crap, hopefully in the new year I'll have some new projects on the go, mostly to do with HAM radio, will certainly fly again soon. FTR I hate FB too   :D Merry Christmas
Gaza07:
21 Dec 2019 15:21:30
Merry Christmas  :beer2:
Members
Stats
  • Total Posts: 197503
  • Total Topics: 19930
  • Online Today: 28
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 16
Total: 16

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

AIO pro/ GPS??

Started by Royston, Saturday,May 11, 2013, 11:31:36

Previous topic - Next topic

Royston

Hi Guys
Eventually got board working with UBEC. Loaded firmware etc.
Everything sound except no power to CN 06 GPS.
Any help, as always, much appreciated.
Regards
Roy

fruitsalad

have you got it wired in correct??
dont grow up,just buy bigger toys!!!!

Royston

As far as I can see. Serial port and looks same as 450  Peter King one I';ve got??

fruitsalad

check for any dry joints on the pads,and all wires are crimped properly..
you never know....
dont grow up,just buy bigger toys!!!!

AM556

Is Peter';s GPS powered from the serial or as mine, pin 11 of the ESC? If so, have you got it connecting to the same pins?
I don';t know why his has a red still connected to pin 2 of the ESC row while the jumper is removed and board powered via a ubec?

Royston

Peters is through serial port. Connects the same. My ECSs are opto and board powered by ubec. All ESC wires are still connected???

Royston

Think I';ll try cable off 450. At least that will eliminate that from the equation.

Royston

OK even more confused now. Tried cable off 450 which is a actually a Hextronik. GPS lit up green but no indication on the board. Tried Hexatronic complete and fine ie. green light on board. :banghead: :banghead: :banghead:
Also board only boots up when USB is connected.
Anybody any ideas where I go from here.
Roy

Biffa

I suffered similar thing with my AIOP board once when it would only power with the USB when I changed firmware.

I reflashed with the working firmware version from here and everything was fine.

Worth a shot rather than pulling your hair out?
Steve

Royston

Cheers.  Will give it a go.
Any ideas about gps

AM556

Saturday,May 11, 2013, 20:04:16 #10 Last Edit: Sunday,May 12, 2013, 13:38:29 by AM556
Peter does demonstrate needing to "jump start" the board when using USB by connecting a battery, though I';ve not needed to.
When you use the cable only from your 450, is the TX from one going to the RX on the other?

Royston

Hi
The board won';t boot up at all unless its connected to laptop via usb.
When using cable from 450 nothing shows on board just a green, I presume power light, on crius gps unit but no light on board. Is that what you mean??

AM556

"Eventually got board working with UBEC" Are you sure? "The board won';t boot up at all unless its connected to laptop via usb"

Royston

Yep
Just tried again to make sure I wasn';t mistaken.
Power up with lipo nothing. Plug usb into laptop and hey presto it boots up. Its got me??
Quad will arm/motors turn. As soon as I unplug from laptop board dies.

Gaza07

If you fit your jumper and power with a Esc does the board power then ? did I read earlier you may have connected your Ubec in reverse I wonder if you have blown something on the power input side ?

Royston

Hi Gaza
Re-fitted jumper but no go but ESCs are OPTO??

Royston

Meant to say no ubec not reversed but during process of wiring board poss touched + - 5v input pins with a live feed.
Will that mean that board is G********SED??

Gaza07

Ah opto esc';s dont have the bec erm you could try the ubec connected to the + and - esc pins on the board see if it gets power from there, if it does then I suspect you have popped summat on the extended power port, make sure your ubec is set to 5v though  ~~

AM556

Have you removed the yellow jumper?
Is your UBEC connected to the yellow pins to the right of where you connected the receiver?

Royston

Hi Gaza. UBEC is 5v. There is power to the board from UBEC. Tested with voltmeter. Do you mean to move UBEC connector from where it should be to where one of the ESC connectors go??

AM566, sorry don';t know your name but yes have removed jumper and it is connected to yellow pins.

Have horrible feeling new board coming up.

Royston

On a more positive note. After a close inspection of GPS wiring and your AIO manual i don';t think It was wired quite right so will give that another go tomorrow.
Thanks Guys

AM556

Sorry Roy, I';m Rob. You could plug the UBEC into one of the ESC ports and replace the jumper.
If that works, I';ll check with my microscope tomorrow to see where the diode will be that may have popped.

Royston

Cheers Rob
Tried ubec on ESC pins but unfortunately no joy.
BUMMER
:cry  :cry :cry

AM556

Hmmmm  :hmm: I';ll assume you';re certain the polarity is correct. Do you have another 5v supply you could cannibalise to power the extended pins? Things are not looking good  :banghead:

Royston

Yep Rob polarity OK. Unfortunately don';t have any other 5v supply. But you';re right. Not looking good.  Oh well RC Timer owe me a credit as ESCs were supposed to incorporate a BEC

ausi1972

Sunday,May 12, 2013, 18:47:37 #25 Last Edit: Sunday,May 12, 2013, 21:08:02 by ausi1972
To get power to the Serial port of the AIO Pro you will need to power the board via the Ext power port using a UBec or the power line from one of the ESC';s Bec';s.
If you just power the board from the ESC';s BEc on the motor rail then you will need to connect the power pins of the GPS to the motor rail and not the Serial port.

Also make sure you are using UBlox in your firmware for GPS type, if not then just try one of my firmwares:
For firmware settings and information files please see my public Google Docs folder:
https://drive.google.com/folderview?id=0B-B7PQy0joGrUjFmb2pSTFlqcWc&usp=sharing

Make sure GPS is connected to Serial pins Tx2 & Rx2.

Remove the jumper (middle of the motor rail) when powering your board from the Ext power connector.
regards Peter King