Welcome to Multi-Rotor UK. Please login or sign up.

Friday,August 23, 2019, 01:44:56

Login with username, password and session length

Shoutbox

Gaza07:
22 Aug 2019 22:47:32
Sorted mate  ~~
Andy7:
22 Aug 2019 10:27:36
Sure. But basically, all the subjects are getting cut off.
Gaza07:
21 Aug 2019 18:14:54
Can you pm me a screen shot of what you mean
Andy7:
21 Aug 2019 12:15:41
Gaza - can you make the subject line section in the forum topic list wider? It's cutting off the subject field really short.
Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196578
  • Total Topics: 19804
  • Online Today: 44
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 39
Total: 39

Theme Changer





3d - Printworx

Printing 3d Forum

Quad just climbs when select RTL and already over RTL site.

Started by andycap, Monday,May 06, 2013, 18:55:44

Previous topic - Next topic

andycap

Hi all.

I am new here but have been lurking for quite a while.

I have an F450 flamewheel with APM 2.5 running 2.9.1b and Ublox GPS.

Whilst I was flying today on my garden I noticed that when I selected RTL from a height of about 15m and was within 3 metres of the original home position, my quad just decided to climb.  I allowed it to continue until it reached about 60m before I took control and brought it down.  I have the RTL height set to 15m.  I have tested RTL yesterday on an open field and it reacted perfectly as expected.  I am not sure if this is a known thing and that I should not be selecting RTL when already that close to home or not.

Unfortunately I do not have telemetry yet (on order from hk) but I do have onboard video of it happening here.

At about 1:08 in the video.

Wonder if I should be worrying about this or not?

Andy.
Can't find a spanner ? Pass me a hammer !

Gaza07

Hi Andy and welcome to the forum I wonder if its a bit of a bug as you said it worked fine when further away, Just keep an eye on it when using RTL  ~~

Jumpy07

Andy does you Alt Hold work ok.. or does it climb ?

Could just have been a GPS glitch.. did you have logging on ?
BNUC-S Pilot with PfCo /PFAW.
UAQ / CAA PfCo Instructor / Flight Assessor

"All that is necessary for the triumph of evil is that good men do nothing"

andycap

Hi.

Thanks for the replys.

Yes my Alt Hold does seem to work fine, so does Loiter although I do have to have the Auto learn compass offset turned on contrary to most recommendations.  I was having loads of trouble with Loiter and even with the apm removed from quad, the best offset calibration i could get for X axis was around 250.  A lot higher than the +-150 that I have read about.  since turning compass learn on my problems have almost gone.  If i do find that it drifts in loiter I just do a single yaw pirouette and it is fine after that.

I done my first Auto waypoint today as you can see in the video and that seemed to work fine as well.   One question though,  I was expecting it to continue to home after waypoint 3 which was the last one i set, but it just stopped at that one and started descending.  Should I have another waypoint at the home location to bring it back to there, or should I have the last waypoint set as Return To Launch ?

This is a great forum and seems to have loads of valuable info.  Thanks people.

Andy.
Can't find a spanner ? Pass me a hammer !