Welcome to Multi-Rotor UK. Please login or sign up.

Monday,November 18, 2019, 16:33:23

Login with username, password and session length

Shoutbox

ched:
18 Oct 2019 11:25:16
Sounds good yama. Would love to see some images. 3d models sound cool too
yama:
18 Oct 2019 10:32:38
i might have to do a review. the 21mp camera is excellent at producing high quality 3d models for mapping.
ched:
10 Oct 2019 16:56:16
Show us some picys and maybe post a review in a thread?
yama:
09 Oct 2019 14:13:10
must admit this anafi is tiny and looks like a toy in a lunchbox but performs like a professional product.
yama:
09 Oct 2019 14:11:52
went ahead and bought one. about to find out if the 21mp camera improves photogrammetry surveys.
ched:
08 Oct 2019 17:14:17
Not tried a parrot anafi but I thought parrot were stopping 'drone' production?
yama:
07 Oct 2019 13:25:37
anyone tried a parrot anafi?
Gaza07:
26 Sep 2019 11:33:59
We know a song about that dont we  :D
Andy7:
26 Sep 2019 08:38:34
 :laugh:
Bad Raven:
26 Sep 2019 07:10:39
Adopts Australian accent "Black, that's not Black, its a dirty grey, THIS is Black........"   :D
Members
Stats
  • Total Posts: 197136
  • Total Topics: 19878
  • Online Today: 47
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 4
Guests: 39
Total: 43

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

Someone please help before I have a mental breakdown!

Started by Stubb-z, Sunday,October 13, 2019, 18:30:17

Previous topic - Next topic

Stubb-z

Trying to get my TGY-ia6C to talk to my omnibus f4 FC (sbus) and its not having any of it - BF shows no stick inputs no matter what I seem to try, and I'm quickly coming to my whits end - never had this before with an FC.  :banghead:
Tried everything I can think of - all combinations in BF and board connections - I know its going to be a simple solution, so anyone managed to do it? Put me out of my misery please!  :cry



P.s please feel free to talk to me like I'm a moron - I probably am being one!
P.P.s - Rx and TX ARE bound and talking to each other!

ched

Does this FC have solder bridge pads to 'switch' between ppm and sbus?
I have a feeling if running BetaFlight 3.5 or newer can use iBus or Sbus connected to same pad as I think the inversion required for Sbus can now be automatically switched off by selecting serial rx and iBus!!!
I try :-)

Stubb-z

OMG ched - think you may be right - three tiny solder bridge pads on the top right hand side of the board I totally missed!
Will bridge them tomorrow after work and report back....... :crossfingers: 

Stubb-z

Had a bit of a bad week - car went bang and had to hire one for work - amoungst other things!

Bridged the solder pads but still no rx joy!

Pretty much the cherry on the cake this week! Although I did sort the ESC issue! :cry

ched

Quote from: Stubb-z on Saturday,October 19, 2019, 19:58:59 Had a bit of a bad week - car went bang and had to hire one for work - amoungst other things!

Bridged the solder pads but still no rx joy!

Pretty much the cherry on the cake this week! Although I did sort the ESC issue! :cry
Sorry to hear bad week, hope bill not too big.

So you bridged the centre to the ppm or SBus? I assume only a single bridge between 2 pads?

Double check in ports you have correct uart selected for serial rx. In Config select correct serial rx manufacturer and then comms type. Other than that I am a bit stumped. Oh check they radio (TX) is set to the same protocol (iBus ideally).
I think Project BlueFalcon has some flysky rx to fc connection videos on youtube. They may be a little old and not your specific FC but have a look it might give  you a clue.

Without extra kit I don't know how to check the output of a rx.

Hope that helps  :hmm:  :hmm:
I try :-)

ched

Just had another thought. Can you set tx and rx to be iBus? If so then you can connect the rx to any uart. It's only SBus that needs a specific uart as it needs an inverter. The F4 FC can't do inversion within cpu so has to have a dedicated inverter!
So iBus doesn't need the dedicated inverter so you can use any uart rx pad and then set appropriately in ports tab in BF.
I try :-)

Stubb-z

Ched  - I could kiss you!  :D
Switched Rx and Tx to Ibus and connected to Uart3 and its working............ Finally!
Uart 3 and 6 dont have an inverter so Sbus was never going to work!
Very greatful to you saving my sanity!
Great end to an otherwise pretty crappy week!

:thankyou: