Welcome to Multi-Rotor UK. Please login or sign up.

Friday,December 06, 2019, 02:33:52

Login with username, password and session length

Shoutbox

Bad Raven:
02 Dec 2019 20:03:50
Only if the battery is fully charged, leak a few volts and it'll be fine.......
Andy7:
02 Dec 2019 17:19:55
If yo fly a Mavic Mini and get over a gramme of mud on it, do you have to register it?  :rofl:
hoverfly:
02 Dec 2019 08:38:56
Not a problem i've had a body mod, I think of Jean Harlow naked on a trampoline  and the new antenna  extends automatically..   :whistling:
Andy7:
29 Nov 2019 17:17:37
That'll play hell with your FPV signal. :rofl:
hoverfly:
29 Nov 2019 17:10:20
Won't get me i'm wearing my tin foil hat... :wack0
Andy7:
29 Nov 2019 14:19:03
Because GOVERNMENT SPY DRONES are watching us! :frantic:
hoverfly:
29 Nov 2019 11:41:22
BBC News this am ..only 50% of people have registered  for the  CAA  scheme.. If people haven't registered  how do they know it's 50%.. :shrug:
ched:
28 Nov 2019 20:16:14
Very very quiet. I am missing chatting :-( Must be the weather....
Gaza07:
25 Nov 2019 08:28:26
Forums very quiet  :shrug:
ched:
18 Oct 2019 11:25:16
Sounds good yama. Would love to see some images. 3d models sound cool too
Members
Stats
  • Total Posts: 197202
  • Total Topics: 19884
  • Online Today: 66
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 32
Total: 32

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

Home file server - cloud - RaspberryPi?

Started by ched, Thursday,February 07, 2019, 20:35:15

Previous topic - Next topic

ched

My old trusty NAS server (eTrayZ) disc has died and the nas is about 10 years old so there is probably better things out there?

Basically I would like to auto backup a couple of directories on my win7 PC, maybe replicate dropbox from Laptop (Win7) and mobile (Android).

I have a couple of usb hard drives and a RaspberryPi B+ kicking about which would be nice to use?

So can anyone recommend any software (OS + applications) that might do the job?

Cheers.
I try :-)

Two-Six

Your starter for 10
https://www.windowscentral.com/how-build-raspberry-pi-powered-nas
https://eltechs.com/raspberry-pi-nas-guide/
https://www.techradar.com/uk/how-to/computing/how-to-build-your-own-raspberry-pi-nas-1315968

I have a Rasberry pie doing nothing here and a pile of disks that need gainful employment, I might give it a go.  :hmm:

If you didn't manage to get your data from that old NAS box, Linux will be able to read those partitions so you can get your stuff back.
Nighthawk Pro, Trex 450 L Dominator 6 cell *FLOWN*, Blade 450-3D, MCPX-BL, MCPX-V2, Hubsan X4, Seagull Boomerang IC .40 trainer, HK Bixler, AXN Clouds fly,, Spektrum DX7, Taranis, AccuRC

atomiclama

Friday,February 08, 2019, 10:58:24 #2 Last Edit: Friday,February 08, 2019, 15:30:19 by atomiclama
Oh FFS something else to read up on and try out  :rolleyes:  ::)
Wasdale X, Ow that hurt

ched

Cheers. There do seem to be quite a few guides out there. I am going to have a play this afternoon and see what I can get working!
As for old data, it's a bit weird. The internal disc I can't access, but the externally connected usb drive I have access to. I also can't access the web interface. So some bits of it work others not. I will pull the HD and see if the Rpi can read it.

Cheers. I will let you know how I get on.
I try :-)

ched

So after looking at lots of guides and realising that my old RPi were older than I thought (Rpi B with 900mhz and 512Mb), I decided to try dietpi and nextcloud.
Dietpi is a cut down distro that also has easy optimised software that just requires a click to instal. So installed dietpi on 4Gb SD card and that went fine. Booted rpi and the installation went fine. Then you eventually get a menu to install optimised software, I selected NextCloud (OpenCould available) and that too went fine, rebooted and tried to login. No NextCloud was having none of it, eventually found the default username and password on an install via dietpi was not defaults but admin and dietpi. I would never guessed that!!
So now logged in via ri ip address /nextcloud/  and logged in correctly. All fine, created additional user account and installed win7 client. All works fine.
Only problem is that it is painfully slow!!! So maybe going to have to rethink this one.....
I try :-)

ched

So I thought I would do a bit more in depth fault finding on my eTrayZ nas. I found I could ssh into it  ~~
So did a bit of checking and it seemed that a xsf partition was a bit iffy. So I tried xsf_repair with -L switch and after about 30mins it found an error and deleted it!!
Rebooted and it's working again. Well mostly, some of the extra apps like MediaTomb and MySQl don't seem to be working but I don't really use them anymore.

So looks like eTrayZ is alive again. So I will make 100% sure I have an alternative backup and it's all upto date in case it dies again.

Cheers.
I try :-)