Welcome to Multi-Rotor UK. Please login or sign up.

Saturday,June 06, 2020, 08:24:20

Login with username, password and session length

Shoutbox

ched:
04 Jun 2020 17:27:04
Hello Six6siX
Six6siX:
03 Jun 2020 13:28:30
ooo... hello all
badger1:
02 Jun 2020 22:09:18
TBS Source One frame with 7" arms
badger1:
02 Jun 2020 22:09:02
my guess was bang on the number - just out on the units!
LiamHowe89:
02 Jun 2020 21:48:33
Just a bit out from your initial guess then  :laugh: What kind of frame do you fly with?
badger1:
02 Jun 2020 18:52:22
shoutbox doesn't like ampersands for some reason
badger1:
02 Jun 2020 18:51:54
and it was more like a 100m fall  :o
badger1:
02 Jun 2020 18:50:36
lol - checked my logging
badger1:
02 Jun 2020 11:52:29
@Liam - no, absolutely fine.  had another couple of flights with it afterwards -  :laugh:
LiamHowe89:
01 Jun 2020 21:23:22
Ouch! Any breakages?
Members
Stats
  • Total Posts: 198612
  • Total Topics: 20021
  • Online Today: 9
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 12
Total: 12

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

Omibus f3 Motor Remapping ?

Started by aburn09, Saturday,August 25, 2018, 12:53:47

Previous topic - Next topic

aburn09

Saturday,August 25, 2018, 12:53:47 Last Edit: Sunday,August 26, 2018, 17:37:23 by aburn09
I've asked this before but ill try again...…...A few years ago I built a Police Quadcopter from my own design which had a naze32 board in it and I was using Spektrum Tx and Rx at the time and as you can see all worked well after a little help on here remapping the motors to move down by two allowing what was motors 1 and 2 to become my servo switches which operated the siren and lights separately.



However ive since decided to update the quad and put in a Omnibus F3 flight controller and I intend to upgrade the motors and lights but i'm stuck remapping the motors by two enabling servo tilt on the FC as before and remapping the motors through the cli on betaflight.
I've got the lights and siren to work but i can only get motors one and two to spin up (which are now in 3 and 4's old slot)
Ive enclosed the original mapping and my remapping to see if anyone can find the answer......I've tried with and without 'servo tilt enabled ' but motors 3 and 4 (now 5 & 6 after remapping ) refuse to spin up going through betaflights motor tab again only 1 and 2 will spin up ?



Reman

I use the exact same F3 board for most of my quads, And I hate to say this, But I spent about a week of evenings reading forums and watching YouTube videos while trying to get one of these to pass through two PWM channels to run a gimbal. In the end I gave up and bought a PWM to PPM converter. I now use PWM mode on my TX/RX and have 8 of the channels run through the converter to give the FC a PPM signal. The remaining 2 RX channels I have go directly to the gimbal.

I'm sure someone out there has managed to get this board to output some PWM channels (As we both assume it should), But I just know that the problem was starting to p*ss me right off, And the PWM to PPM converter ended up being the quickest and least stressful option for me to get what I needed.
I need a pay rise........ Though I'd settle for a reduction in the amount of hours I need to work to get the same money.

Cheredanine

Also pretty sure pwm has been removed from f3 because they are struggling, you will need an older build or I think someone did a custom one

aburn09

Saturday,August 25, 2018, 19:43:55 #3 Last Edit: Sunday,August 26, 2018, 16:31:23 by aburn09
Thanks Cheredanine you did comment last time when I changed the naze to a SP Racing EVO3 and you said you thought the SP Racing boards wouldn't allow remapping which is why I tried the Omnibus after I keep walking by this particular model in bits and keep saying i'll give that another go sometime well sometime is here again but still no joy :banghead:...….If I can find another naze32 board then id also have to find a very old copy of betaflight as I know the naze32 wasn't supported last time I tried to plug it into betaflight  :banghead:...……….Unless anyone else has any other ideas I fear the Police Quad will never fly again  :cry

Cheredanine

Quote from: aburn09 on Saturday,August 25, 2018, 19:43:55
Thanks Cheredanine you did comment last time when I changed the naze to a SP Racing EVO3 and you said you thought the SP Racing boards wouldn't allow remapping which is why I tried the Omnibus after I keep walkinh by this particular model in bits and keep saying i'll give that another go sometime well sometime is here again but still no joy :banghead:...….If I can find another naze32 board then id also have to find a very old copy of betaflight as I know the naze32 wasn't supported last time I tried to plug it into betaflight  :banghead:...……….Unless anyone else has any other ideas I fear the Police Quad will never fly again  :cry

Ask on rcexplorer mate, they will know.

aburn09

Did you mean this site Cheredanine https://rcexplorer.se/forums/forum/eto verything-else/
As it looks to be all about Tricopters ? However I'm getting desperate to find a solution to this as I hate loose ends and this one has been going on long enough now all I need is a way to switch two functions on and off ie the lights and siren which used to be very simple and i cant see why its still not possible through betaflight ?

Cheredanine

Yes mate (and currently their focus is bi-copters) - the reason being both bi and tri copters require servos, they have daily experience of this

aburn09

Thanks I'll link this post there then although technically I'm not using servos I'm using two way switches where motors one and two were which obviously did and still will work its just motors 3 and 4 (now 5 and 6 ) which just wont spin up.......If I leave the motors as they should be ie 1-4 (which will work) can anyone think of another method to trigger 2 switches through betaflight using the omnibus board ?

Cheredanine

Quote from: aburn09 on Sunday,August 26, 2018, 11:23:23
Thanks I'll link this post there then although technically I'm not using servos I'm using two way switches where motors one and two were which obviously did and still will work its just motors 3 and 4 (now 5 and 6 ) which just wont spin up.......If I leave the motors as they should be ie 1-4 (which will work) can anyone think of another method to trigger 2 switches through betaflight using the omnibus board ?

Appreciate that mate but still pwm output,
You could try mapping specific stuff to specific pads and triggering the stuff, but what “stuff” I dunno