Welcome to Multi-Rotor UK. Please login or sign up.

Friday,December 13, 2019, 00:07:56

Login with username, password and session length

Shoutbox

Bad Raven:
02 Dec 2019 20:03:50
Only if the battery is fully charged, leak a few volts and it'll be fine.......
Andy7:
02 Dec 2019 17:19:55
If yo fly a Mavic Mini and get over a gramme of mud on it, do you have to register it?  :rofl:
hoverfly:
02 Dec 2019 08:38:56
Not a problem i've had a body mod, I think of Jean Harlow naked on a trampoline  and the new antenna  extends automatically..   :whistling:
Andy7:
29 Nov 2019 17:17:37
That'll play hell with your FPV signal. :rofl:
hoverfly:
29 Nov 2019 17:10:20
Won't get me i'm wearing my tin foil hat... :wack0
Andy7:
29 Nov 2019 14:19:03
Because GOVERNMENT SPY DRONES are watching us! :frantic:
hoverfly:
29 Nov 2019 11:41:22
BBC News this am ..only 50% of people have registered  for the  CAA  scheme.. If people haven't registered  how do they know it's 50%.. :shrug:
ched:
28 Nov 2019 20:16:14
Very very quiet. I am missing chatting :-( Must be the weather....
Gaza07:
25 Nov 2019 08:28:26
Forums very quiet  :shrug:
ched:
18 Oct 2019 11:25:16
Sounds good yama. Would love to see some images. 3d models sound cool too
Members
Stats
  • Total Posts: 197224
  • Total Topics: 19890
  • Online Today: 49
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 43
Total: 43

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

twitch and flip from hover

Started by Stickman, Wednesday,July 25, 2018, 18:19:55

Previous topic - Next topic

Stickman

Hi all, I wonder if anyone can help with a fault I'm seeing on my new (first) build?  I lift off into a hover and the quad begins to twitch then flips over. 

Specs are cb 2.5in frame, emax 1106 6000kv (soft mounted), Furious piko OSD (soft mounted), spedix GS25 BLheli32 4in1, Gemfan 2540 props, Betaflight 3.2.5, 8k/8k, min throttle at 8% (tried 4.5 and 6.5%), DShot1200

I thought it was min throttle but 8% idle hasn't fixed it.  Any ideas much appreciated as I'm baffled and frustrated!!

hoverfly

Start by checking motor position and rotation,  , a motor may go in the right direction but if it's in the wrong position
the quad will flip. Basic error and very common.
Reptile folder , alien 500 , F/ Shark Attitudes,
 .Tarot 650, Air-rio Kinetic.. DX9  Various wings and planks.. Taranis x9D+..Mavic..Armattan.. Chameleion...
Massive over draught.....

Stickman

Thanks! Will give it a try and report back...

Cheredanine

Quote from: Stickman on Wednesday,July 25, 2018, 18:19:55
Hi all, I wonder if anyone can help with a fault I'm seeing on my new (first) build?  I lift off into a hover and the quad begins to twitch then flips over. 

Specs are cb 2.5in frame, emax 1106 6000kv (soft mounted), Furious piko OSD (soft mounted), spedix GS25 BLheli32 4in1, Gemfan 2540 props, Betaflight 3.2.5, 8k/8k, min throttle at 8% (tried 4.5 and 6.5%), DShot1200

I thought it was min throttle but 8% idle hasn't fixed it.  Any ideas much appreciated as I'm baffled and frustrated!!

Yeah ok first point, dshot doesn’t use min throttle. Did you mean digital idle?
Second there is a hell of a lot of soft mounting there, soft mounting acts like a low pass filter, a little is good, too much is very bad

Still quad shouldn’t flip. (If I am clear, it takes off and hovers, then things start to go wrong?)
It doesn’t sound like digital idle, you are not at zero throttle.

When I have seen this behaviour before it has been with 4in 1escs and there have been issues with the motor wire solders to the ESCs (eg dry joints, not enough solder or almost shorting)

Stickman

Wednesday,July 25, 2018, 19:32:09 #4 Last Edit: Wednesday,July 25, 2018, 19:45:39 by Stickman
Thanks!  Poor soldering is a possibility as I haven't had much practice; I'll check the joints...I can flip the TPU arm protectors over to take out the motor soft mounting, but the FC would be tricky because it sits on silicone inserts.

I'm probably misusing terms - I was reading an article about raising min throttle but the only setting I could see in that area of Betaflight was an idle percentage, which sounds like the one you mention.  It was at 4.5% but I tried 6.5 and 8% to no avail.

Yes, it takes off, hovers, and responds to commands in the right sense but it sounds like a motor begins to "sputter" and it progresses into a flip over.


Cheredanine

Quote from: Stickman on Wednesday,July 25, 2018, 19:32:09
Thanks!  Poor soldering is a possibility as I haven't had much practice; I'll check the joints...I can flip the TPU arm protectors over to take out the motor soft mounting, but the FC would be tricky because it sits on silicone inserts.

Silicon inserts on the F.C. are fine. Just stick with them mate
Quote
I'm probably misusing terms - I was reading an article about raising min throttle but the only setting I could see in that area of Betaflight was an idle percentage, which sounds like the one you mention.  It was at 4.5% but I tried 6.5 and 8% to no avail.

Min throttle is only applicable to oneshot, dshot uses digital idle, 4.5% is generally too high. If it was too low it would only effect when the throttle is zeroed, not in a hover, stick with 4.5%
Quote
Yes, it takes off, hovers, and responds to commands in the right sense but it sounds like a motor begins to "sputter" and it progresses into a flip over.

Just check your props are tight, but strongly suspect the motorwire solder joints to the ESCs

hoverfly

Check the motor mounting screws haven't damaged the windings.
Reptile folder , alien 500 , F/ Shark Attitudes,
 .Tarot 650, Air-rio Kinetic.. DX9  Various wings and planks.. Taranis x9D+..Mavic..Armattan.. Chameleion...
Massive over draught.....

Cheredanine

Quote from: hoverfly on Thursday,July 26, 2018, 08:59:27
Check the motor mounting screws haven't damaged the windings.

Also possible but would produce massive heat in motor and tends to cause twitch at bottom more than anything else, would expect getting into a hover would be difficult and twitching would be noticable whilst doing so

Stickman

Thanks for all the help folks, much appreciated!  I'm hoping to have a look at the soldering tonight or tomorrow (real life permitting  ;D) so I'll let you know.  Famous last words, but I was super careful to measure the motor screws and you can see through the motor mounts and there aren't any threads sticking through, so fingers crossed they're OK  :crossfingers:

Stickman

IT WORKS!!  ::) re-soldered two motor wires and I'm in business.
Thanks both for all your help - amazing knowledge and community spirit!  :notworthy:

ched

Quote from: Stickman on Thursday,July 26, 2018, 19:28:25
IT WORKS!!  ::) re-soldered two motor wires and I'm in business.
Thanks both for all your help - amazing knowledge and community spirit!  :notworthy:

Well done. Now don't forget to show us some video to prove it works  ::)
I try :-)