Welcome to Multi-Rotor UK. Please login or sign up.

Wednesday,July 08, 2020, 00:39:07

Login with username, password and session length

Shoutbox

Andy7:
07 Jul 2020 14:01:29
... I could ask how you knoiw this... but I would regret it.
hoverfly:
07 Jul 2020 11:53:34
Little known fact, if you push a runner bean seed up your nose the moisture will cause it to germinate, and expand.You wont get any beans though just  two black eyes. :o
Andy7:
04 Jul 2020 13:16:48
VIDEO or it didn't happen!! :) Nice going though, keep it up!
Bad Raven:
02 Jul 2020 19:46:48
 ~~
whoelseisbored (LiamHowe89):
02 Jul 2020 17:45:19
Sounds basic but I'm happy with it  :laugh:
whoelseisbored (LiamHowe89):
02 Jul 2020 17:45:05
Managed a split s :D
badger1:
28 Jun 2020 12:29:49
BF GPS Rescue mode configured - what could possibly go wrong?   :o
badger1:
27 Jun 2020 21:07:37
and can't make it back to where you take off from   :laugh:
badger1:
27 Jun 2020 21:07:04
it's too windy if you fly downwind
Bad Raven:
27 Jun 2020 20:51:32
I have done Dynamic Soaring in over 55mph, and quad flying in over 25mph with the right equipment.
Members
  • Total Members: 8117
  • Latest: DarylW
Stats
  • Total Posts: 198979
  • Total Topics: 20051
  • Online Today: 30
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 22
Total: 22

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

twitch and flip from hover

Started by Stickman, Wednesday,July 25, 2018, 18:19:55

Previous topic - Next topic

Stickman

Hi all, I wonder if anyone can help with a fault I'm seeing on my new (first) build?  I lift off into a hover and the quad begins to twitch then flips over. 

Specs are cb 2.5in frame, emax 1106 6000kv (soft mounted), Furious piko OSD (soft mounted), spedix GS25 BLheli32 4in1, Gemfan 2540 props, Betaflight 3.2.5, 8k/8k, min throttle at 8% (tried 4.5 and 6.5%), DShot1200

I thought it was min throttle but 8% idle hasn't fixed it.  Any ideas much appreciated as I'm baffled and frustrated!!

hoverfly

Start by checking motor position and rotation,  , a motor may go in the right direction but if it's in the wrong position
the quad will flip. Basic error and very common.
Reptile folder , alien 500 , F/ Shark Attitudes,
 .Tarot 650, Air-rio Kinetic.. DX9  Various wings and planks.. Taranis x9D+..Mavic..Armattan.. Chameleion...
Massive over draught.....

Stickman

Thanks! Will give it a try and report back...

Cheredanine

Quote from: Stickman on Wednesday,July 25, 2018, 18:19:55
Hi all, I wonder if anyone can help with a fault I'm seeing on my new (first) build?  I lift off into a hover and the quad begins to twitch then flips over. 

Specs are cb 2.5in frame, emax 1106 6000kv (soft mounted), Furious piko OSD (soft mounted), spedix GS25 BLheli32 4in1, Gemfan 2540 props, Betaflight 3.2.5, 8k/8k, min throttle at 8% (tried 4.5 and 6.5%), DShot1200

I thought it was min throttle but 8% idle hasn't fixed it.  Any ideas much appreciated as I'm baffled and frustrated!!

Yeah ok first point, dshot doesn’t use min throttle. Did you mean digital idle?
Second there is a hell of a lot of soft mounting there, soft mounting acts like a low pass filter, a little is good, too much is very bad

Still quad shouldn’t flip. (If I am clear, it takes off and hovers, then things start to go wrong?)
It doesn’t sound like digital idle, you are not at zero throttle.

When I have seen this behaviour before it has been with 4in 1escs and there have been issues with the motor wire solders to the ESCs (eg dry joints, not enough solder or almost shorting)

Stickman

Wednesday,July 25, 2018, 19:32:09 #4 Last Edit: Wednesday,July 25, 2018, 19:45:39 by Stickman
Thanks!  Poor soldering is a possibility as I haven't had much practice; I'll check the joints...I can flip the TPU arm protectors over to take out the motor soft mounting, but the FC would be tricky because it sits on silicone inserts.

I'm probably misusing terms - I was reading an article about raising min throttle but the only setting I could see in that area of Betaflight was an idle percentage, which sounds like the one you mention.  It was at 4.5% but I tried 6.5 and 8% to no avail.

Yes, it takes off, hovers, and responds to commands in the right sense but it sounds like a motor begins to "sputter" and it progresses into a flip over.


Cheredanine

Quote from: Stickman on Wednesday,July 25, 2018, 19:32:09
Thanks!  Poor soldering is a possibility as I haven't had much practice; I'll check the joints...I can flip the TPU arm protectors over to take out the motor soft mounting, but the FC would be tricky because it sits on silicone inserts.

Silicon inserts on the F.C. are fine. Just stick with them mate
Quote
I'm probably misusing terms - I was reading an article about raising min throttle but the only setting I could see in that area of Betaflight was an idle percentage, which sounds like the one you mention.  It was at 4.5% but I tried 6.5 and 8% to no avail.

Min throttle is only applicable to oneshot, dshot uses digital idle, 4.5% is generally too high. If it was too low it would only effect when the throttle is zeroed, not in a hover, stick with 4.5%
Quote
Yes, it takes off, hovers, and responds to commands in the right sense but it sounds like a motor begins to "sputter" and it progresses into a flip over.

Just check your props are tight, but strongly suspect the motorwire solder joints to the ESCs

hoverfly

Check the motor mounting screws haven't damaged the windings.
Reptile folder , alien 500 , F/ Shark Attitudes,
 .Tarot 650, Air-rio Kinetic.. DX9  Various wings and planks.. Taranis x9D+..Mavic..Armattan.. Chameleion...
Massive over draught.....

Cheredanine

Quote from: hoverfly on Thursday,July 26, 2018, 08:59:27
Check the motor mounting screws haven't damaged the windings.

Also possible but would produce massive heat in motor and tends to cause twitch at bottom more than anything else, would expect getting into a hover would be difficult and twitching would be noticable whilst doing so

Stickman

Thanks for all the help folks, much appreciated!  I'm hoping to have a look at the soldering tonight or tomorrow (real life permitting  ;D) so I'll let you know.  Famous last words, but I was super careful to measure the motor screws and you can see through the motor mounts and there aren't any threads sticking through, so fingers crossed they're OK  :crossfingers:

Stickman

IT WORKS!!  ::) re-soldered two motor wires and I'm in business.
Thanks both for all your help - amazing knowledge and community spirit!  :notworthy:

ched

Quote from: Stickman on Thursday,July 26, 2018, 19:28:25
IT WORKS!!  ::) re-soldered two motor wires and I'm in business.
Thanks both for all your help - amazing knowledge and community spirit!  :notworthy:

Well done. Now don't forget to show us some video to prove it works  ::)
I try :-)