User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

MultiRotorUK ShoutBox

Refresh History
  • Mike Bagnall: My taranis must be wrong or broken it's brand new
    Today at 14:13:47
  • Reman: Weather's way too ropey to go flying near Bristol today, But it's not too wet to go wading through a muddy field to walk my Labrador though........ Damn it ! LOL !
    August 12, 2018, 11:17:55
  • Bad Raven: They flew quads and planes
    August 10, 2018, 12:59:11
  • Bad Raven: Took some boys flying, they got an hour and a half before the wetness loomed.
    August 10, 2018, 12:58:53
  • mo_miah: lots of rain yesterday with some localised flooding, some more rain today, quads broken anyway so no flying for me, need a new frame :(
    August 10, 2018, 10:06:02
  • hoverfly: Spoke to soon there is some strange wet stuff falling from the sky. and my runner beans are making slurping noises..... ::)
    August 10, 2018, 09:30:31
  • Bad Raven: Bring a sponge.......
    August 10, 2018, 06:07:43
  • hoverfly: Not a drop  here the garden is like a desert..
    August 09, 2018, 21:57:22
  • Bad Raven: BIG thunderstorm with lots of cloud to cloud red and the occasional very close ground strikes.
    August 09, 2018, 21:12:51
  • Clarkie 22: Bad Crash and a poorly rotor arm :/
    August 06, 2018, 18:31:53
  • Bad Raven: The screamer alarm went off, usually early warning, but nit this time, didn't make it back to patch.
    August 06, 2018, 17:35:29
  • Bad Raven: Think I ran this pack a little close, just had to put 2359 into a 2200 pack. OOPS!
    August 06, 2018, 17:33:21
  • Bad Raven: I think nthere's agreat similarity, both talentless and over hyped.
    August 06, 2018, 14:21:58
  • Bajadre: @ Reman yeah matey haha
    August 06, 2018, 14:18:59
  • shawdreamer: keep that up and the only thing you'll "get" is commited.
    August 06, 2018, 13:48:17
  • hoverfly: Weird that i get..marianne faithfull broken english..... :shrug: :shrug:
    August 06, 2018, 13:22:23
  • Gav: :hmm:
    August 06, 2018, 11:33:20
  • DarkButterfly: Nope, that's just you ::)
    August 06, 2018, 10:43:08
  • shawdreamer: nope..... thats erm....... probably just you :huh
    August 06, 2018, 10:37:01
  • Reman: Is it just me, Or whilst browsing Tattu packs online, Does anyone else get that song "All the things you said" stuck in their mind ? :)
    August 06, 2018, 09:57:59

Who's Online

Theme Selection



Forum Default

Permanently

Author Topic: Continuous beep after startup?  (Read 450 times)

Offline ched999uk

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 2718
  • Liked: 619
  • Country: gb
Continuous beep after startup?
« on: June 04, 2018, 10:02:51 »
I am running bf 3.2.2 and sometimes when I plug in a charged battery I get the normal esc startup beeps but then get a continuous beep from the buzzer. My tx is receiving telemetry so rx is working. If I unplug battery and plug in again (sometimes it takes 2 tries) it normally works fine.

Any thoughts what might be the issue?
Cheers

Offline UrbanFPV

  • Trade Count: (0)
  • Full Member
  • ***
  • Posts: 141
  • Liked: 87
  • Country: 00
Re: Continuous beep after startup?
« Reply #1 on: June 04, 2018, 10:13:06 »
You could try turning off all the beep configs in betaflight and gradually turn each one back on to isolate the offending one.

There are some you won't need on anyway.  I've got this with BF 3.3.x on one of my quads, but I think I damaged the FC due to dodgy soldering (accidently got some solder across a couple of the pins on the microprocessor).  I solved by removing the beeper  for now and using the dshot esc beeper instead :-/
Talon SVX
Tyrant S 215
Aurora 90
GEPRC Sparrow (Mo Sparah)
Chameleon Ti
Mavic Pro
QX7s
Aomway Commanders
Youtube : https://www.youtube.com/channel/UCo9rqz1V6XIaU3xikNDzjKg

Offline Jakalas

  • Trade Count: (0)
  • Full Member
  • ***
  • Posts: 173
  • Liked: 157
  • Country: gb
  • Say what...?
Re: Continuous beep after startup?
« Reply #2 on: June 04, 2018, 10:31:22 »
Could also be that the current sensor is not reading correctly and is detecting to high input voltage, resulting in the warning beeps.

The fact that it goes away after unplugging and re-plugging the battery a couple of times could mean that it's very close to the threshold and by slightly running the battery voltage down is causing it to drop back into the nominal voltage threshold according to the FC, hence why it stops beeping.

Have a look at the Power & Battery tab in Betaflight for the settings, or alternatively as UrbanFPV guested, disable the BAT settings under Beeper Configuration section on the Configurations tab.

Offline mitchell.atheis

  • Trade Count: (0)
  • Full Member
  • ***
  • Posts: 128
  • Liked: 35
  • Country: gb
Re: Continuous beep after startup?
« Reply #3 on: June 04, 2018, 16:43:28 »
I have had a recent problem with my buzzer like this, Since i enabled 'Dshot reverse motors' on my quads, then disabled it soon after not getting it to work properly. I now get a constant beeping when i plug a lipo in until my Tx is turned on and all the sticks are in default position  :hmm:

Offline ched999uk

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 2718
  • Liked: 619
  • Country: gb
Re: Continuous beep after startup?
« Reply #4 on: June 04, 2018, 16:49:51 »
I have had a recent problem with my buzzer like this, Since i enabled 'Dshot reverse motors' on my quads, then disabled it soon after not getting it to work properly. I now get a constant beeping when i plug a lipo in until my Tx is turned on and all the sticks are in default position  :hmm:
Cheers.
I think that is the standard behaviour. It is to remind you to turn on tx Before plugging battery in!!!

My tx is on and rx is sending telemetry data back to tx. So I know tx/rx is OK.

Cheers.

Offline mitchell.atheis

  • Trade Count: (0)
  • Full Member
  • ***
  • Posts: 128
  • Liked: 35
  • Country: gb
Re: Continuous beep after startup?
« Reply #5 on: June 04, 2018, 17:02:16 »
The reason i said that is because i think there must be some hidden buzzer options which triggers it off, I have all my buzzer options turned off in the BF config and it's still going off. Unless there is some sort of glitch ?

Your problem sounds random as opposed to my situation though.

Offline Lamaule

  • Trade Count: (0)
  • Sr. Member
  • ****
  • Posts: 873
  • Liked: 567
  • Country: 00
  • Tricopter, one prop short of a Quadcopter
    • My YouTube Channel
Re: Continuous beep after startup?
« Reply #6 on: June 04, 2018, 17:50:49 »
This will be the battery scaling factor in betaflight. I had this and they changed the default value recently. It causes the voltage sensor to read over 16.8v if you're 4s - mine was 17.1v. this causes an alarm to be triggered. Lower the scaling factor and you'll be fine. It should read 16.8 on a full battery and no more!
I am running bf 3.2.2 and sometimes when I plug in a charged battery I get the normal esc startup beeps but then get a continuous beep from the buzzer. My tx is receiving telemetry so rx is working. If I unplug battery and plug in again (sometimes it takes 2 tries) it normally works fine.

Any thoughts what might be the issue?
Cheers

Sent from my VTR-L09 using Tapatalk


Offline mitchell.atheis

  • Trade Count: (0)
  • Full Member
  • ***
  • Posts: 128
  • Liked: 35
  • Country: gb
Re: Continuous beep after startup?
« Reply #7 on: June 04, 2018, 22:40:35 »
This will be the battery scaling factor in betaflight. I had this and they changed the default value recently. It causes the voltage sensor to read over 16.8v if you're 4s - mine was 17.1v. this causes an alarm to be triggered. Lower the scaling factor and you'll be fine. It should read 16.8 on a full battery and no more!
Sent from my VTR-L09 using Tapatalk
Would never of thought to look at this, thanks!

Offline Lamaule

  • Trade Count: (0)
  • Sr. Member
  • ****
  • Posts: 873
  • Liked: 567
  • Country: 00
  • Tricopter, one prop short of a Quadcopter
    • My YouTube Channel
Re: Continuous beep after startup?
« Reply #8 on: June 04, 2018, 22:50:12 »
Lol, me neither. Took me months to resolve my beeping quad! 🤣
Would never of thought to look at this, thanks!

Sent from my VTR-L09 using Tapatalk


Offline atomiclama

  • Trade Count: (3)
  • Hero Member
  • *****
  • Posts: 2471
  • Liked: 782
  • Country: gb
  • Uhh! What's that then, Oh! new project.
Re: Continuous beep after startup?
« Reply #9 on: June 05, 2018, 07:32:48 »
Could be that the micro on the FC is not starting up properly.
These will help work it out.

What does the buzzer do at startup ?

Does it do multiple beeps then stay on or does it just go on straight away.

What does the status led do at startup?

If you get it into the continuous beep could you then attach a pc to the USB port and see if it is running.

Wasdale X, Ow that hurt

Offline ched999uk

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 2718
  • Liked: 619
  • Country: gb
Re: Continuous beep after startup?
« Reply #10 on: June 09, 2018, 19:31:14 »
This will be the battery scaling factor in betaflight. I had this and they changed the default value recently. It causes the voltage sensor to read over 16.8v if you're 4s - mine was 17.1v. this causes an alarm to be triggered. Lower the scaling factor and you'll be fine. It should read 16.8 on a full battery and no more!
Sent from my VTR-L09 using Tapatalk
Looks like you were correct! Changed scaling factor by 1 and no more continuous beep on battery connection.
All perfect.
Well would have been until on last 10 seconds of last batt quad dropped. Then another continuous beep, rx signal lost!!!
So looks like I have a little tinkering to do tonight  :smiley:

So thanks very much Lamaule.

Offline Lamaule

  • Trade Count: (0)
  • Sr. Member
  • ****
  • Posts: 873
  • Liked: 567
  • Country: 00
  • Tricopter, one prop short of a Quadcopter
    • My YouTube Channel
Re: Continuous beep after startup?
« Reply #11 on: June 09, 2018, 19:59:32 »
Looks like you were correct! Changed scaling factor by 1 and no more continuous beep on battery connection.
All perfect.
Well would have been until on last 10 seconds of last batt quad dropped. Then another continuous beep, rx signal lost!!!
So looks like I have a little tinkering to do tonight  :smiley:

So thanks very much Lamaule.
Hey ched - really pleased we got this sorted. It's such an annoying issue and it took me ages to work it out for myself. So pleased it's helped you!

Sent from my VTR-L09 using Tapatalk


Offline ched999uk

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 2718
  • Liked: 619
  • Country: gb
Re: Continuous beep after startup?
« Reply #12 on: June 09, 2018, 21:45:33 »
RX all fixed. It was the connector for rx to FC. It had wiggled loose - too many crashes  ::)
So all ready to go for tomorrow  ::)

Offline ched999uk

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 2718
  • Liked: 619
  • Country: gb
Re: Continuous beep after startup?
« Reply #13 on: June 24, 2018, 21:50:52 »
Beeping is back again when I finally got some spare time to fly!!! :banghead: :banghead:

This time I had a micro usb, OTG and SpeedyBee (SBee) on my Andrid phone at the ready.

So when the continuous beeping happens when powering on I can't actually connect SBee to the FC! When I eventually get the beeping to stop (battery connected and then disconnected a number of times) SBee connects no problem! When it's beeping SBee shows the usb driver SMT... (cant remember exact) and I click to connect but it times out!

Basically it starts to boots and you get the initialisation beeps then instead of the esc 'ready' beep tones I then get a constant beep  :banghead:

So looks like something is stopping the FC booting properly. I even tried using a used battery but still beeps so it's not voltage!

Any ideas?
Cheers

Offline hoverfly

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 2697
  • Liked: 1145
  • Country: gb
  • Quads, lots of quads
Re: Continuous beep after startup?
« Reply #14 on: June 25, 2018, 09:15:37 »
A very crude method  but turn off battery monitoring  :hmm:
Reptile folder , alien 500 , F/ Shark Attitudes,
 .Tarot 650, Air-rio Kinetic.. DX9  Various wings and planks.. Taranis x9D+..Mavic..Armattan.. Chameleion...
Massive over draught.....

Offline atomiclama

  • Trade Count: (3)
  • Hero Member
  • *****
  • Posts: 2471
  • Liked: 782
  • Country: gb
  • Uhh! What's that then, Oh! new project.
Re: Continuous beep after startup?
« Reply #15 on: June 25, 2018, 09:37:52 »
Any ideas?

Your FC is knackered, get a new one.

Sorry unless you want to remove the FC and check over all the joints and go to quite some length to fault find, I think a replacement is yo best bet.
Wasdale X, Ow that hurt

Offline ched999uk

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 2718
  • Liked: 619
  • Country: gb
Re: Continuous beep after startup?
« Reply #16 on: June 25, 2018, 10:56:14 »
Cheers.
I was thinking that I need a new FC as the OSD has never worked on this one!
I will try and disable all battery and current monitoring to keep it going till I can get a new FC.  ::)

Cheers everyone.

Offline shawdreamer

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 1335
  • Liked: 766
  • Country: gb
  • Tricopter, one prop short of a Quadcopter
Re: Continuous beep after startup?
« Reply #17 on: June 25, 2018, 12:10:50 »
continuous beeping after start up???

I know what that is!..................






.............







550 custom H-copter (redesigned)
zmr250
Reaper250 V.1
Podracer v2
zmr250Hybrid
250 Twinboard
Project Sparkie (under repair)
https://www.thingiverse.com/shawdreamer/designs