Welcome to Multi-Rotor UK. Please login or sign up.

Tuesday,November 19, 2019, 08:05:52

Login with username, password and session length

Shoutbox

ched:
18 Oct 2019 11:25:16
Sounds good yama. Would love to see some images. 3d models sound cool too
yama:
18 Oct 2019 10:32:38
i might have to do a review. the 21mp camera is excellent at producing high quality 3d models for mapping.
ched:
10 Oct 2019 16:56:16
Show us some picys and maybe post a review in a thread?
yama:
09 Oct 2019 14:13:10
must admit this anafi is tiny and looks like a toy in a lunchbox but performs like a professional product.
yama:
09 Oct 2019 14:11:52
went ahead and bought one. about to find out if the 21mp camera improves photogrammetry surveys.
ched:
08 Oct 2019 17:14:17
Not tried a parrot anafi but I thought parrot were stopping 'drone' production?
yama:
07 Oct 2019 13:25:37
anyone tried a parrot anafi?
Gaza07:
26 Sep 2019 11:33:59
We know a song about that dont we  :D
Andy7:
26 Sep 2019 08:38:34
 :laugh:
Bad Raven:
26 Sep 2019 07:10:39
Adopts Australian accent "Black, that's not Black, its a dirty grey, THIS is Black........"   :D
Members
Stats
  • Total Posts: 197138
  • Total Topics: 19878
  • Online Today: 53
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 2
Guests: 53
Total: 55

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

Uart6 stopped working after bataflight update

Started by dayshaddow, Friday,June 01, 2018, 13:21:53

Previous topic - Next topic

dayshaddow

Hi
I did my first ever bataflight update on my f4 v3 last night and it appears uart6 6 which is how I am using ibus seems to have stopped working.in bataflight inputs from the sticks has nothing moving on screen.i will get the update date when I get home from work if that helps.i picked the f4 controller from the list.i did read it might be the inverter..i found an update hex file to try tonight.any suggestions
Bad things happen because I am dumb

Cheredanine

Firstly you need the right target, you don’t just pick a board, you have to have exactly the right one, if you are unsure, go to the cli and type “version”, this will not just tell you the release number but the target (eg “bluejay f4”
Then you need to know what target your board should be using (which board is it? Where did you get it from?

Secondly, even if the target is right, you need to set up the uart for rx
That means:
On the ports tab set the uart to serial rx
On the config tab make sure the right protocol is selected on the left about half way down
On the receiver tab make sure the channel map is correct.

On all those pages you need to hit save if you change anything

Cheredanine

Ps you will have to set up all other stuff after an upgrade also

mo_miah

Quote from: Cheredanine on Friday,June 01, 2018, 13:59:11
Firstly you need the right target, you don’t just pick a board, you have to have exactly the right one, if you are unsure, go to the cli and type “version”, this will not just tell you the release number but the target (eg “bluejay f4”
Then you need to know what target your board should be using (which board is it? Where did you get it from?

Secondly, even if the target is right, you need to set up the uart for rx
That means:
On the ports tab set the uart to serial rx
On the config tab make sure the right protocol is selected on the left about half way down
On the receiver tab make sure the channel map is correct.

On all those pages you need to hit save if you change anything


I was just about to say that, great minds...

dayshaddow

The ports setting are correct as it was the first thing I checked.i even restored my setting from a working backup to double check.i will check the version and report back in a few hours
Bad things happen because I am dumb

Cheredanine

restoring from a working backup is a bad idea, variable names etc change between versions. Backups are only really effective for the same version.
Suggest you reflash and set it up again without using a backup

dayshaddow

I missed out it's a omnibus fc
So it's an omnibus f4 v3 fc.
Bad things happen because I am dumb

dayshaddow

Ok no worries.i did resetup up first and then when the issue was noticed resetup up again AND then chose to restore.perhaps forth time lucky
Bad things happen because I am dumb

Cheredanine

Ok mate, so you need to be a bit careful, there are a lot of variants of omnibus, many are f4 and several have a v3.
There are at least 3 separate omnibus f4 targets (omnibusf4, omnibusf4fw and omnibusf4sd) as well as a generic one, each will different pin out definitions for the GPU, you need to know which to use

However, just in case can you take screen shots of ports tab, config tab and receiver tab?

dayshaddow

I picked the first option being f4...almost finnished work so I will get on and get back to flying 😁
Bad things happen because I am dumb

Cheredanine

Quote from: dayshaddow on Friday,June 01, 2018, 15:16:43
I picked the first option being f4...almost finnished work so I will get on and get back to flying 😁

Pretty sure the second is for the firework variant
If you post screenshots when you ge5 chance will check them over

dayshaddow

Fingers crossed it's an easy fix.would be nice to get a test hover done tonight then a few flights Saturday so I am happy enough to open the fpv goggles box Sunday.i have a feeling that I will have my first drone crash in a few days.seems well built 😂
Bad things happen because I am dumb

dayshaddow

Ok so this is the version
OmnibusF4 (obf4)3.3.2 May 4 2018.i am guessing that using what I already knew about the fc picking the option 1 omnibus f4 was correct
Bad things happen because I am dumb

dayshaddow

Ok no idea why the thread was locked.i did a video so you guys can see how annoying this has become
Bad things happen because I am dumb

Cheredanine

Sunday,June 03, 2018, 16:55:35 #14 Last Edit: Sunday,June 03, 2018, 16:59:41 by Cheredanine
Pmsl
Ok here is your problem
Each screen has its own “save” (or in the case of the ports tab and a few others, “save and reboot”
Typing save on the cli screen only saves cli commands you have typed.
Before you leave the ports, or any other tab. On the bottom right of the the page there is a save button, that is how you save your settings on that page
(You need to scroll down)

dayshaddow

Thank God for you.perhaps it shall fly again..respect 😎
Bad things happen because I am dumb