User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

MultiRotorUK ShoutBox

Refresh History
  • Reman: Like I said, In the past I've had a handful of packs "Go off" at me like fireworks after bad crashes (Usually with RC helis), So it's hard to get that image out of your head while stripping down Li-Po's. :)
    Today at 11:22:54
  • shawdreamer: the horror stories will always incite worry when messing about with Lipo's but its the same as everything else when working on electronics alike, alsong as your careful and methodical there's very little to panic about, I regularly recycle 4s's with a single dead cell into usable 3s packs, end of the days its alot more economical, safer and enviro friendly than having to bin them....just a pain that the dead cell is NEVER one of the outer cells so you always end up having to strip a good cell off to get at the bad cell before putting it back afterwards, its like dropping toast, it'll always land buttered side down and inevitably covered in pet fur :angry:
    Today at 00:11:16
  • Reman: Just did the one electrical job that still scares me. I dismantled some Lipo's with knacked cells and built usable packs out of the good cells. I've had packs go "VOOOOOOSH" at me in the past so I'm always slightly scared of having bare lipo contacts anywhere near what I'm working on, But all appears to have gone well and one of them is currently doing a charge/discharge cycle to make sure nothings a miss. :)
    January 20, 2019, 22:28:43
  • Reman: My original Dremel Pro made it to 14 years of heavy weekend use (And abuse) before it crocked. Dismantled that but it turned out to be a "Control module" fault, And Dremel made it ni on impossible to get into that without pooching it completely. :(
    January 20, 2019, 22:17:27
  • ched999uk: BR  ::)
    January 16, 2019, 22:26:54
  • Bad Raven: That's a warrnty claim if ever I heard one....
    January 16, 2019, 20:32:55
  • ched999uk: My 28 year old 12v 35w Weller soldering iron failed  :( I didn't fancy forking out £100 for a new one. Stripped it down and found conductor snapped in cable. 10Mins later all back working great. :smiley: ::) I am very happy!!
    January 16, 2019, 17:23:06
  • shawdreamer: "look up there....its a drone!.....and whats this noise?..... no.....no..... it cant be!....NOOOOOOOO.......OOOOOOOOOOOOOPS I DID IT AGAIN, I PLAYED WITH YOUR HEAR....."
    January 10, 2019, 14:17:24
  • shawdreamer: <starts downloading britney spears albums and preping his large frame to carry a PA system>
    January 10, 2019, 14:15:08
  • Bajadre: defo steveo :) we should get loads of drones together up there so how they handle more that one lol
    January 08, 2019, 19:39:07
  • steveo9007: its all a ploy to get who ever has won the contract for geofencing the airport in, i reckon  ::)
    January 08, 2019, 18:38:26
  • Bajadre: more lies hope they prepped the police staement already lol
    January 08, 2019, 18:27:49
  • Bad Raven: Take Offs resumed
    January 08, 2019, 18:24:45
  • steveo9007: yeah not good though is it..what will come out of this now its happened at both major airports  :o
    January 08, 2019, 18:05:13
  • Bad Raven: Planes still landing, appears take offs affected
    January 08, 2019, 18:02:47
  • steveo9007: newsflash people, drone sighting at Heathrow Airport  just received on news app..
    January 08, 2019, 17:54:07
  • shawdreamer: tsk x2, just checked my thingiverse messages too... another a8 owner asking if one of my designs would work with his printer.... I said no as its not fire proof.... now he seems confused :confused:
    January 05, 2019, 15:35:09
  • hoverfly: Some people,  he's probably heading for a Darwin award... :laugh:
    January 05, 2019, 13:58:53
  • shawdreamer: tsk.... a new Anet A8 owner asking for mod suggestions for his xmas first printer on thingiverse... I suggested a fire suppression system or atleast a wall mount for a fire extinguisher and smoke alarm..... he removed my post.... no helping some people :shrug:
    January 05, 2019, 12:42:05
  • Reman: I did double check it with a metre (Mainly because I knew if I didn't check the polarity this would be the time the manufacturer had gone off script and put the negative in the middle of the coax) and felt slightly cheated because it was only making 19.7 volts. :)
    January 04, 2019, 14:01:11

Who's Online

Theme Selection



Forum Default

Permanently

Author Topic: Stuttering motor on idle.  (Read 417 times)

Offline Andy7

  • Global Moderator
  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 1430
  • Liked: 830
  • Country: gb
    • The Tracker
Stuttering motor on idle.
« on: May 14, 2018, 11:48:47 »
Noticed yesterday that one of my motors is stuttering on idle when I arm.
Goes away as soon as I put any throttle in, and hovers perfectly.
I had an unexpected flip-out on Sunday, though I think that may have been a failsafe due to a chewed antenna.

Possible sign of an ESC beginning to go bad? Spedix ES20s.
Motor spins freely, no dirt in it, props on tightly.
ZMR200 | EMAX 2206 2300kv | XSRF4PO(BF) | FatShark Dom V3 | Spedix ES25 | 4S 1300mAh | 5045x3 PC HQ Props | FrSky QX7.
Hubsan X4 107 V2
YouTube: www.youtube.com/user/AndySevern7

Offline Lamaule

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 1198
  • Liked: 711
  • Country: 00
  • Tricopter, one prop short of a Quadcopter
    • My YouTube Channel
Re: Stuttering motor on idle.
« Reply #1 on: May 14, 2018, 11:53:34 »
Recalibrate your escs and make sure your idle up is high enough to spin all of them reliably. Props off while you're doing it!

Sent from my VTR-L09 using Tapatalk


Offline Andy7

  • Global Moderator
  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 1430
  • Liked: 830
  • Country: gb
    • The Tracker
Re: Stuttering motor on idle.
« Reply #2 on: May 14, 2018, 12:06:31 »
That was my initial thought - but do you NEED to recalibtate for OneShot / Dshot? Thought it was all digital?
ZMR200 | EMAX 2206 2300kv | XSRF4PO(BF) | FatShark Dom V3 | Spedix ES25 | 4S 1300mAh | 5045x3 PC HQ Props | FrSky QX7.
Hubsan X4 107 V2
YouTube: www.youtube.com/user/AndySevern7

Offline Lamaule

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 1198
  • Liked: 711
  • Country: 00
  • Tricopter, one prop short of a Quadcopter
    • My YouTube Channel
Re: Stuttering motor on idle.
« Reply #3 on: May 14, 2018, 12:10:36 »
Yeah, but I'd still start there. I've had some weird stuff happen in the past where settings have changed.  Occasionally I have had crashes where I have had had to reflash firmware. I think jakalas has had the same too.
That was my initial thought - but do you NEED to recalibtate for OneShot / Dshot? Thought it was all digital?

Sent from my VTR-L09 using Tapatalk


Offline Cheredanine

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 4990
  • Liked: 1393
  • Country: gb
  • Cleverly disguised as a responsible adult
Re: Stuttering motor on idle.
« Reply #4 on: May 14, 2018, 12:46:26 »
To be specific, you need to calibrate for oneshot/multishot, they are not digital. Dshot calibration doesn’t do anything.
Agree with firmware reflash, I have had crashes where doing that fixed issues
Other common causes -
mounting screws touching the windings.
Esc problem
Min_command too high
min-throttle/digital idle (one shot/dshot) too low
(Both of those should be fixed if you reflash)
Electrical short

Offline Andy7

  • Global Moderator
  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 1430
  • Liked: 830
  • Country: gb
    • The Tracker
Re: Stuttering motor on idle.
« Reply #5 on: May 14, 2018, 13:35:55 »
Running DSHOT 600. Motor idle throttle, set to 4.5% (8k Gyro, 2k PID loop)
All motors stutter at 1008... which is fair enough,
Stable at 1014


Armed on the bench (yep, no props!) seems fine.
Taking it out to the garden for a try.

ZMR200 | EMAX 2206 2300kv | XSRF4PO(BF) | FatShark Dom V3 | Spedix ES25 | 4S 1300mAh | 5045x3 PC HQ Props | FrSky QX7.
Hubsan X4 107 V2
YouTube: www.youtube.com/user/AndySevern7

Offline Andy7

  • Global Moderator
  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 1430
  • Liked: 830
  • Country: gb
    • The Tracker
Re: Stuttering motor on idle.
« Reply #6 on: May 14, 2018, 13:43:06 »
Hmmm... right as rain.  :hmm:

Only thing I did was to recalibrate the acc.
Must have just wanted some attention.  :shrug:
ZMR200 | EMAX 2206 2300kv | XSRF4PO(BF) | FatShark Dom V3 | Spedix ES25 | 4S 1300mAh | 5045x3 PC HQ Props | FrSky QX7.
Hubsan X4 107 V2
YouTube: www.youtube.com/user/AndySevern7

Offline Lamaule

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 1198
  • Liked: 711
  • Country: 00
  • Tricopter, one prop short of a Quadcopter
    • My YouTube Channel
Re: Stuttering motor on idle.
« Reply #7 on: May 14, 2018, 15:54:02 »
Glad you've sorted it! 
Hmmm... right as rain.  :hmm:

Only thing I did was to recalibrate the acc.
Must have just wanted some attention.  :shrug:

Sent from my VTR-L09 using Tapatalk


Offline Andy7

  • Global Moderator
  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 1430
  • Liked: 830
  • Country: gb
    • The Tracker
Re: Stuttering motor on idle.
« Reply #8 on: May 14, 2018, 16:17:32 »
Ahhh... but there's only ONE way to be TOTALLY sure that it's working properly. #sendit

 ::)
ZMR200 | EMAX 2206 2300kv | XSRF4PO(BF) | FatShark Dom V3 | Spedix ES25 | 4S 1300mAh | 5045x3 PC HQ Props | FrSky QX7.
Hubsan X4 107 V2
YouTube: www.youtube.com/user/AndySevern7

Offline Lamaule

  • Trade Count: (0)
  • Hero Member
  • *****
  • Posts: 1198
  • Liked: 711
  • Country: 00
  • Tricopter, one prop short of a Quadcopter
    • My YouTube Channel
Re: Stuttering motor on idle.
« Reply #9 on: May 14, 2018, 16:19:56 »
Ahhh... but there's only ONE way to be TOTALLY sure that it's working properly. #sendit

 ::)
No video, no proof!

Sent from my VTR-L09 using Tapatalk