Welcome to Multi-Rotor UK. Please login or sign up.

Wednesday,July 08, 2020, 00:19:39

Login with username, password and session length

Shoutbox

Andy7:
07 Jul 2020 14:01:29
... I could ask how you knoiw this... but I would regret it.
hoverfly:
07 Jul 2020 11:53:34
Little known fact, if you push a runner bean seed up your nose the moisture will cause it to germinate, and expand.You wont get any beans though just  two black eyes. :o
Andy7:
04 Jul 2020 13:16:48
VIDEO or it didn't happen!! :) Nice going though, keep it up!
Bad Raven:
02 Jul 2020 19:46:48
 ~~
whoelseisbored (LiamHowe89):
02 Jul 2020 17:45:19
Sounds basic but I'm happy with it  :laugh:
whoelseisbored (LiamHowe89):
02 Jul 2020 17:45:05
Managed a split s :D
badger1:
28 Jun 2020 12:29:49
BF GPS Rescue mode configured - what could possibly go wrong?   :o
badger1:
27 Jun 2020 21:07:37
and can't make it back to where you take off from   :laugh:
badger1:
27 Jun 2020 21:07:04
it's too windy if you fly downwind
Bad Raven:
27 Jun 2020 20:51:32
I have done Dynamic Soaring in over 55mph, and quad flying in over 25mph with the right equipment.
Members
  • Total Members: 8117
  • Latest: DarylW
Stats
  • Total Posts: 198979
  • Total Topics: 20051
  • Online Today: 30
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 28
Total: 28

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

Stuttering motor on idle.

Started by Andy7, Monday,May 14, 2018, 11:48:47

Previous topic - Next topic

Andy7

Noticed yesterday that one of my motors is stuttering on idle when I arm.
Goes away as soon as I put any throttle in, and hovers perfectly.
I had an unexpected flip-out on Sunday, though I think that may have been a failsafe due to a chewed antenna.

Possible sign of an ESC beginning to go bad? Spedix ES20s.
Motor spins freely, no dirt in it, props on tightly.
ZMR200 | EMAX 2206 2300kv | XSRF4PO(BF) | FatShark Dom V3 | Spedix ES25 | 4S 1300mAh | 5045x3 PC HQ Props | FrSky QX7.
Hubsan X4 107 V2
YouTube: www.youtube.com/user/AndySevern7

Lamaule

Recalibrate your escs and make sure your idle up is high enough to spin all of them reliably. Props off while you're doing it!

Sent from my VTR-L09 using Tapatalk


Andy7

That was my initial thought - but do you NEED to recalibtate for OneShot / Dshot? Thought it was all digital?
ZMR200 | EMAX 2206 2300kv | XSRF4PO(BF) | FatShark Dom V3 | Spedix ES25 | 4S 1300mAh | 5045x3 PC HQ Props | FrSky QX7.
Hubsan X4 107 V2
YouTube: www.youtube.com/user/AndySevern7

Lamaule

Yeah, but I'd still start there. I've had some weird stuff happen in the past where settings have changed.  Occasionally I have had crashes where I have had had to reflash firmware. I think jakalas has had the same too.
Quote from: Andy7 on Monday,May 14, 2018, 12:06:31
That was my initial thought - but do you NEED to recalibtate for OneShot / Dshot? Thought it was all digital?


Sent from my VTR-L09 using Tapatalk


Cheredanine

To be specific, you need to calibrate for oneshot/multishot, they are not digital. Dshot calibration doesn’t do anything.
Agree with firmware reflash, I have had crashes where doing that fixed issues
Other common causes -
mounting screws touching the windings.
Esc problem
Min_command too high
min-throttle/digital idle (one shot/dshot) too low
(Both of those should be fixed if you reflash)
Electrical short

Andy7

Running DSHOT 600. Motor idle throttle, set to 4.5% (8k Gyro, 2k PID loop)
All motors stutter at 1008... which is fair enough,
Stable at 1014


Armed on the bench (yep, no props!) seems fine.
Taking it out to the garden for a try.

ZMR200 | EMAX 2206 2300kv | XSRF4PO(BF) | FatShark Dom V3 | Spedix ES25 | 4S 1300mAh | 5045x3 PC HQ Props | FrSky QX7.
Hubsan X4 107 V2
YouTube: www.youtube.com/user/AndySevern7

Andy7

Hmmm... right as rain.  :hmm:

Only thing I did was to recalibrate the acc.
Must have just wanted some attention.  :shrug:
ZMR200 | EMAX 2206 2300kv | XSRF4PO(BF) | FatShark Dom V3 | Spedix ES25 | 4S 1300mAh | 5045x3 PC HQ Props | FrSky QX7.
Hubsan X4 107 V2
YouTube: www.youtube.com/user/AndySevern7

Lamaule

Glad you've sorted it! 
Quote from: Andy7 on Monday,May 14, 2018, 13:43:06
Hmmm... right as rain.  :hmm:

Only thing I did was to recalibrate the acc.
Must have just wanted some attention.  :shrug:


Sent from my VTR-L09 using Tapatalk


Andy7

Ahhh... but there's only ONE way to be TOTALLY sure that it's working properly. #sendit

::)
ZMR200 | EMAX 2206 2300kv | XSRF4PO(BF) | FatShark Dom V3 | Spedix ES25 | 4S 1300mAh | 5045x3 PC HQ Props | FrSky QX7.
Hubsan X4 107 V2
YouTube: www.youtube.com/user/AndySevern7

Lamaule

Quote from: Andy7 on Monday,May 14, 2018, 16:17:32
Ahhh... but there's only ONE way to be TOTALLY sure that it's working properly. #sendit

::)
No video, no proof!

Sent from my VTR-L09 using Tapatalk