Welcome to Multi-Rotor UK. Please login or sign up.

Monday,August 26, 2019, 03:26:31

Login with username, password and session length

Shoutbox

Andy7:
24 Aug 2019 19:21:05
 ~~
Gaza07:
23 Aug 2019 19:26:42
I agree it does look a lot better for some reasom SMF shorten any recent posts display  :rolleyes:
Andy7:
23 Aug 2019 10:29:15
Nice! Looks loads better.  :beer2:
Gaza07:
22 Aug 2019 22:47:32
Sorted mate  ~~
Andy7:
22 Aug 2019 10:27:36
Sure. But basically, all the subjects are getting cut off.
Gaza07:
21 Aug 2019 18:14:54
Can you pm me a screen shot of what you mean
Andy7:
21 Aug 2019 12:15:41
Gaza - can you make the subject line section in the forum topic list wider? It's cutting off the subject field really short.
Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196588
  • Total Topics: 19805
  • Online Today: 60
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 21
Total: 21

Theme Changer





3d - Printworx

Printing 3d Forum

RCTimer Brushless gimbal controller - How to get it to work.

Started by sausageroll, Friday,April 26, 2013, 00:31:45

Previous topic - Next topic

sausageroll

Hi Everyone,

So I got the gimbal controller and straight out of the box, its an abortion of a device, makes the motors shake all over the place, really bad. The new version of the firmware however, _048, seems to work rather well.

Its not as straightforward as id like to to do firmware updates. As the board is based on the Arduino, you update it like you would any arduino board, so you use the Arduino IDE control which you get from www.Arduino.cc

You need to install the FTDI drivers to your computer, using this link - http://www.ftdichip.com/Drivers/VCP.htm

Then you need to download the latest version of the firmware, its a RAR file, so unrar it to your desktop or whevever and have a look around inside the folder. The version I put on is _048 so your looking for _048.ino

http://code.google.com/p/brushless-gimbal/downloads/list


The next bit is a bit faffy. Plug the board in, and then you need to launch the Arduino program, and see if the board is talking to the computer. Select the com port using tools - serial port (this will vary hopefully it will find it, if not you need to find out what the comport is using device manager on windows). You need to set the board to Arduino Pro or Pro Mini - the top variation on the list - using tools - board.

Next you need to open the console which is the little magnifying glass in the top right corner. Type in HE and press send - this should call up a help list. If you get stuff coming back, then the board is talking to the computer. If you dont get anything, change the baud rate to 115200 (or close, its something like that).


After that, do file - open and navigate to the firmware, _048.ino in my case. Then pres the upload button and watch it upload. it should upload and there should be no orange warnings.

Thats it updated. Now you can close all that down to free up the com port and open up the GUI which is in the same folder as the firmware. Run that and set it to the saem comport and it should find the board. Im having trouble getting it to actually make adjustments, i need to do more reading but it recognises it atleast.

You can do a test that the system is working by plugging in a motor and sticking the IMU board FACE DOWN!!!! to the moving part. You will need to experiment with the plugs, as there are two outputs for motors and they are not labelled so plug it in and if it spazzes out, turn it off and try the other plug. If it still spazzes out, try turning the plug over (reversing the motor).

Dont forget you need to leave the IMU unit absolutely still when you turn the system on or it wont calibrate. If you hold the IMU in your hands, this is not still enough. Stick it on the table and dont tap your feet or cough or anything whilst it boots up. The LED will go blue and the motor will wake up and start moving. Dont expect it to be perfect first time, it may creep all over the place, this is what the gain tuning is for.


I should point out that I am no expert in this, I fudged my way through with the help of a freind who knows about the arduino platform. It took several goes with the settings to get this to work, so hopefully this helps people get through it the first time. Its easy enough to pick up.

Im going to try and coax my freind onto the forum and he may be able to answer any other questions that may come up, caus if its not covered in this post, i dont know the answer! This is literally all I know at this time.


Pete.

sausageroll


powerlord

Cool. Good stuff.

49 has been out for 2 weeks though. Could be worth upgrading ?

powerlord


Gaza07

I could only see version _48 but thought maybe I had missed something  :rolleyes:  ~~

Quote from: powerlord on Friday,April 26, 2013, 09:05:33
http://brushlessgimbal.de/brugi-v1/brugi-aoi/

in case you';ve not found the site yet.

and its 48 on there, so I must have imagined v49  :whistling:

powerlord

Got my one working ! Yeh !!

First flight in the bag - needs tuning but very very smooth

sausageroll

Have you managed to get the GUI to work to tune the RCtimer board? I cant get it to work properly....

powerlord

Remember this is the carbon job from eBay.

However board is the same I think.

GUI connects. Vibration monitoring works.

Changing pids don';t seem to take - tried save to board avid save to flash. But not read help or looked in net yet, thought I';d just try defaults first.

How do you tell how many poles motor is ? Is it just counting the number if coils ?

sausageroll

I can get the GUI to recognise the board is there but it wont adjust anything, all the sliders are greyed out.....

phattZz

have you guys had anymore luck with this? i';ve been searching everywhere on how to get this going and this is the only forum i can find discussing it!. I';ve just ordered one from RCTIMER and i think i';m regretting it already....

Did yours come fully assembled with the pins already soldered?

sausageroll

They are fully soldered, but no paperwork, instructions etc. I, beginning to think it does not have the arduino bootloader installed, which is why it has communication problems.

To install the bootloader requires a atmel reprogramming device (can';t do it with just software and my pickit and real ice programmers won';t do it either)

I';d keep an eye on flyduino and order an alexmos

rickp


powerlord

If it didn';t have the bootliader you wouldn';t be able to upload new code in arduino. I thought you';d said you';d done that ?


Gaza07

The Rctimer board is fitted with a usb port and ftdi chip which means you should be able to upload new firmware using the arduino app through the usb port, make sure when you plug the usb in it initialises properly and sets up a com port,
if it doesnt it wont work until you install the ftdi driver ~~

powerlord

Yup as gaza says it has bootliader already and USB. If your using mutliwii etc you';ll already have grid drivers otherwise you';ll need to load them.

Make sure to compile and upload you select correct board type (not got it handy but is earlier in this thread I think)

No code changes should be required.

phattZz

thanks guys. i guess ill find out when it eventually comes from rctimer....

powerlord

Just a note to say my rctimer one also came.

It all works fine, but I also cannot get GUI to work (tried all versions) and can';t get arduino to update it. Weird. I had the same problem with an arduino before though and it was just the board type and recompile - been through 3 of 4 likely ones but still getting bootloader timeout for now

Gaza07

I wonder if its worth reloading the bootloader through the ISP pins and then try again it wouldn';t be the first board ive seen that has the wrong bootloader installed  :popcorn:

rcjarvis

Quote from: phattZz on Tuesday,April 30, 2013, 05:43:20
have you guys had anymore luck with this? i';ve been searching everywhere on how to get this going and this is the only forum i can find discussing it!. I';ve just ordered one from RCTIMER and i think i';m regretting it already....

Did yours come fully assembled with the pins already soldered?


HI guys, glad I found you all... I also have the same problem, Rctimer has directed me to brushlessgimbal.de,  they are supposedly thr open source community for this controller... Maxcopter ( a member over there ) has tried hard to help me in vain...

here';s the link: http://brushlessgimbal.de/forum/index.php?topic=41.0

Maybe copy/paste your posts on ther  so they get on the problem and solve it... they all seem to have theirs running, but I see there is a lot of people with the same problem...

Min will recognise (commport 6) but the software freezes at "tc reading values"...

I would suggest to come back to this forum with solutions as we get some !!! Hopefully !!!

I see ther is a lot in this forum, grateful I have found it !!!
Dan

Gaza07

Hi rcjarvis and welcome to the forum, I had a look at that link and at least found out we can use the _48 gui with the _049 firmware which is useful as its been doing my head in trying to find out how to compile a tcl file  :rolleyes:

I have my rctimer board connecting with no probs on a win7 64bit machine since i re set it up and installed the older driver, the problem is now I cant use any of the more modern FTDI adapters as the driver doesnt work with them and I cant allow it to download a updated driver as the board wont connect any more if i do  :rolleyes:
At least my old spark fun FTDI works with the older driver to so I can still connect to other stuff  ~~

I have my gimbal working fine and have been connecting the battery and usb at the same time which makes things easier, I read on the gimbal forum your not supposed to do that  :confused: I wonder why as you can connect to the many wii boards using the same mcu and ftdi

Now I know I can use the new firmware with the older gui I will update mine and try to re tune it  ~~

Gav

What controllers are on the rc timer gimbals?   Is it the Marinez type?  Just interested

Gaza07

I';m pretty sure its based on his design but slightly different, I cant find a manual for the actual rctimer version any where that tells you what all the connectors are  :rolleyes:

Quote from: Gav on Saturday,May 25, 2013, 20:23:44
What controllers are on the rc timer gimbals?   Is it the Marinez type?  Just interested

Smit80

Quote from: Gaza07 on Saturday,May 25, 2013, 22:39:27
I';m pretty sure its based on his design but slightly different, I cant find a manual for the actual rctimer version any where that tells you what all the connectors are  :rolleyes:


Yes I it is the Martinez but a slightly different board design than the downloadable PCB layouts PDF';s.
http://code.google.com/p/brushless-gimbal/downloads/detail?name=Brushless%20Gimbal%2050x50mm%20V3.0.1.zip&can=2&q=

As a bonus the A1 and A2 (For Analogue Pitch and Roll inputs) already have pins attached and are in a different place but ARE labelled on the board. A1 is Pitch, A2 is Roll. You can connect A1 to your RX with a male to male servo connection - There is no need for the +V (Center wire on Futaba style). I did not connect the +V center wire as a precaution, just ground and signal and mine works perfectly!!!  ~~ :laugh:

Gaza07

Thank you Smit80 I was wondering which connectors did what is I intend to have the pitch control on a knob  ~~

powerlord

It';s solved in another thread. Sorry I';m on tapatalk so can';t find just now but just view all my posts.

Basically it';s a windows driver issue- see my post for details

rcjarvis

woah Powerlord... please explain or give me a link to such thread... I';ve been all over the internet for weeks trying to solve this connect problem... if that';a what you mean by ';solved in another thread';....
Thanks
Dan

Gaza07

Ive got the Brugi _049 firmware loaded and the gimbal appears to be working quiter well I also connected the A1 input to my rx and can now alter the pitch with my tx control knob  ~~
I just need to get the copter holding height and loitering right now then I will do a test flight  ~~


RcJarvis   this si the driver Im using

[attachurl=1]


rcjarvis

I';m using CDM v2.08.28 Certified so that would be the problem... You mean it works  better with 24 ?

Dan

Gaza07

Mine wouldnt work at all with the CDM v2.08.28 driver see if you can un install it or roll back to the one I use  ~~