Welcome to Multi-Rotor UK. Please login or sign up.

Friday,June 05, 2020, 16:25:26

Login with username, password and session length

Shoutbox

ched:
04 Jun 2020 17:27:04
Hello Six6siX
Six6siX:
03 Jun 2020 13:28:30
ooo... hello all
badger1:
02 Jun 2020 22:09:18
TBS Source One frame with 7" arms
badger1:
02 Jun 2020 22:09:02
my guess was bang on the number - just out on the units!
LiamHowe89:
02 Jun 2020 21:48:33
Just a bit out from your initial guess then  :laugh: What kind of frame do you fly with?
badger1:
02 Jun 2020 18:52:22
shoutbox doesn't like ampersands for some reason
badger1:
02 Jun 2020 18:51:54
and it was more like a 100m fall  :o
badger1:
02 Jun 2020 18:50:36
lol - checked my logging
badger1:
02 Jun 2020 11:52:29
@Liam - no, absolutely fine.  had another couple of flights with it afterwards -  :laugh:
LiamHowe89:
01 Jun 2020 21:23:22
Ouch! Any breakages?
Members
Stats
  • Total Posts: 198591
  • Total Topics: 20021
  • Online Today: 25
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 20
Total: 20

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

Matek 405 FC and FCHUB-6S pdb

Started by aburn09, Friday,February 16, 2018, 19:56:19

Previous topic - Next topic

aburn09

Friday,February 16, 2018, 19:56:19 Last Edit: Friday,February 16, 2018, 20:01:29 by aburn09
Just taken one of my quads apart to put a new fight controller in and pdb both are Matek
https://m.banggood.com/Matek-F405-OSD-BetaFlight-STM32F405-Flight-Controller-Matek-FCHUB-6S-Hub-Power-Distribution-Board-for-RC-Drone-p-1194724.html
Everything is soldered as it should be the esc's are soldered into the pdb and the only connection between the pdb and the flight controller is a ribbon connector.......I've connected the board to betaflight and went into the motor tab to make sure the motors all work but none do ?.......They have power as they bleep when the battery is connected but it looks like there's no signal wire connection to betaflight as like I said I can't get any of the motors to spin up ??......I have tried a second ribbon connector that they supply but still no motors......I've included two pictures to show everything is connected correctly.......Any ideas ?

Hozza

Is the FC powering up OK from the pdb? As it will power up via the USB

aburn09

Yes Hozza........It might be because I have no TX at the moment long story so while I'm waiting for it to be sent back I've connected everything up without it and I'm not sure now if the board is armed as the blue light is flashing and I can't arm it without the tx at the moment so that could be the problem :hmm:

Cheredanine

Friday,February 16, 2018, 22:03:33 #3 Last Edit: Friday,February 16, 2018, 22:11:39 by Cheredanine
Test 1. Without plugging the usb in, power from the lipo, do the LEDs on the flight controller light up? (Yes - fc is getting power from the pdb via the ribbon ok - suggests ribbon is ok. No -problem with the ribbon connector.)
Question - what esc protocol are you using?
(You don’t need Rx or to arm to run motors from bf motor tab)

PS don’t oarticukarly like thenlook of ribbon cable connection at the pdb end, shouldn’t have exposed traces and it appears to on the photo

aburn09

Thanks Cheredanine for the reply......I don't think the photo really shows the ribbon cable properly as I can assure you the cable is fully inserted both ends but I think I am right about setting up the whole betaflight settings without the TX as I said the motors wouldn't spin up in the motors tab and I think it was because the flight controller is disarmed which it is showing as I have connected up some rgb lights to the flight controller and configured them through the led strip tab to show when the quad is armed=red/disarmed=green and at the moment they are showing green which is why I can't bypass the motors through the motors tab without my TX.......I have confirmed this by reflashing the board and not set anything up through betaflight and this time using the motor tab I can get all motors to spin up :)........So just waiting to get my TX back to hopefully start trouble free flying again ?

Digit

To spin the motors through the Betaflight configurator you don't need the board to arm.

aburn09

I know that's normally the case but I can't explain why once I've programmed betaflight it won't spin the motors but a fresh flashed board will ? (At the moment all I wanted to do was to confirm the wiring was correct and the motors spin which they do if I don't program the board ?)

Cheredanine

As Digit says, arming is irrelevent when driving motors from motor tab in bf mate.
See questions above.

aburn09

 Any reasons why you don't think it will spin the motors once programmed then ?

Digit

What programming are you doing?
As asked above what ESC protocol (oneshot 125, oneshot 42, multishot, Dshot etc) and ESCs are you using?

aburn09

Sorry Digit/Cheredanine oversight on my behalf I forgot to change my esc to oneshot125 in the configuration tab  :banghead:.......Now all works as it should  ~~

Cheredanine


QuadFox

Bah, beat me to it! I have the same Matek combo, love it.

Was going to say for future reference, if you type status into the CLI you should get some indication of the problem from the arming disable flags.

Another trap can happen when you change the mixer layout from Quad X to something more appropriate for non-true-X quads, if you get this wrong all seems fine in the GUI, but there are no motors to spin up in the motors tab (values all 0).