Welcome to Multi-Rotor UK. Please login or sign up.

Tuesday,June 25, 2019, 00:19:56

Login with username, password and session length

Shoutbox

ched999uk:
22 Jun 2019 14:56:09
who??  :laugh:
Slayer23:
22 Jun 2019 11:48:18
guess whos back
 :laugh: :laugh:
atomiclama:
18 Jun 2019 10:41:40
Luckily wasn't that far out and managed to bring it back LOS  :sweating: So now need to coat the reset of my kit. :laugh:
atomiclama:
18 Jun 2019 10:40:51
Stuff it, yesterday I was going to fly rain or no rain, guess what it was raining, still went out. Quad is all conformal coated so I thought lets give it ago. Quad was fine VRX strapped to the top of me goggles wasn't Didn't think to coat that.
Bad Raven:
12 Jun 2019 19:43:40
You didn't break rules, its just difficult to follow lengthy posts here, better in a proper thread.
ChrisKz:
12 Jun 2019 18:43:54
Thanks Ched ... BR . sorry if I broke rules
ched999uk:
12 Jun 2019 18:41:18
Cheers BR
Bad Raven:
12 Jun 2019 18:39:58
Shout box not ideal for discussions!  BMFA affiliated clubs do not HAVE to force achievement tests no more than they HAVE to allow any specific type of model. There are plane only, there are Heli only, etc.
ched999uk:
12 Jun 2019 18:30:21
Seems to be a pv club in IP6 here: https://www.facebook.com/groups/1483581111957310/
ChrisKz:
12 Jun 2019 17:38:49
I'm with u on that one ched .  I'm in no hurry to purchase one yet , I like to do a little research as to what is out there . Insurance is a must anyways . I shoot pcps so always covered
Members
  • Total Members: 8046
  • Latest: ayush05
Stats
  • Total Posts: 195996
  • Total Topics: 19717
  • Online Today: 55
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 21
Total: 21

Theme Changer





3d - Printworx

Cannot bind R-XSR and Taranis QX7

Started by BigBug, Monday,October 30, 2017, 18:27:52

Previous topic - Next topic

BigBug

Hi there!

I recently bought a Taranis QX7 (LBT EU) transmitter and also a R-XSR (LBT EU) receiver. I have installed Open TX 2.2.0 (17-02-12), then flashed the internal XJT module with the 'XJT_LBT_build151223.frk' (from FrSKy website) and also flashed the R-XSR with 'R-XSRLBT171009.frk' (from FrSKy website) via S.Port on the Taranis.

Next step is the binding between the Tx and the Rx, so as the manual says, I supply 5V (it accepts from 3.5V to 10V) to the R-XSR while pressing the F/S button. Red and Green LEDs stays solid and then I set the Tx into binding mode. Unfortunately, I do not know if I am doing anything wrong, but it does not work.

Any suggestions/recommendations/advice? I will really appreciate it.

Thanks in advance!!

Cheredanine

You are doing it the wrong way round.
Put the radio in to bind Mose (it will start beeping you have to live with that for the duration of the process)
Now power up the r-xsr whilst holding down the bind button.
Wait a few seconds, power down the reciever, take the radio out of bind mode and power up the Rx, you should then get a solid green light

BigBug

Hi Cheredanine,

Thank you very much for your quick reply. I will try it asap and let you know.

Have a nice day!

Michael Navigator

exactly same issue. Binding does not work for neither r-xsr nor xsr. Although it says in the RX Manual that they are compatible.



Both, RX and TX have the newest EU Firmware on them. Bindings works with the same TX and other receivers without an issue. But,

BigBug

Hi all,

I have to say that I even bought a new R-XSR, but still the same issue. It is exactly the same as Michael Navigator. Thanks Michael for sharing a video with us. Which Open TX/ XJT module version have you installed in your Taranis QX7?

Have a nice weekend guys!

Michael Navigator


Cheredanine

Saturday,November 04, 2017, 21:34:07 #6 Last Edit: Saturday,November 04, 2017, 21:48:06 by Cheredanine
It has nothing to do with opentx.
What firmware have you got flashed to both he r-xsr and module on the radio? (Michael)

I have bound a qx7 to both xsr and xm+ with the last week or so

Big bug are you still having the problem?

Michael Navigator


TX (Q X7)
a freshly (04.11.2017) created "opentx-x7-noheli-lua-en.bin" via Companion 2.2

Bootloader firware
eu1_170213.bin
eu2_170213.bin
both seem to work, i could not figure out a difference

i even tried the non EU versions
noneu1_170213.bin
noneu2_170213.bin

All tests worked fine with other RX (X4R_REVO 3.3.for example).

RX
R-XSR -> "R-XSRLBT171009.frk" and for testing purpose "R-XSRFCC171009.frk"
XSR -> "XSRLBT170619.frk" and "XSRFCC170619.frk"

In the meantime, i am a Flash expert. I hope the chips can cope with 1000 rewrite cycles ;-)


BigBug

Hi all,

Cheredanine, I am having exactly the same issue and I just tested my new R-XSR (LTB-EU) straight out from the box, so no updates at all.

I will try to spend some time later on and test other combinations.

As Michael said, I am also a flash expert  :laugh: :laugh:

Cheredanine

Sounds like a problem with one of the firmware releases then, suggest you back off one or the other (radio or reciever)
I rarely update (I have a lot of quads, it is a pain to upgrade)

I haven’t updated any firmware this year.

I got a qx7s about 3weeks ago, with the firmware it came with I have had no issues binding to xm+ or xsr (the xsr would be using firmware revision from at least January if not older)

Don’t worry about opentx version, that isn’t involved in bind.

Michael Navigator

Update: I finally got the XSR working. The R-XSR still is not binding although going through the exact same procedure

How I did it: I installed ad flashed all devices - again - with the most recent software and firmware obtained -again - from http://www.open-tx.org/2017/05/30/opentx-2.2.0 and https://www.frsky-rc.com/. Important: on the RX there is printed: X4RS_RS_REV1.1. It was sold to me as XSR. It works with the XSR firmware.

* Open TX 2.2. (just to eliminate all possible errors)
* opentx-x7-eu-noheli-lua-en.bin created with the companion
* TX eu1_170213.bin,
* RC XSRLBT170619.frk

As mentioned, the R-XSR still does not work.

I tried the exact same procedure as used for the XSR. Only difference is the firmware of the RX
* R-XSRLBT171009.frk
I also tried an older version and wrong versions (in my despair)
* R-XSR_LBT_170904.frk
* XSRLBT170619.frk
* XM+LBT170313.frk

No sucess.

Cheredanine

Ok mate, so cool on the xsr, I was under the impression that was what you had done already.

On the last three bullet points, only one of those firmwares are for the r-xsr.
Flashing with firmware for other hardware (the second is for the xsr and the third is for the xm+) is not only not going to work but a very bad idea as it can brick the board by changing the chip pin layout.

I notice the r-xsr firmware you use, whilst the latest, is nit at a version as high as the firmware on the xsr that worked.
I therefore think the problem is the version of firmware on your internal module will not talk to the (older) r-xsr firmware.

You could try flashing am older version of the internal module firmware, otherwise contact the supplier.

On the radio open tx is the operating system, it is not on the internal module.
Binding takes place between the internal module and the Rx, that is why the version of opentx is irrelevent

BigBug

Hi all!

I managed to contact FrSKY and they sent me a new firmware version of the R-XSR [LBT-EU] (attached) Rx and IT WORKED  ~~. I just decided to flash my XJT module with 'XJT_EU_V20_build170317.hex.frk'

Michael Navigator

Same here, I finally contracted FrSky support. But all i received so far was: "Thanks contact us, maybe the problem is the firmware, i have feedback the problem to our test team, any new information i will tell you." ;-)
Anyway, the new Firmware you posted works. :-)

Many thanks to you guys.

Here is the video in German:


I'll post a link in die video description to the forum so ppl can download the file as long as it's not available directly from FrSky. I hope that's fine with you.

Michael Navigator

And for you English speaking guys exclusively also in English. I hope you enjoy. ;-)


Michael Navigator

In the meantime, the firmware is officially released. Seems we officially found a bug in the LBT version of the firmware.  :beer2:

https://www.frsky-rc.com/r-xsr/

BigBug

Yes!! Thank you guys for your help and also thanks for having this community available for us!  :beer2:

WYSIWYG

I'm still in the same boat even using the new firmware. I also tried to change to non EU in the hope of connecting it to no avail. Any other ideas??

Thanks.

BigBug

Hi WYSIWYG,

Could you please explain us what steps did you follow?


WYSIWYG

Updated my 9XDwith the options of eu, lua, noheli and english via OpenTx to 2.2. Bootloader is already 2.2. Downloaded latest firmware of r-xsr from frsky site and also downloaded and tried the file above this post. Turned on 9XD with both trims held to get to bootloader. Connected usb to back of 9XD, transferred latest firmware to sd card of Tx. Unplugged USB, turn Tx off then plug in lead for firmware update connected to back of Tx with Rx connected to it, hold Menu the Page, go to Firmware look for firmware file, then long press to update external then ENT to confirm to update, wait for it to finish. Turn Tx off and unplug Rx.
I've powered the receiver via the main board as I've already soldered them and before you say it I've also powered it via 6v power supply because I've got another lead from another receiver which is also not binding. Go through the binding process and the blue, red, and green lights remain solid.

Cheredanine

Sorry mate but at no point there did you state you had connected the r-xsr physically to the radio, did you do that?
Nor did you state you had updated the radio (opentx is not the firmware, you need to update the internal module on the radio as well as the Rx to a version that talks to each other

WYSIWYG

Yes mate it's on the middle of the paragraph where I turn off Tx and plug/connect Rx to lead connected to the back of Tx.

WYSIWYG

 Maybe I've got it wrong regarding updating Tx via opens 2.2 app where you run app (OpenTx) on PC then choose which version you want to load into Tx like: which raďio,  what language, whether EU or not, with or without Lua scripts etc. Then download using opens app then put Tx into bootloader connect USB to back of Tx click write to Tx then turn off and unplug USB lead from PC. Could you please let me know how exactly to update firmware of 9XD?

Thanks,
Angelo

Cheredanine

So opentx is the operating system. It is nit the firmware on the radio, that is the Frsky firmware in the internal module.
This video explains the difference:



And this one explains how to flash the firmware on both the internal module and the Rx
(Apologies on the connect, I missed it);



WYSIWYG

The 2 videos show exactly what I previously did with my Tx. No problems with the Tx after the upgrade. I have also tried to use the firmware from the Frsky website and that firmware corrupts the Tx, I just get a blank screen a random warning now and again. I have reverted to the OpenTx firmware again and still not able to bind them. I have contacted Quadcopter.co.uk for them to test to see if it's my radio that is not working. If I flash an international firmware on it via opentx then it works with my QX90 perfectly so I don't think it's my radio. This is my first foray into Frsky and Taranis. I am an experienced rc flyer and a club examiner with 'B' Cert. so I'm not unfamiliar with rc.
Thanks.

Cheredanine

Once again, opentx is not the firmware,
You don’t need to change opentx at all
What needs to match is the Frsky firmware on the internal module (not opentx) and the firmware on the Rx, don’t understand why you are playing with opentx

WYSIWYG

I'm very confused. Where do I get the EU Firmware from for my 9xd. The Frsky official firmware from their site only leaves a blank screen on my raďio.

Paul01

You need the firmware for the xjt module not the taranis firmware. The x9d has an internal xjt radio module and it's the firmware on this that needs updating.

Sent from my SM-G950F using Tapatalk

FrSky Taranis X9D Plus with TBS Crossfire Micro
FatShark Dominator V3 with RapidFire Module
Armattan Chameleon-BF3.5.7
TBS Source One-BF4.02-RPM Filtering
KL-EX95
DJI Mavic Pro
https://www.youtube.com/c/paul01

WYSIWYG

Thanks Paul01 that clarifies things formea whole lot. I thought xjt modules are other external modules you plug to the back of the Tx like the transition a while back from 35mhz to 2.4Ghz on futaba Tx where you plug in a different module to the back of the Tx. I'll try updating that when I get home. Thanks again.

Paul01

No problem, its a topic that confuses most as you are right in thinking the XJT is an external module, the Taranis just comes with one internally, they are both treated the same from a firmware point of view other than one you choose flash internal and the other external.
FrSky Taranis X9D Plus with TBS Crossfire Micro
FatShark Dominator V3 with RapidFire Module
Armattan Chameleon-BF3.5.7
TBS Source One-BF4.02-RPM Filtering
KL-EX95
DJI Mavic Pro
https://www.youtube.com/c/paul01