Welcome to Multi-Rotor UK. Please login or sign up.

Saturday,July 04, 2020, 21:54:28

Login with username, password and session length


04 Jul 2020 13:16:48
VIDEO or it didn't happen!! :) Nice going though, keep it up!
Bad Raven:
02 Jul 2020 19:46:48
whoelseisbored (LiamHowe89):
02 Jul 2020 17:45:19
Sounds basic but I'm happy with it  :laugh:
whoelseisbored (LiamHowe89):
02 Jul 2020 17:45:05
Managed a split s :D
28 Jun 2020 12:29:49
BF GPS Rescue mode configured - what could possibly go wrong?   :o
27 Jun 2020 21:07:37
and can't make it back to where you take off from   :laugh:
27 Jun 2020 21:07:04
it's too windy if you fly downwind
Bad Raven:
27 Jun 2020 20:51:32
I have done Dynamic Soaring in over 55mph, and quad flying in over 25mph with the right equipment.
whoelseisbored (LiamHowe89):
26 Jun 2020 16:44:24
How windy is too windy? :hmm:
whoelseisbored (LiamHowe89):
25 Jun 2020 22:58:29
YASSSS!! Flew a full 2 packs and no motors going nuts on me!  :D
  • Total Posts: 198954
  • Total Topics: 20050
  • Online Today: 20
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 2
Guests: 24
Total: 26

Theme Changer


3d - Printworx

Printing 3d Forum

Naza-M V2 Failsafe using Taranis X9D+ and X8R

Started by nate80, Tuesday,August 01, 2017, 16:38:45

Previous topic - Next topic


Whilst building my f550 hex I';ve come across and bookmarked so many guides to initialising failsafe on the Taranis X9D+ or X8R, and loads of horror stories of failsafe settings that haven';t functioned correctly. It';s made me a bit paranoid, so I';ve re-read all the threads and re-watched the video';s about setting failsafe and none of it works.

Following all the various guides I';ve tried:

Selecting failsafe using the taranis switches and then pressing the F/S button on the X8R to ';remember'; that combination of switch and thumb stick selections.  I';ve tried this with both Receiver and Custom selected in the Taranis menu.  Having Receiver selected when I tested the method by powering off the TX actually brought an error message up in the Naza Assistant.

I';ve used the taranis menu to select Custom, then Set, and altered channel 7 (the mode switch channel) to remember failsafe on signal loss.

Like I say, I';ve set up a Failsafe switch that overrides everything else and puts the Naza into RTH mode.  That works fine.  But I can';t get the taranis or the X8R receiver to remember that exact failsafe setting on  loss of signal.

I don';t actually think it matters though (though I could be wrong?!) as when I turn off the receiver the Naza Assistant automatically selects the secondary Failsafe mode anyway.  But I read that you shouldn';t really on this and it';s best to have the custom set up Failsafe option kick in when loosing signal.

If anyone knows how to set the X9D+ and X8R up to select the custom set failsafe I';d be stoked and v grateful.



Wednesday,August 02, 2017, 13:57:08 #1 Last Edit: Friday,August 04, 2017, 13:39:56 by GdLookinMingeR
the easiest way i found to do this is.

turn on tx
power receiver or quad with props off

put the transmitter into failsafe mode as programmed
then press the FS button on the receiver it then records the setting.

power off power all on with props off again and test signal when
powering off tx reciever should go into failsafe  ::)

Hope that makes sense
Kind Regards

Just re read post - seen you have tried that  :lipsrsealed
my apologies but has always been 100% reliable way in my experience.

Carbon Tricopter with KK2 mini because you have to own a Tri and Falcon Evo FPV (rebuild again) with fatshark 600mw vtx & pz2040 cam. New addition (hidden from the missus!) 250 quad.


Many thanks Jay. Yeah, I had tried it. I';ll give it another go though as I';ve not managed to find a perfect solution yet. I';ve got the flight controller looking after failsafe at the moment (return to home) which works in theory. I';d really like the receiver to control the failsafe as I';d like to have it put the retractable legs down as well as return to home. Could be useful.