Welcome to Multi-Rotor UK. Please login or sign up.

Friday,June 05, 2020, 16:43:14

Login with username, password and session length

Shoutbox

ched:
04 Jun 2020 17:27:04
Hello Six6siX
Six6siX:
03 Jun 2020 13:28:30
ooo... hello all
badger1:
02 Jun 2020 22:09:18
TBS Source One frame with 7" arms
badger1:
02 Jun 2020 22:09:02
my guess was bang on the number - just out on the units!
LiamHowe89:
02 Jun 2020 21:48:33
Just a bit out from your initial guess then  :laugh: What kind of frame do you fly with?
badger1:
02 Jun 2020 18:52:22
shoutbox doesn't like ampersands for some reason
badger1:
02 Jun 2020 18:51:54
and it was more like a 100m fall  :o
badger1:
02 Jun 2020 18:50:36
lol - checked my logging
badger1:
02 Jun 2020 11:52:29
@Liam - no, absolutely fine.  had another couple of flights with it afterwards -  :laugh:
LiamHowe89:
01 Jun 2020 21:23:22
Ouch! Any breakages?
Members
Stats
  • Total Posts: 198591
  • Total Topics: 20021
  • Online Today: 25
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 22
Total: 22

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

F4 Betaflight - Led Strips

Started by ched, Thursday,July 13, 2017, 10:53:20

Previous topic - Next topic

ched

OK so I know LEDs are not critical to quads but I am waiting on components so I am stuck on my build. I thought I would ';play'; with the ';Matek Tail Light WS2812B & Loud Buzzer Dual Modes'; that I bought  https://goo.gl/RdJhs2.
Reading the instructions I have to power the LED module on and cycle through the colours with the button till I get all lights OFF. Then wait 10 seconds and it will beep once setting into Flight controller mode. Then I power off, connect the Data line to J1 (Omnibus F4 V3 Pro running BF 3.1.7). Then power on.
In BF I switched the LED Strip ON in config, save and reboot. Go to the LED page and select 8 LEDs (0 to 7). Set a colour and save.
I still have zero LEDs on.
I realise that very few people will have same LED module but does my BF procedure sound OK or have I missed something?
Any ideas?
Cheers.
I try :-)

Cheredanine

Yes mate, bf process sounds fine

Some fc will provide power to LEDs from USB, some require lipo, just bear that in mind

ched

Quote from: Cheredanine on Thursday,July 13, 2017, 18:07:46
Yes mate, bf process sounds fine

Some fc will provide power to LEDs from USB, some require lipo, just bear that in mind

Cheers. Tried usb and lipo. Going to try and map resource back to PWM6. See if that helps. It is a clone board and J1 (LED strip) has only works with BF3.1.7 on. So might be that cloners didn';t bother hooking J1 up properly.

Cheers
I try :-)

ched

Just remapped LED Strip to PWM6 and all working  ::) Looks like cloners were very lazy.
I try :-)