Welcome to Multi-Rotor UK. Please login or sign up.

Monday,November 18, 2019, 16:27:16

Login with username, password and session length

Shoutbox

ched:
18 Oct 2019 11:25:16
Sounds good yama. Would love to see some images. 3d models sound cool too
yama:
18 Oct 2019 10:32:38
i might have to do a review. the 21mp camera is excellent at producing high quality 3d models for mapping.
ched:
10 Oct 2019 16:56:16
Show us some picys and maybe post a review in a thread?
yama:
09 Oct 2019 14:13:10
must admit this anafi is tiny and looks like a toy in a lunchbox but performs like a professional product.
yama:
09 Oct 2019 14:11:52
went ahead and bought one. about to find out if the 21mp camera improves photogrammetry surveys.
ched:
08 Oct 2019 17:14:17
Not tried a parrot anafi but I thought parrot were stopping 'drone' production?
yama:
07 Oct 2019 13:25:37
anyone tried a parrot anafi?
Gaza07:
26 Sep 2019 11:33:59
We know a song about that dont we  :D
Andy7:
26 Sep 2019 08:38:34
 :laugh:
Bad Raven:
26 Sep 2019 07:10:39
Adopts Australian accent "Black, that's not Black, its a dirty grey, THIS is Black........"   :D
Members
Stats
  • Total Posts: 197136
  • Total Topics: 19878
  • Online Today: 47
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 4
Guests: 39
Total: 43

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

F4 Betaflight - Led Strips

Started by ched, Thursday,July 13, 2017, 10:53:20

Previous topic - Next topic

ched

OK so I know LEDs are not critical to quads but I am waiting on components so I am stuck on my build. I thought I would ';play'; with the ';Matek Tail Light WS2812B & Loud Buzzer Dual Modes'; that I bought  https://goo.gl/RdJhs2.
Reading the instructions I have to power the LED module on and cycle through the colours with the button till I get all lights OFF. Then wait 10 seconds and it will beep once setting into Flight controller mode. Then I power off, connect the Data line to J1 (Omnibus F4 V3 Pro running BF 3.1.7). Then power on.
In BF I switched the LED Strip ON in config, save and reboot. Go to the LED page and select 8 LEDs (0 to 7). Set a colour and save.
I still have zero LEDs on.
I realise that very few people will have same LED module but does my BF procedure sound OK or have I missed something?
Any ideas?
Cheers.
I try :-)

Cheredanine

Yes mate, bf process sounds fine

Some fc will provide power to LEDs from USB, some require lipo, just bear that in mind

ched

Quote from: Cheredanine on Thursday,July 13, 2017, 18:07:46
Yes mate, bf process sounds fine

Some fc will provide power to LEDs from USB, some require lipo, just bear that in mind

Cheers. Tried usb and lipo. Going to try and map resource back to PWM6. See if that helps. It is a clone board and J1 (LED strip) has only works with BF3.1.7 on. So might be that cloners didn';t bother hooking J1 up properly.

Cheers
I try :-)

ched

Just remapped LED Strip to PWM6 and all working  ::) Looks like cloners were very lazy.
I try :-)