Welcome to Multi-Rotor UK. Please login or sign up.

Thursday,August 22, 2019, 23:35:28

Login with username, password and session length

Shoutbox

Gaza07:
22 Aug 2019 22:47:32
Sorted mate  ~~
Andy7:
22 Aug 2019 10:27:36
Sure. But basically, all the subjects are getting cut off.
Gaza07:
21 Aug 2019 18:14:54
Can you pm me a screen shot of what you mean
Andy7:
21 Aug 2019 12:15:41
Gaza - can you make the subject line section in the forum topic list wider? It's cutting off the subject field really short.
Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196578
  • Total Topics: 19804
  • Online Today: 44
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 1
Guests: 41
Total: 42

Theme Changer





3d - Printworx

Printing 3d Forum

Failsafe not working (FrSky D8R-II+)

Started by bulesz, Thursday,April 11, 2013, 00:36:32

Previous topic - Next topic

bulesz

Thursday,April 11, 2013, 00:36:32 Last Edit: Friday,April 12, 2013, 10:03:38 by bulesz
Heyya,

I';m sure that I do something wrong, but dunno (yet) what... just checked the Failsafe Throttle and Failsafe Battery in the Settings/Failsafe @ Mission Planner.
Using Megapirateng 2.8R3.

Symptome: when turn off the radio at middle throttle, the motors keep running the state where I have left them. With zero throttle the same.
On the screen the Flying mode not changing and not disarming as well (at zero throttle Failsafe test).

Any idea?

Cheerz,
B

SimonS


bulesz

Heyho,

Thanks for you reply, yes I have missed to set the FailSafe with the RX. So I have bind and set the throttle to zero and pressed the bind button at RX.
Now when I turn off the radio the throttle will go to zero. So this works.

BUT the failsafe of the megapirate is still not working. :( I mean as far I know it should behaive like these:
- failsafe when throttle at 0 = disarmed
- failsafe when flying = RTH + AL or AL (without GPS)

At me, when turn off the radio, only cut the thruttle to zero (as I set the RX) but not any reaction from the megapirate... I have checked the Failsafe throttle and Failsafe low battery in the Settings / Failsafe page.

:hmm:

SimonS

I have know idea how megapirate works but with the Naza you would set up the failsafe between Tx & Rx with the throttle partly open and the RTH switch in the active position. Then when the signal is lost the Rx will give those commands to the Naza (ie, go home).

Your set up now is telling the Rx to tell the controller to close the throttle.  When the failsafe is not set between the Tx & Rx the Frsky Rx continues to give the last known command to the controller until the signal from the Tx is reestablished.  This is what you saw before.

bulesz

Thanks for your reply and I see now the FailSafe "trigger", but that not clear the Mefapirate has three different Failsafe states:

1. at zero throttle -> disarm
2. while flying with GPS locked -> RTH + AUTOLAND
3. while flying without GPS -> AUTOLAND

And I don';t have a clue where could I set these??? I mean the Megapirate/Missionplanner overwrite the RX/TX one state trigger... ?  :hmm:

Allanm

There';s a good video on how to set failsafe on Megapirateng made by Peter King. Search on YouTube. Not sure if yours will work the same but I am sure if you watch the vid, it will give you an idea how it needs to be set up
Allan

bulesz

Thanks for your reply, but I';m truly lost... :(

I have watched that video and followed this guide:
https://code.google.com/p/arducopter/wiki/AC2_Failsafe

Set up my FrSky RX/TX failsafe to cut the throttle, so if I turn off the radio the throttle will be cut to zero (to around 983 pwm)
I set the Throttle Failsafe in the Mission Planner, set the limit to 995 pwm (because my lowest is 983 so I needed to set a higher value).

When I do the test the instant disarm or the mode change is all missing, only doing the "frsky" failsafe and not the megapirate related.... :(

SimonS

Friday,April 12, 2013, 08:32:59 #7 Last Edit: Friday,April 12, 2013, 08:38:51 by SimonS
When you turn off your Tx the Rx continues to pass instructions to the controller and this will be the settings set up in the Tx/Rx fail safe.  The controller follows those instructions (eg. throttle closed) because the link from the Rx to the controller has not failed.

Think of it as two separate fail safes. One between the Tx and Rx and another between the Rx and controller. It should then be easier to understand what needs to be set for the two different failure scenarios.

bulesz

Yes, my problem is with the FailSafe between the RX and FC (APM) which is controlling by the Megapirate.

As I guess this is the Throttle failsafe:
if
no signal + throttle is lower than X,
then
do the megapirate Failsafe (RTH + Land or just Land (without GPS)

So this part is not working for me and I don';t know why... :(

SimonS

The mega pirate fail safe will not kick in unless the link between the Rx and controller fails.

If you want it to RTH when the link between the Tx and Rx fails then that is set up between the Tx and Rx. It takes no account of what is set in the controller

bulesz

Mate, the RTH etc, is the default failsafe of the megapirate! I can set up in the Mission Planner only the ON/OFF trigger and the method 1/2.

"When a throttle failsafe is triggered one of the following will happen:

Disarm motors - if you are in stabilize or acro mode and your throttle is zero
RTL - if you have a GPS lock and are at least 2 meters from your home position
LAND - if you have no GPS lock or are within 2 meters of home when the failsafe triggers
Continue with the mission - if you are in AUTO mode and have set the FS_THR_ENABLE parameter to "2"."

The failsafe has been set with the RX...when I turn off my radio (signal loss...epic fail.. ;) ) the throttle will be cut.

My problem: why the megapirate failsafe is not triggered?

SimonS

You posted above:-

QuoteAs I guess this is the Throttle failsafe:
if
no signal + throttle is lower than X, ........


If you turn the Tx off, the Rx is not receiving a signal but does provide a signal to the controller (whatever you set as the Tx/Rx failsafe) so the ';no signal'; part of the Throttle failsafe is not met.  Instead of going into RTH it thinks you have simply closed the throttle.

With Arducopter you can fit an 8 way switch to the Tx to switch between all the different modes.  Do you have such a switch or some other way of commanding RTH?

bulesz

I have set the different flight modes to the 3 way switch, currently STAB, ACRO, LOITER.

But as far I know in the 2.8 megapirate the "superduper" failsafe is not activated so in the APM_Config.h need to uncomment this row near to the end of the file:

// #define FAILSAFE

to

#define FAILSAFE

and compile back.

I have done, but need to make the tests (my kids are sleeping and I don';t want to wake them up with the beeeeps... :) )

ausi1972

Connect in Mission Planner on the Radio config screen. Check what your throttle channel reading is (PWM value). Then turn off your radio and see if the PWM value drops below 975.
If not then you need to setup and throttle cut switch or travel adjust on your radio so that the throttle PWM is below 975 then re-bind your radio to the receiver with that value. Put the throttle back to normal and test again.

Also remember to enable failsafe in Mission planner. You can test it with the props off by getting a GPS fix and watching the flight modes screen. When you switch off your radio the mode should switch to RTL.
regards Peter King

bulesz


Iulian

Saturday,November 01, 2014, 19:40:38 #15 Last Edit: Saturday,November 01, 2014, 19:44:35 by Iulian
Megapirateng 3.1.5-R2 , FS-TH9X , FrSky D8R-II plus. Bind the receiver with transmitter. Turn off both. Turn on only receiver. Press briefly the bind button of the receiver. Enable fail safe in Mission Planner. The fail safe will work now.