Welcome to Multi-Rotor UK. Please login or sign up.

Monday,March 30, 2020, 13:38:04

Login with username, password and session length

Shoutbox

ched:
27 Mar 2020 21:41:51
We've been in self imposed lock down for last 2 weeks!!! March is going so slowly............................ More time to Whoop around the garden  :D
Gaza07:
27 Mar 2020 21:30:37
Self isolation since tuesday already feels like a month  :wack0
shawdreamer:
27 Mar 2020 12:06:05
YEEEESSSS, we finally have a viable excuse for locking boris johnson in a room by himself were he cant do anymore harm
ched:
24 Mar 2020 18:45:40
Don't bin your Thingiverse account you have lots of good stuff there. It will all quieten down in a few months.Just ignore the muppets as normal.  :D
shawdreamer:
24 Mar 2020 13:45:57
wow Im so binning my thingiverse account.... the amount of knobs hashtagging "covid19" on their just to get hits is just ridicules
dirtymojo69:
18 Mar 2020 05:49:28
how do we get to general discussion chatroom?
DarkButterfly:
17 Mar 2020 11:10:32
@badger1, When my quad got all muddy, a quick rinse under the hot tap, avoiding the electronics, got the worst of it off, then strip down and clean, quick repair to the VTx, it's all good again ~~
Skilloutx:
17 Mar 2020 06:37:19
Thank you for all the stories that come to experience in this place, which is very Dr.
badger1:
16 Mar 2020 19:12:55
last-flight-itis strikes again :(  no damage - just mud though.  :smiley:  unless the damage is under the mud   :angry:
Members
Stats
  • Total Posts: 197950
  • Total Topics: 19971
  • Online Today: 10
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 39
Total: 39

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

You've probably heard this a 1000 times before

Started by jedders62, Wednesday,May 04, 2016, 16:52:19

Previous topic - Next topic

jedders62

But please bear with me.
I bought a Storm SRD280 V2 a few months ago & as it';s my first "proper" quad you can imagine the carnage.Fortunately having to do all of the repairs has given me the bug even more.
Today I thought I would have my first play in Librepilot updating the most recent software from the V3& things have started to go downhill. I carried out an update in librepilot & imported the necessary UAV file & all appeared to go well, all saved & flashed etc but although the Tx is bound it no longer operates the quad & in the librepilot flight data section the orientation is out 90 Deg.
Does anybody have any ideas as to what I should try, the sun';s shining & flying times a';wastin

Ern Stock

Well probably best to await someone cleverer than me ,
But , is the Librepilot firmware (15.09) showing on the firmware tab of the GCS ?
Your "storm 280" and "v2,v3" are not something I';m familiar with.
Is it a cc3d flight controller ?
Could you . . . On firmware page , hit erase n upgrade , connect cc3d.
Wait.
Then go through the set up wizard ?


wobblybob

And if it';s a CC3D and the USB port is on the right or left hand side . Librepilot will need to be changed . Attitude tab yaw 90o if the USB is on the right looking down with the front of the craft facing away from you . Hope that makes sense  :-/ . And yaw -90o if the USB is on the right .
Alien frame,Emax 2213 935 KV motors Emax 30amp ESC,AMP2.7,X8R Rx,

jedders62

Sorry, yes it is a CC3D Atom & I';ve gone so far as to upgrade & erase & re-install the Storm UAV file all to no avail. The problem, I think, is that the quad no longer responds to the Tx despite being bound ( I know this as I can remotely operate the buzzer)

crash pilot

cc3d atom only works on open pilot as far as i know i use a lot of them and the firmware i got is 15.02 or something like that. I could not get Libre pilot to work on my atoms so back to open pilot. Unless someone has it working   

Ern Stock

Thursday,May 05, 2016, 12:42:53 #5 Last Edit: Thursday,May 05, 2016, 12:49:16 by Ern Stock
I have librepilot on cc3d.
Not much odds really - as long as they fly !

If you want to stick with the storm programming , then you need other storm users or the storm company itself to sort you. (?)
(Possibly librepilot forum , though I think they';ll suggest the following )
Other option (as long as yr "storm-optimised-cc3d" accepts it) is to erase and go through set up wizard. Just use a template or default settings when you get to that part.
Always a chance the storm settings you try are just lacking a ';connect battery at this point '; instruction ?
Ps remember to remove props.
Also - have you looked on the input page of gcs ?

jedders62

Thanks for the replies. I';ve pretty much exhausted all options that I can think of. My last operation was to download the bootloader & carry out a full rescue. It seems to have worked judging by the status of the leds on the cc3d but still no response to the Tx.
On the flight data on the gcs I';m showing red on input, output & config so I';ve jumped in way over my head as, without any knowledge of the manual operation & stupidly not saving my original settings, I think I may need to contact Helipal - although since they';re in HK I';m not too optimistic about my chances of success.

Ern Stock

If you';re not familiar with it ,Why not watch a cc3d set up vid (painless360 ';s channel perhaps ).
Then go through the set up wizard on the welcome / home page of LP .
Lots of info in the LP wiki.
One presumes there is a separate on-board receiver ? - perhaps should show a light when connected/ bound ?
Or give helipal a try - be interesting to hear if they keen to help.
Have had a peak at their storm280 page - does look awesome. ! Camera poss needs an upgrade.
Ps not sure but I think wobblybob,s post needs an edit - should the last word be left , not right ?
Have made myself wobbly re-reading it. It is a very important setting though , as he says . I usually remember it 10ms after attempting first flight after a reset.

dirtyharry

how does the receiver connect to the flight controller ?

It looks like it could be sbus on the main port which you would have to configure:-

configuration tab then hardware tab then mainport tab then select s.bus

you would also have to make the receiver port "disabled if it is sbus on the main port.

After this run the configuration wizard in the "input " tab

http://image.helipal.com/storm-srd280-v3-cc3d-big005-1.jpg


jedders62

Thanks for pointing me at painless 360';s site Ern, it looks like I';ve got a whole series to watch & then I';ll try again. The annoying thing is I';m sure I';ve done everything correctly & the problems only began when I downloaded the srd280 v3 uav file(which incidentally has given me some parameters for the Tx & it is sbus on the main port). Never mind, I';ll catch up when I';ve been through the videos & if I still haven';t got anywhere I';ll run through your suggestion dirtyharry.
Cheers

jedders62

OK so this morning I ran through the setup wizard, I previously had a problem with this as the fc would not reconnect during the reboot process. After reinstalling librepilot this time all went well on the quad setup section but when I';m in the transmitter wizard & reach the point of giving inputs via the Tx it is not recognised so I come to a dead stop.
I';m really grateful for your help in getting me this far, hopefully one more good idea will get me airborne again. :smiley:

jedders62

A quick update to add to my confusion.
I';ve manually input the Tx settings from Helipal';s youtube video & the Tx & Rx are definitely bound. I';m basing this on the fact that the Tx display shows the onboard battery voltage & a toggle switch on the Tx activates the buzzer.
Since I still get no response to the Tx in setup wizard or from the quad itself I can only assume that I inputted incorrect info to the vehicle setup wizard. I';m not sure how I could have done this since those inputs which I was unsure of offered a default option & I would therefore expect them to at least give a workable result.
At least when this is solved I';ll be a one stop shop for anybody else needing the information :smiley:
ps dirtyharry Now that I';ve done what I should have in the first place ie a bit of research, I';m sure that your point about the sbus is the right one & I';m looking at it now but the default in vehicle setup was pwm. I can change that but I expect to be asked for info that I dont have so I might need more pointers.

Ern Stock

Friday,May 06, 2016, 21:48:41 #12 Last Edit: Friday,May 06, 2016, 21:54:51 by Ern Stock
So , as Dirty Harry says , you need to change settings in the hardware page before doing transmitter wizard. , or so I reckon. ( it';s not part of the vehicle set up wizard )
And take note of the page';s heading -all power off to the cc3d , wait 30 secs , then plug back in and check settings.
Then do wizard.
It';ll all seem so straightforward b4 long !

jedders62

Success!
Thanks for everybody';s help. In the end the problem did lay with the set up within the vehicle & Tx wizards relating to sbus connections. What stopped me(us) resolving it more quickly was the fact that librepilot kept failing to reboot during the wizard setups  preventing me moving forward  I allowed myself to get frustrated & that never helps :banghead:
I';m heading out flying now so I';ll see how the generic quad profile I downloaded works & the start all over again trying to find & install a better one.

And you';re right Ern, despite the problems I feel as though its so straightforward I can go out & build my own from scratch now :whistling: