Welcome to Multi-Rotor UK. Please login or sign up.

Friday,August 23, 2019, 01:49:14

Login with username, password and session length

Shoutbox

Gaza07:
22 Aug 2019 22:47:32
Sorted mate  ~~
Andy7:
22 Aug 2019 10:27:36
Sure. But basically, all the subjects are getting cut off.
Gaza07:
21 Aug 2019 18:14:54
Can you pm me a screen shot of what you mean
Andy7:
21 Aug 2019 12:15:41
Gaza - can you make the subject line section in the forum topic list wider? It's cutting off the subject field really short.
Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196578
  • Total Topics: 19804
  • Online Today: 44
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 45
Total: 45

Theme Changer





3d - Printworx

Printing 3d Forum

Mission Planner and MegaPirateNG 2.9

Started by Srocupado, Saturday,March 16, 2013, 14:09:19

Previous topic - Next topic

Srocupado

Hello Guys,

What version of Mission Planner should be used with MegaPirate 2.9 betas ?
I';m still with 1.2.33, is this one ok ?

Thanks.

Gaza07

The current version is 1.2.36 if you click help there is an update button there  ~~

Srocupado

Just uploaded and tested the Megapirate 2.9 R7.
Worth the try.
Really stable, Alt. Hold is rock solid with the default PIDs.
Will test the loiter mode tomorrow, but for now, it';s really going well.

robshaw

Tunrnigy Talon Tri, TBS Discovery, TBS Discovery PRO, Spnky 250 Mini, EZUHF, EZOSD

Srocupado

Megapirate 2.9 is still in beta versions.
I suggest you do not download it, it still have bugs.
But, if you would like to try: http://megapirateng.googlecode.com/svn/beta/

robshaw

Ahh, thanks mate.  I will heed your advice and keep clear for the moment.  Got enough problems with my quad as it is without adding to them. Haha.
Tunrnigy Talon Tri, TBS Discovery, TBS Discovery PRO, Spnky 250 Mini, EZUHF, EZOSD

Nano71

And how was your loiter mode in windy conditions ?  ::)

Srocupado

Hi Nano71,

I';ve uploaded the 2.9 R300.
Loiter is stable with default PIDs. I dont know what is "windy" for you, but there was enough wind to shake the trees.
I was really astonished with the RTL, it worked like a charm, landed smoothly, even under wind and with very little drift from the target (+/- 40cm).
Alt hold is working better than on Arducopter, in my opinion at least, because if you go foward really fast it compensates the altitude faster than Arducopter.
Overall I';m really, really glad.

Nano71

Wednesday,April 03, 2013, 15:37:34 #8 Last Edit: Wednesday,April 03, 2013, 15:41:59 by Nano71
I';m using mission planner 1.2.38 and megapirateng 2.9 R300

My loiter or circle is jumpy, goes up and down 50cm- 1m within one second.

Throttle rate perhaps ?

Or something else ?

Any wise advise ?

:help:


Srocupado

Try lowering the P and increasing the I on Loiter, if does not solve, get back to the old values and try the same procedure with the Thr. Rate.

Is your stabilized mode doing the same ?

Gaza07

Nano have you got a piece of open cell foam over your baro, it needs covering to stop it being affected by wind or prop wash and bright lightt  ~~

Quote from: Nano71 on Wednesday,April 03, 2013, 15:37:34
I';m using mission planner 1.2.38 and megapirateng 2.9 R300

My loiter or circle is jumpy, goes up and down 50cm- 1m within one second.

Throttle rate perhaps ?

Or something else ?

Any wise advise ?

:help:

Nano71

Wednesday,April 03, 2013, 18:24:04 #11 Last Edit: Wednesday,April 03, 2013, 18:45:55 by Nano71
So I have tried with foam but still the same problem.

I have made some other tests with the throttle rate, I have decreased the throttle rate from 5,000 to 4000 and then to 3000 same problem,Then I decreased the throttle rate to 1,000 and it was better but still not perfect, I will try some other tests tonight

Does these figures seems reasonable ?

Does it make sense ?

I have just lowered the throttle rate to 0,5000 and the jumpy effect is gone ! 

Gaza07

I haven';t had a chance to try this version I didnt get the svn thing setup to download it, anyone got it already downloaded and zipped up anywhere  ~~

Nano71

Amazing, it is stable in strong winds now and it behaves like the hubsan x4!  :cool:

robshaw

Nano 71, that seems a pretty drastic change for any parameter but if it works then thats great.  I think I have a similar problem with my loiter.  Its a bit up and down and tbh a bit side to side too. Will try playing with throttle rate.

Gaza07, there';s a download for the latest working version on here, if thats what your after............

https://docs.google.com/folder/d/0B-B7PQy0joGrUjFmb2pSTFlqcWc/edit

Its Peter Kings download page, its linked from his YouTube videos so I don';t think there should a problem posting it here.
Tunrnigy Talon Tri, TBS Discovery, TBS Discovery PRO, Spnky 250 Mini, EZUHF, EZOSD

firey1

hi Gaz i can email it to tonight you if you want
Mike
MIKE

550 RC Spider quad for FPV
550 Alien quad (my sons now)
F450 quad
450 size bell 212, MD500,Augusta 109
600 size Huey running apm 2.5  3 planes  Taranis and 9xr  radios Skyzone FPV goggles

firey1

Quote from: Nano71 on Wednesday,April 03, 2013, 19:46:59
Amazing, it is stable in strong winds now and it behaves like the hubsan x4!  :cool:


totally agree its 300% better than 2.8
MIKE

550 RC Spider quad for FPV
550 Alien quad (my sons now)
F450 quad
450 size bell 212, MD500,Augusta 109
600 size Huey running apm 2.5  3 planes  Taranis and 9xr  radios Skyzone FPV goggles

Allanm

Quote from: firey1 on Wednesday,April 03, 2013, 21:25:52
totally agree its 300% better than 2.8


Is this with Peters software and parameters? I just had an email from him with the new settings, apparently, 291r6 ( that was fitted) tends to fall out of the sky!
I just installed 291r300 with his new parameters. Just waiting for the wind to drop to try it!
Allan

firey1

Friday,April 05, 2013, 21:20:03 #18 Last Edit: Friday,April 05, 2013, 21:25:42 by firey1
Quote from: Allanm on Friday,April 05, 2013, 21:09:22
Is this with Peters software and parameters? I just had an email from him with the new settings, apparently, 291r6 ( that was fitted) tends to fall out of the sky!
I just installed 291r300 with his new parameters. Just waiting for the wind to drop to try it!
Allan

mine is straight from the mega pirate wiki site have been running this beta version for a few weeks now with no problems
on the r300 update you have to change a few parameters depending on your setup
check your board version r300 is crius aio v2
disable ppm as its enabled on r300
controller also changed i reverted back to mwi as thats what i have been using from start
Mike
MIKE

550 RC Spider quad for FPV
550 Alien quad (my sons now)
F450 quad
450 size bell 212, MD500,Augusta 109
600 size Huey running apm 2.5  3 planes  Taranis and 9xr  radios Skyzone FPV goggles

Toledodave

I also updated to 2.9 rev 300 and am dissapointed at myself for screwing something up. Now i have no radio input in Mission Planner. I rebinded my Rx and double checked all connections and still no radio input.  I was on v2.7 and radio worked fine. Only reason i updated was to get yaw servo controll which according to updates was corrected in 2.9. Now stuck with no radio. Cant calibrate with no signal. Unless i completely over looked something.  Any suggestions are welcome. Thankyou.

Gaza07

Check that ppmsum is disabled like below in the APM_config.h screen and try setting it the mwi as below  ~~


// RC configuration

// PPM_SUM(CPPM) Signal processing
#define SERIAL_PPM SERIAL_PPM_DISABLED
/*
SERIAL_PPM_DISABLED
SERIAL_PPM_ENABLED // For all boards, PPM_SUM pin is A8
SERIAL_PPM_ENABLED_PL1   // Use for CRIUS AIOP Pro v2,
*/

#define TX_CHANNEL_SET TX_mwi
/*
TX_set1 //Graupner/Spektrum                          PITCH,YAW,THROTTLE,ROLL,AUX1,AUX2,CAMPITCH,CAMROLL
TX_standard //standard  PPM layout Robbe/Hitec/Sanwa     ROLL,PITCH,THROTTLE,YAW,MODE,AUX2,CAMPITCH,CAMROLL
TX_set2 //some Hitec/Sanwa/others                    PITCH,ROLL,THROTTLE,YAW,AUX1,AUX2,CAMPITCH,CAMROLL
TX_mwi //MultiWii layout      ROLL,THROTTLE,PITCH,YAW,AUX1,AUX2,CAMPITCH,CAMROLL
*/

Toledodave

Omg Gaza i could kiss you rt now!  Lol  i know for a fact ppmsum is enabled. Tx was at standard and i read default should be Mwi so i did change that to Mwi but i didnt play with the ppm setting. Almost did!  I hope thats all it is. Im so close to flight i can taste the crash already! Lol 

Toledodave

Wednesday,July 10, 2013, 22:33:50 #22 Last Edit: Wednesday,July 10, 2013, 22:51:09 by Toledodave
Woot!  Gaza you are most definately THE MAN!   You hit that one right on the money! Got my Radio working and calibrated again! And!..... I now have Yaw controls! It was the Enabled PPM!  Problem solved ....well for most part. Now servo has a ticking bomb sounding twitch :/  but works.  Now just waiting for Esc still to get here and retweek my Modes! Thanks to Robshaws help and i think im good to go. Fpv is working just no tracker yet. Ppm and/or trainer issues. But thats all!  Finally! :)

Hands0n

I';m obviously missing something - where is 2.9 rev 300 located exactly?  I';m finding 2.9 but no directories to rev 300. 

Reason for interest - my Chinese Crius v1.1 just arrived in the post today. Fancy getting it planted on the H-copter this weekend, so gathering all the bits I';ll need.
--
Danny
"Its better than bad, its good"

Current FCs: Pixhawk, APM 2.6, Naza M V2, Naze32, Flip32+ CC3D, KK2.1.5
Aircraft: miniMax Hex, DJI 550 (clone) TBS Disco, 450 Firefly, 250 Pro, ZMR250, Hubsan X4, Bixler 2

Toledodave

I found mine at top of first main page/tab in Arduino program when you load your 2.9 sketch.
It states:  #define THISFIRMWARE "MegaPirateNG V2.9 r300"

Hands0n

Doh! It did feel like I was doing something stupid ::)  Thank you. I';ll download and check that out. :)

Sent from my C6603 using Tapatalk 4 Beta

--
Danny
"Its better than bad, its good"

Current FCs: Pixhawk, APM 2.6, Naza M V2, Naze32, Flip32+ CC3D, KK2.1.5
Aircraft: miniMax Hex, DJI 550 (clone) TBS Disco, 450 Firefly, 250 Pro, ZMR250, Hubsan X4, Bixler 2

Toledodave

Quote from: Hands0n on Thursday,July 11, 2013, 06:24:43
Doh! It did feel like I was doing something stupid ::)  Thank you. I';ll download and check that out. :)

Sent from my C6603 using Tapatalk 4 Beta

    The only way i know to obtain 2.9 is through an Svn host. I used Tortoise Svn to get it. I believe 2.9 is still beta thats why its not per say...downloadable.

Hands0n

I';ve got Tortoise on my Windows PC, but been mostly on Mac or Android this week. Hoping for some play time this weekend :)

Quite interested in seeing this Crius 1.1 fly. Not had practical experience of Megapirate or APM, both WIP (slowwwwww)

Sent from my C6603 using Tapatalk 4 Beta

--
Danny
"Its better than bad, its good"

Current FCs: Pixhawk, APM 2.6, Naza M V2, Naze32, Flip32+ CC3D, KK2.1.5
Aircraft: miniMax Hex, DJI 550 (clone) TBS Disco, 450 Firefly, 250 Pro, ZMR250, Hubsan X4, Bixler 2

sevet

Why not try the megapirateng-add-ons? it has a new version 2.9.1b (newer than the beta MPNG 2.9.R7) which is said to completely squash the bug of falling out of the skies (motor disarm in midair)

https://code.google.com/p/megapirateng-add-ons/downloads/list

Hands0n

Quote from: sevet on Monday,July 15, 2013, 09:52:14
Why not try the megapirateng-add-ons? it has a new version 2.9.1b (newer than the beta MPNG 2.9.R7) which is said to completely squash the bug of falling out of the skies (motor disarm in midair)

https://code.google.com/p/megapirateng-add-ons/downloads/list



Thank you. 

Actually .......... I loaded up MP-add-ons during Sunday  ~~  I';ve got over a problem calibrating the ACC, had to do it in Terminal rather than the GUI part of Flight Planner, it kept failing using that (advice from a Peter King video to the rescue).  Now I';m just about ready to plant the FC into an air frame once the all essential GPS cable arrives, probably the next few days.

I got a good feel about ';add ons'; given the various write ups I';ve read.  I';m all in favour of more efficient code and the eschewing of stuff unlikely to be used such as the ultrasonic sensor. 

--
Danny
"Its better than bad, its good"

Current FCs: Pixhawk, APM 2.6, Naza M V2, Naze32, Flip32+ CC3D, KK2.1.5
Aircraft: miniMax Hex, DJI 550 (clone) TBS Disco, 450 Firefly, 250 Pro, ZMR250, Hubsan X4, Bixler 2