Welcome to Multi-Rotor UK. Please login or sign up.

Friday,August 23, 2019, 10:12:57

Login with username, password and session length

Shoutbox

Gaza07:
22 Aug 2019 22:47:32
Sorted mate  ~~
Andy7:
22 Aug 2019 10:27:36
Sure. But basically, all the subjects are getting cut off.
Gaza07:
21 Aug 2019 18:14:54
Can you pm me a screen shot of what you mean
Andy7:
21 Aug 2019 12:15:41
Gaza - can you make the subject line section in the forum topic list wider? It's cutting off the subject field really short.
Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
Members
  • Total Members: 8066
  • Latest: badger1
Stats
  • Total Posts: 196581
  • Total Topics: 19804
  • Online Today: 39
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 1
Guests: 33
Total: 34

Theme Changer





3d - Printworx

Printing 3d Forum

Incredibly frustrated

Started by Grimbo, Saturday,March 09, 2013, 11:33:49

Previous topic - Next topic

Grimbo

Well, this thing has me beat.  X-frame quad with Crius AIOP V2 and megapirateng.  All set up with mission planner; level, escs calibrated, flight modes set, tx stick directions all correct.

BUT - on take off (stabilise mode)  it tilts forward (and if I don';t do a sharpish application of power to get it in the air the front props will hit the ground and it will flip over) and if I can get it in the air it just wants to fly forward and needs constant rearwards correction.

I';ve re calibrated everything at least twice now.  The artificial horizon in Mission planner shows everything as it should, so   I have reached point of maximum frustration and I had to put it away before I attacked it with a large hammer. 

Has anyone got any ideas?  What am I missing?
Cheers

icedfusion

I did a quick search on your frame just to see what it looked like.
From the look of it, I will assume the FC board is mounted centered.
I will also assume that you have Centre of Gravity at this point (check by trying to balance it).


If everything happens as you describe, then you can try and calibrate the quad whilst it is in the air. You have to use the GUI to set a switch which allows you to adjust the gyro/accels in the air. I do this on my APM2.0, then when i check the ';Horizon'; in the GUI it looks way out, but it flies level.

Don';t forget to move all trims to 0 or centre before calibrating the level.

Sometimes, getting the horizon flat on the table does not translate to a stable hover when in flight.

ice.

Jumpy07

Could be one of a few things..
Check your centre of gravity is under the FC.. if not move the battery to compensate if possible
Could also be be accel calibration, make sure you have done this
Make sure you have calibrated your TX and all sticks centre ok and all trims are removed.
Also consider using autotrim if you need to make a lot of trim adjustments on your TX.
BNUC-S Pilot with PfCo /PFAW.
UAQ / CAA PfCo Instructor / Flight Assessor

"All that is necessary for the triumph of evil is that good men do nothing"

Grimbo

Thanks guys

I';ve tried to calibrate the accelerometers but all I get is "command received:", it does not go through the sequence of asking to move the model to different positions.  I think with magapirate and APM I have to do it manuallY?

Mover the battery back a bit to improve the CG, it was a bit off but I didn';t think it was enough to cause my problem.  Cannot try it at the mo as I need to recharge my batts.


steve fh

Hi.

Two weeks ago i was in a similar position to you with AOIP V2 Meggp 2.8 etc and a quad that checked out on the bench but tried to flip left or head off violently to the left each time i tried to fly.

Switched to the MultiWii code form this forum and instantly it flew and now after a few P value changes is hands off stable in acro and level mode.

Might be worth a switch to MultiWii (if you have not already tried it) to rule out firmware issues ?

I plan to try MeggaP again at some point once ive got a gps so i can use way points but for now MultiWii is letting me get air time.

One thing i have had issues with (think a few others have as well) is that i have to re trim the ACC';s each time i fly if i want level mode to work well.  I';ve started to wonder if this has something to do with why the MeggaP was messing around as as far us i understand even in acro it tries to level so will be upset if the ACC';s are losing calibration each time the board boots up.

Keep going it';s worth it in the end.

BNUC-S Pilot with PFAW.

www.capturedmotion.co.uk

Grimbo



Hmmm, Multi Wii - doesn';t support gps?  Not that i plan to use it right away, just curious.

And I think it uses multiwii GUI?

Gaza07

When you set your copter level how do you know its actually level ? the reason I ask is because when i do this I have a small level I use to check it, the new level command wont work with megapirate you have to use the CLI to set the acc level  ~~

Gaza07

Multi Wii does support Gps it does position hold and return home but doesnt yet support mission planning  ~~

Quote from: Grimbo on Saturday,March 09, 2013, 16:36:28

Hmmm, Multi Wii - doesn';t support gps?  Not that i plan to use it right away, just curious.

And I think it uses multiwii GUI?

Grimbo

Quote from: Gaza07 on Saturday,March 09, 2013, 16:49:57
When you set your copter level how do you know its actually level ? the reason I ask is because when i do this I have a small level I use to check it, the new level command wont work with megapirate you have to use the CLI to set the acc level  ~~


I put a level across it diagonally both ways, and then across both front arms , then both rear, then same each side.

Gaza07

Sounds good to me  do you use the CLI to set level after that  ~~

Quote from: Grimbo on Saturday,March 09, 2013, 17:27:25
I put a level across it diagonally both ways, and then across both front arms , then both rear, then same each side.

firey1

Quote from: Grimbo on Saturday,March 09, 2013, 13:56:27
Thanks guys

I';ve tried to calibrate the accelerometers but all I get is "command received:", it does not go through the sequence of asking to move the model to different positions.  I think with magapirate and APM I have to do it manuallY?

to make the calibration work you hold the throttle stick down and right as if arming then click calibrate for it to run the calibration process
Mike
MIKE

550 RC Spider quad for FPV
550 Alien quad (my sons now)
F450 quad
450 size bell 212, MD500,Augusta 109
600 size Huey running apm 2.5  3 planes  Taranis and 9xr  radios Skyzone FPV goggles

firey1

also a handy we thing for checking level is a button level stuck to my gyros  from hobby king  i use for my helicopters  using flymentor as you need to be level when powering up

http://www.hobbyking.com/hobbyking/store/__10614__Button_spirit_level_2pc_.html

Mike
MIKE

550 RC Spider quad for FPV
550 Alien quad (my sons now)
F450 quad
450 size bell 212, MD500,Augusta 109
600 size Huey running apm 2.5  3 planes  Taranis and 9xr  radios Skyzone FPV goggles

Rammylad

I have the Crius AIO pro Megapirate V 1.1 and to calibrate the level without using Mission Planner I connect the quad via USB for power. I then put the quad onto a level surface and hold the throttle stick to the left for about 15 seconds, you will see the Led';s flashing for a few seconds whilst it calibrates once the Led';s return to normal it is calibrated.

Rammylad

In this video at 14.06 seconds it shows you how the level calibration is done don';t have it connected to Mission Planner.


Grimbo

Quote from: Gaza07 on Saturday,March 09, 2013, 18:14:49
Sounds good to me  do you use the CLI to set level after that  ~~


Hmm, CLI doesn';t seem to have any functionality. Plugged in via usb, the only two tabs that give anything are log download (there aren';t any apparently) and log browse.

Grimbo

Quote from: Rammylad on Sunday,March 10, 2013, 10:08:06
I have the Crius AIO pro Megapirate V 1.1 and to calibrate the level without using Mission Planner I connect the quad via USB for power. I then put the quad onto a level surface and hold the throttle stick to the left for about 15 seconds, you will see the Led';s flashing for a few seconds whilst it calibrates once the Led';s return to normal it is calibrated.


Yep, that';s the way I';ve done it.  Thx