Welcome to Multi-Rotor UK. Please login or sign up.

Monday,August 19, 2019, 11:44:51

Login with username, password and session length

Shoutbox

Andy7:
19 Aug 2019 09:14:20
Good for you!  ~~
DarkButterfly:
18 Aug 2019 19:13:57
Had another negative encounter, it's been a few years since the last one, just an uneducated ******, going on about drones being illegal yada yada yada.    :-/
Still that didn't spoil my flying time, had an absolute blast  ~~
Gaza07:
07 Aug 2019 19:52:01
ooooh mrs jones  :D
hoverfly:
30 Jul 2019 15:26:34
D.B. you tightwad.. :cool:
atomiclama:
29 Jul 2019 20:14:10
DB that just means you have shed loads of props in the first place ;-)
DarkButterfly:
29 Jul 2019 18:53:33
Just had a thought, even with all the crashing I've done, I haven't bought any replacement props in over a year ~~
ched:
09 Jul 2019 19:45:42
May the sun shine and winds be light for BFU#8. Son't forget lots of vids for those of us unable to attend.  :D
Gaza07:
09 Jul 2019 18:10:30
Hope you all have a great day  :beer2:
Andy7:
09 Jul 2019 14:05:28
BFU#8 details locked in for this saturday - see the head of the forum thread for all details.
hoverfly:
05 Jul 2019 21:51:05
Good for genital warts as well......or so I'm told.. :hmm
Members
Stats
  • Total Posts: 196555
  • Total Topics: 19801
  • Online Today: 51
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 38
Total: 38

Theme Changer





3d - Printworx

Printing 3d Forum

DJI Phantom - A Word of Warning

Started by eyeflying, Wednesday,February 20, 2013, 15:11:11

Previous topic - Next topic

eyeflying

Just wanted to share this cautionary tale...

If you own or buy a DJI Phantom and you wish to change any of the setting on the Phantom';s Naza Flight Controller, make sure you download the Phantom';s Naza Assistant 2.02 software to do this. DO NOT under any circumstances use the standard Naza Assistant 1.8 as you will definitely  ';brick'; the Phantom';s Naza beyond repair!

I know this to be true as I';m trying to fix a Phantom for another member of this Forum who made this very easy mistake.

To date, I have spoken to DJI North America and two of the main UK dealers for DJI and none of them can offer a solution to restoring the Phantom';s firmware.

DJI in China have said that the Naza would need replacing with a new Phantom Naza so I spoke to a UK dealer who has stock of these. However, they have tried to repair another crash damaged Phantom and they installed a new Naza (dedicated Phantom version) but cannot get access to the settings as it says it needs to update its firmware but then just locks up when it tries to do so. They have tried two different Phantom Nazas and both have the same problem so it would seem that changing the Flight Controller is not a solution to a ';bricked'; Naza either.

And before anyone suggests it... the standard way of forcing a Naza Firmware update (F1 to F2) does NOT work with the Phantom.

Just thought I';d post this cautionary advice whilst I continue to try and find a solution for a very frustrated would-be-Phantom-flyer!


Gaza07

Oh thats not good thanks for letting us know  ~~

DarrellW

A good reason for going for an open source flight controller, not good enough really there should have been some sort of a block in the software/firmware stopping this from happening!
I think..........I think I am........therefore I am.............I think!

eyeflying

After many, many attempts at finding a solution and after several emails to DJI, plus a long phone conversation with them - they';ve given me a fix - and it works!

There is a way to restore the Phantom Firmware after all but for some reason, DJI don';t want this fix published. I suppose they want to sell you a new Flight Controller instead??


Jumpy07

Is it they don';t want the standard Naza M firmware installed on Phantom version ?
BNUC-S Pilot with PfCo /PFAW.
UAQ / CAA PfCo Instructor / Flight Assessor

"All that is necessary for the triumph of evil is that good men do nothing"

eyeflying

I think its probably a safety issue. It is possible to flash the Phantom with the standard Naza Firmware but then you';ll have issues with stability due to the fact the GPS and the compass are in different locations. There are also issues with the Phantom';s Tx controller too and the way its configured

They really want the Phantom to be an out-of-the-box solution - I don';t think they want people messing with it.


Rudeboy

Any chance you could pm me the fix, I have a phantom and a normal naza so could be handy should I ever mix the 2 up and put the wrong firmware on one!!
My YouTube Channel
Rudeboy's FPV Facebook Page

NorCal

Response to Multi-Rotor UK

Quote from: eyeflying on Wednesday,February 20, 2013, 15:11:11
To date, I have spoken to DJI North America and two of the main UK dealers for DJI and none of them can offer a solution to restoring the Phantom';s firmware.


Could you please post some more details about the dealers and how you reached DJI North America.  I can';t find a telephone number for North America (and they are notorious for not responding to emails).

I';m really afraid that I may have messed up huge time and "bricked" my MCU by updating to 3.01.  This was in response to a prompt that popped up in the assistant advising me of the update, so I thought I was following instructions.  Sure, there is a warning about the update not being for the Phantom, but it is pretty buried in the docs and overwhelmed by the pop up notice.  Oh well, I';m a new Phantom flyer, and I really loved the little beast, so I';m more hurt about this and looking for a fix than wanting to fix blame.

For the record, now the aircraft idles normally with the throttle back, but it will not begin to rev until the stick is at 50%.  Also, what would normally be one blinking light when it has satellites and is ready to fly, it has two in quick succession.  So, I';m not about to try to fly it in that condition, although I did a sort of taxi test by revving it up just enough to lift off a couple of inches.  BTW, I was in a room where the only things at risk were the Phantom (probably already trashed), myself, a lamp and some knickknacks.  Anyway, it lifted off nicely, but I had to be really ginger on the throttle.  Now, once it is past 50%, it revs up very quickly.

It looks like the 3.01 and the pop up message may have just shown up on the scene, as of May 1, so I suspect there might be a tide of people like myself that were led down the garden path by the prompt.  Hopefully, there will be answers for them on how to restore the firmware.

Thanks in advance for any help.  Believe me, it will be appreciated.

Cheers!

Gene


robshaw

I';ve just bricked £230k';s worth of conveyor equipment after a firmware update failed at 42%. Unfortunately for me these modules aren';t open source either..... So here';s to non Naza controllers. (For the moment anyway, until my crius megaP falls out the sky).
Tunrnigy Talon Tri, TBS Discovery, TBS Discovery PRO, Spnky 250 Mini, EZUHF, EZOSD

macspite

Quote from: robshaw on Sunday,May 05, 2013, 20:11:38
I';ve just bricked £230k';s worth of conveyor equipment after a firmware update failed at 42%.


Ouch! I hope the cost isn';t coming out of your wages ...  :blink