Welcome to Multi-Rotor UK. Please login or sign up.

Monday,December 16, 2019, 02:06:26

Login with username, password and session length

Shoutbox

Bad Raven:
02 Dec 2019 20:03:50
Only if the battery is fully charged, leak a few volts and it'll be fine.......
Andy7:
02 Dec 2019 17:19:55
If yo fly a Mavic Mini and get over a gramme of mud on it, do you have to register it?  :rofl:
hoverfly:
02 Dec 2019 08:38:56
Not a problem i've had a body mod, I think of Jean Harlow naked on a trampoline  and the new antenna  extends automatically..   :whistling:
Andy7:
29 Nov 2019 17:17:37
That'll play hell with your FPV signal. :rofl:
hoverfly:
29 Nov 2019 17:10:20
Won't get me i'm wearing my tin foil hat... :wack0
Andy7:
29 Nov 2019 14:19:03
Because GOVERNMENT SPY DRONES are watching us! :frantic:
hoverfly:
29 Nov 2019 11:41:22
BBC News this am ..only 50% of people have registered  for the  CAA  scheme.. If people haven't registered  how do they know it's 50%.. :shrug:
ched:
28 Nov 2019 20:16:14
Very very quiet. I am missing chatting :-( Must be the weather....
Gaza07:
25 Nov 2019 08:28:26
Forums very quiet  :shrug:
ched:
18 Oct 2019 11:25:16
Sounds good yama. Would love to see some images. 3d models sound cool too
Members
Stats
  • Total Posts: 197240
  • Total Topics: 19890
  • Online Today: 59
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 31
Total: 31

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

MinimOSD and APM problem...

Started by PaulJC, Saturday,May 09, 2015, 15:05:28

Previous topic - Next topic

PaulJC

Just wondering if anyone can help, i have a quad running APM2.5 with Arducopter 3.2.1, i have a minimOSD flashed with R800 and 3DR radio telemetry module, these are connected with a Y cable (RX only on the OSD).

My APM is powered by a power module and the MinimOSD has the solder tabs joined so is running 5v across the board.

If plugged in direct to the APM with both Tx & Rx connected the OSD functions completely normally...

If attached to the Y cable along with the telemetry radio the OSD boots up fine but it shows nothing but zero';s for data, this stays the same if connected to Mission Planner (1.3.25) or not...

If attached to the Y cable but with the telemetry radio unplugged I receive ';No mav data!';

I have ';enabled Telemetry'; within MP and also made adjustments to the settings of SR0 and SR1 and these seem to have made no difference.

Any ideas? I have tried searching without much luck?

Jimmer

I had the same problem, it seems some boards do not supply a decent enough signal level to drive both the telemetry and the OSD. I soldered header pins onto the UART 0 output on the board and fed my OSD from that - works great.

PaulJC

Quote from: Jimmer on Saturday,May 09, 2015, 15:32:29
I had the same problem, it seems some boards do not supply a decent enough signal level to drive both the telemetry and the OSD. I soldered header pins onto the UART 0 output on the board and fed my OSD from that - works great.


Awesome, that i can try  ~~

PaulJC

OMG i owe you massively, i';ve been pulling my hair out for hours trying to get this thing working and that done the trick straight away!! Thank You :notworthy: :notworthy: :notworthy: :notworthy: :notworthy:

Jimmer

Glad to be of help - a problem shared and all that lol.

Chewy

Hmmm, think i might give this a try too.  I have a Mavlink OSD here that i just haven';t been able to get going.  It came as part of a cheap APM kit from China.  Now i understand why it was cheap, none of it worked properly!  Being an electrical engineer, i';ve been slowly working through it, fixing all the faults.  I';ve had exactly the same symptoms, all zeros on the data or no mav data with the telemetry disconnected.  I was close to writing the OSD off and putting it in the bin, so it';s got to be worth a shot.

By the way, i found THIS THREAD over on the Ardupilot forums that has photos which show the solder points for future reference.

firey1

What you also may find is the split cable is wired wrong
I had 2 spliting cables to run osd and telemetry had both been wired wrong I just pulled the wires from the plugs re wired correctly and everything worked great
MIKE

550 RC Spider quad for FPV
550 Alien quad (my sons now)
F450 quad
450 size bell 212, MD500,Augusta 109
600 size Huey running apm 2.5  3 planes  Taranis and 9xr  radios Skyzone FPV goggles

Chewy

Nah, checked the wiring, it was all correct.  Anyway, tried connecting straight the UART0 pads, still exactly the same as before.  I';m writing the OSD off as a bad-un...

PaulJC

Also changed the advanced settings within mission planner?

Chewy

Yup.  Believe me, i';ve wasted hours on this OSD.  It';s in the bin now to stop me wasting more time trying to get numbers on a screen instead of flying the bloody thing...

PaulJC

Mine took me absolutely ages to get working, i';m sooooo happy it works spot on now though...

Hands0n

I';ve just today fixed a persistent problem that loomed up on my TBS disco rendering it useless for FPV. 

The problem was two fold - one was the video picture tearing making it impossible to view. This worked originally but developed after a few months.  Also the minimOSD overlay would disappear during the flight, requiring a power on reboot of the entire multi-rotor to get it going.

Today I solved both issues.   I fitted an LC filter to the power for the VTX and Camera, the tearing stopped.   But the minimOSD continued to "crash".  So I fitted a UBEC to power the minimOSD as a temporary cluge to save me hacking another feed from the LC Filter output.   That didn';t work either, the minimOSD continued to crash, although differently now, the overlay persisted, but simply stopped updating a few seconds after arming (it was fine before).

So after some searching with no good result I decided to update the minimOSD Extra firmware to the latest I could find, that being 2.4_r726 from here: https://code.google.com/p/minimosd-extra/downloads/list

That did the trick! I';ve got to think that the previous (stable) version I was running is no longer compatible with ArduCopter 3.2.1 (or possibly earlier!).   I have had over 40 minutes of flight with it this evening and it worked 100% throughout.

--
Danny
"Its better than bad, its good"

Current FCs: Pixhawk, APM 2.6, Naza M V2, Naze32, Flip32+ CC3D, KK2.1.5
Aircraft: miniMax Hex, DJI 550 (clone) TBS Disco, 450 Firefly, 250 Pro, ZMR250, Hubsan X4, Bixler 2

red zeppelin

HandsOn, sorry to revive an old thread but I think you have working what I am looking to set up.  Basically I want to add 1) telemetry link to android phone, 2) Video feed from camera to phone, and 3) OSD overlay onto video. 

I have been building the quad up over time and all is flying well, now on to the video and telemetry parts.  Right now I have a DBPower camera (knock off of a GoPro), I am not sure if it does video out but I think I can get the GoPro cable for that cheap enough to find out.  I know I need to get OSD, like minim or something and a telemetry module (TX and RX) like the 3DR one.

Question is, what does the wiring look like for all of this?  Also, if I can';t get real time video out from the DBPower camera, is there another suggestion on a camera that will record and transmit like that at the same time?  Thanks,