Welcome to Multi-Rotor UK. Please login or sign up.

Monday,December 16, 2019, 02:20:00

Login with username, password and session length

Shoutbox

Bad Raven:
02 Dec 2019 20:03:50
Only if the battery is fully charged, leak a few volts and it'll be fine.......
Andy7:
02 Dec 2019 17:19:55
If yo fly a Mavic Mini and get over a gramme of mud on it, do you have to register it?  :rofl:
hoverfly:
02 Dec 2019 08:38:56
Not a problem i've had a body mod, I think of Jean Harlow naked on a trampoline  and the new antenna  extends automatically..   :whistling:
Andy7:
29 Nov 2019 17:17:37
That'll play hell with your FPV signal. :rofl:
hoverfly:
29 Nov 2019 17:10:20
Won't get me i'm wearing my tin foil hat... :wack0
Andy7:
29 Nov 2019 14:19:03
Because GOVERNMENT SPY DRONES are watching us! :frantic:
hoverfly:
29 Nov 2019 11:41:22
BBC News this am ..only 50% of people have registered  for the  CAA  scheme.. If people haven't registered  how do they know it's 50%.. :shrug:
ched:
28 Nov 2019 20:16:14
Very very quiet. I am missing chatting :-( Must be the weather....
Gaza07:
25 Nov 2019 08:28:26
Forums very quiet  :shrug:
ched:
18 Oct 2019 11:25:16
Sounds good yama. Would love to see some images. 3d models sound cool too
Members
Stats
  • Total Posts: 197240
  • Total Topics: 19890
  • Online Today: 59
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 38
Total: 38

Theme Changer





thumbnail

3d - Printworx

Printing 3d Forum

Motors or Flight Controller fault? - SOLVED!

Started by ched, Sunday,March 29, 2015, 16:54:13

Previous topic - Next topic

ched

Sunday,March 29, 2015, 16:54:13 Last Edit: Monday,April 13, 2015, 12:24:24 by ched999uk
I have had my h107d for about 6 months. Only ever flown indoors, always calibrate gyros on same table that has not moved as it';s wedged between sofa and wall. Recalibrated tx, checked blades, arms, prop guard etc. I have had 5 batteries from new (6 months) probably 5 charges per week on each batt.

The problem is that it is drifting right and forwards. I can trim it stable at first but then drifting gets worse and worse. Change battery and its OK then drifts again.

I can blow the props and they turn no problem, they all feel fine but front left (viewed from rear) and rear left start slower and stop faster then the right ones.
I have new batteries on way, so if that is problem it will be sorted soon.

So do I have failing motors or is the Flight Controller/gyros failing?

Any ideas?
Thanks
I try :-)

philtrum

how easy is it to move a motor from one corner to the other, to see if the problem moves with the motor, or stays with the arm

if it moves ... needs motors
if it stays, is fc

Cheers
Phil
Many Thanks
Phil
www.makeitbuildit.co.uk

ched

Quote from: philtrum on Sunday,March 29, 2015, 17:15:50
how easy is it to move a motor from one corner to the other, to see if the problem moves with the motor, or stays with the arm
if it moves ... needs motors
if it stays, is fc
Cheers
Phil

Cheers Phil. Now why didn';t I think of that????? Shows what a difference experience makes.
Thanks I will give it a go.
I try :-)

quadfather

Quote from: ched999uk on Sunday,March 29, 2015, 16:54:13
The problem is that it is drifting right and forwards. I can trim it stable at first but then drifting gets worse and worse. Change battery and its OK then drifts again.


This pretty much mirrors my experience with the Hubsans.  I can spend an entire battery trimming it to hover in place, then I change for a fresh battery and it';s all over the place again.  :angry:

I have now decided that Hubsans aren';t meant to hover still and don';t bother with trims. ~~
-rw-rw-rw-  -  The Number of the Beast

iam4208

Yeah, I can';t get mine to hover hands free, but my brothers Syma X5 does no problem!
Hubsan X4, DJI Flamewheel F450 with Naza M V2/GPS, but too scared to attach my GoPro Hero 4 to it:-)

ched

Cheers. I have just had a little more of a check and my batteries/chargers are not right. charged on Friday night and they range from 4.07v to 4.48v! So before I do anything rash I will wait for my new batteries and charger to arrive. Ordered blades, batteries and better charger from BG at same time (11th Mar). Blades arrived early last week so batts and charger shouldn';t be to far behind.

Thanks. I will reply back when tested with new batts. :)
I try :-)

ched

Monday,April 13, 2015, 12:22:58 #6 Last Edit: Monday,April 13, 2015, 16:50:54 by ched999uk
New batteries and charger arrived and they are great. Still had the drifting problem. So not batteries or their charge level.
It got so bad that I had to switch to expert mode so I had enough roll to stabilise the drift!
It was not consistent either. It wasn';t that it would only happen when x4 got hot sometimes first battery sometimes 3rd.
Then I thought I would see if it was certain manoeuvres that caused the drift to get worse. It was yaw that made things go badly wrong!
So I had a closer inspection.
The prop guard was rubbing the front left prop hub!!!!!!!! But very lightly, so I could still blow the prop round, it felt fine.  I changed to the old broke prop guard and the x4 flys perfect again, well as perfect as I can fly anyway.

So it was a new prop guard that caused the problem!!!

Moral to the story remember when you change/replace components if you subsequently have a problem it might be the replaced part is not right!

Cheers.
I try :-)

iam4208

Funnily enough, I had a similar problem at the weekend.  I now check all props are spinning freely by hand after any prang!
Glad you cracked it ~~
Hubsan X4, DJI Flamewheel F450 with Naza M V2/GPS, but too scared to attach my GoPro Hero 4 to it:-)