Welcome to Multi-Rotor UK. Please login or sign up.

Monday,July 06, 2020, 05:39:46

Login with username, password and session length


04 Jul 2020 13:16:48
VIDEO or it didn't happen!! :) Nice going though, keep it up!
Bad Raven:
02 Jul 2020 19:46:48
whoelseisbored (LiamHowe89):
02 Jul 2020 17:45:19
Sounds basic but I'm happy with it  :laugh:
whoelseisbored (LiamHowe89):
02 Jul 2020 17:45:05
Managed a split s :D
28 Jun 2020 12:29:49
BF GPS Rescue mode configured - what could possibly go wrong?   :o
27 Jun 2020 21:07:37
and can't make it back to where you take off from   :laugh:
27 Jun 2020 21:07:04
it's too windy if you fly downwind
Bad Raven:
27 Jun 2020 20:51:32
I have done Dynamic Soaring in over 55mph, and quad flying in over 25mph with the right equipment.
whoelseisbored (LiamHowe89):
26 Jun 2020 16:44:24
How windy is too windy? :hmm:
whoelseisbored (LiamHowe89):
25 Jun 2020 22:58:29
YASSSS!! Flew a full 2 packs and no motors going nuts on me!  :D
  • Total Posts: 198958
  • Total Topics: 20050
  • Online Today: 28
  • Online Ever: 530
  • (Tuesday,June 26, 2012, 08:34:46 )
Users Online
Users: 0
Guests: 13
Total: 13

Theme Changer


3d - Printworx

Printing 3d Forum

Crius AIOP V1,V1.1 MultiWii 2.1 Firmware

Started by Gaza07, Saturday,September 08, 2012, 10:10:11

Previous topic - Next topic


Saturday,September 08, 2012, 10:10:11 Last Edit: Sunday,October 14, 2012, 22:18:14 by Gaza07
Here';s a copy of the multiwii 2.1 firmware that has been edited for the crius AIOP
using the rctimer cn-06 v1 and v2 gps or any other ublox neo 6m gps that doesn';t have the eeprom to store the gps settings,

this firmware would also work with the rctimer cn-06 v2 but that has a eeprom and can be setup using the ublox ucentre found here



Monday,January 07, 2013, 17:27:55 #1 Last Edit: Monday,January 07, 2013, 17:51:28 by koda
Thank you for sharing - since there is a newer version of MultiWii_dev_r1240, could you modify also this one, please? I´ve read that there some usefull changes for GPS control.

I tried to modify it myself but my CN-06 v2 (connected dirrectly through serial interface) does not lock sometimes. In version 2 of CN-06, the position should be stores in EPROM so I suppose it should lock ealisy after the first initialisation on the same place later. I´ve found that reflashing with the same firmware somehow helps and than the satelites emerge quite fast... After some day the story repeats.
Any ideas what is wrong? Should I also modify something in def.h ?

My config.h:




Secret Man is correct the fix has already been applied in the new Dev versions so just set up the config.h for the AIOP and the Ublox protocol  ~~


First off, thank you all for working on this code!

I have just used this code to flash my AIOP v2 and use with a uBlox CN-06 v2 GPS from RC Timer. 

I now have the quad and laptop sitting outside where it can "see" the sky and yet there are still no satellites being reported in the GUI.  This brings up a couple of questions:

1. Did I need to change the baud rate on the CN06 before use?  What I mean is that I see various mentions of using Ublox software or other tools to change the baud rate before the CN06 is usable.  In fact, RC Timer';s website even mentions this on the CN-06 product page but I am confused because it also seems like the message here is that the CN-06 is "plug and Play" if you have the correct MWC code which you all have kindly provided.  If changing the baud rate beforehand is necessary, can someone please provide some steps or point me towards a tutorial?  I have been trying to do this simple task for hours with no luck.

2. Approximately how long does it take the CN-06 to "lock on" to GPS satellites the first time I use it (cold start)?  Maybe that';s why the MWC GUI doesn';t show anything yet?

Many thanks in advance for your help.



One other thing I would like to add:

I currently have the GPS hooked up to the "Serial 0" port on my AIOP v2.0.  This is the same as the FTDI port.  I did set the following line in the config.h file:

#define GPS_SERIAL 0

Could the use of this particular port be causing the GPS not to function?

I do get a solid green LED on the GPS so I can confirm that it is getting power.

Thanks again for any help.



I';m not sure if the gps would work on serial 0 or not but its not just a case of setting the port number in the sketch you have to have it physically wired to the correct port to, Is there a reason you cant use port 2 which is the normal port for the gps ? any chance ofa picture or diagram of your connections  ~~


Thanks Gaza07.  Your suggestion worked.  I had soldered wires onto the wrong molex connector so I was just being lazy and using the FTDI port which was labeled on my AIOP v2 as "Serial 0".  Then I was attempting to plug into my usb connector so I could check GPS status on the MWC GUI.  Well, I forgot, you can';t use FTDI and USB connectors at the same time.  I switched to the Serial 2 connector (and changed the config.h accordingly back to "Serial 2") and all was well.

One other thing that was stupid of me and had me stumped for a while (and I sincerely hope this note spares someone else the pain despite my embarassment): DON';T FOR GET TO ROUTE "Tx" FROM THE GPS TO "Rx" ON THE AIOP AND "Rx" FROM THE GPS TO "Tx" ON THE AIOP!!!!  This little oversight cost me hours!!

Thanks all!


Thank you for this! I have been struggling with this for a month.
Downloaded and tried to execute MultiWiiConf_2_1 but get this error: C:ProgramData\Oracle\Java\javapath\javaw.exe
Unspecifed error

Any thoughts?



Have you visited the java web site and see if there is an upgrade or try to re install java  ~~


Thanks, yes. I updated java, twice. Had my son try it on his laptop and he got the same error. Is multiwii worth bothering with? Any advice on a fc with code that actually works?


Multi Wii is a good firmware flys very nice and easy to setup normally, give the wii win gui a try instead of using the conf program,
you can find the latest version here https://code.google.com/p/mw-wingui/ see how you get on with that,
you can also upload megapirateNG to the AIOP which is a port from the APM but its quite a bit more involved than wii, and can take a fair bit more effort to get it flying smoothly,
A lot of members are currently using the APM the guys in chat are mostly APM users so you could consider one of those but you would need the flight controller gps module and telemetry modules all can be had from rctimer in a single package its quite a complex system but the guys who already use it can make it much easier, it supports auto flying with way points and will perform as good as much more expensive units, or you could go for a naza lite with gps which is almost plug and play and very easy to fly and setup,
I currently have a couple of naza';s a couple of APM';s and a fixhawk which is a 32 bit APM type fc oh and not forgetting a hand full of rabbits  :rolleyes:

Quote from: tapinkham on Saturday,December 13, 2014, 22:19:23
Thanks, yes. I updated java, twice. Had my son try it on his laptop and he got the same error. Is multiwii worth bothering with? Any advice on a fc with code that actually works?