Pages:
Actions
  • #31 by Gavster29 on 11 Feb 2018
  • Thanks guys, ordered! I'll look back on the old thread next time!

    Sent from my TA-1033 using Tapatalk

  • #32 by Gavster29 on 15 Feb 2018
  • I need some help folks!

    My new receiver turned up today, wired it up and whilst the gimbal channels and Channel 12 rssi work I can't get any of the switches to activate in Betaflight!

    I've set the 2 way switch to channel 5 for arm and and 3 way mode switch on channel 6 in the QX7 but I get nothing on any channel in Betaflight :(

    Sent from my TA-1033 using Tapatalk

  • #33 by ched999uk on 15 Feb 2018
  • I know very little to nothing about taranis but I have seen quite a few posts were people are asking for help setting up. Might be worth looking at a youtube video for setting up the QX7?
    Just had a quick search and found this from Project Blue Falcon (Rip). Seems like he has a series of vids on QX7.
  • #34 by Gavster29 on 15 Feb 2018
  • I know very little to nothing about taranis but I have seen quite a few posts were people are asking for help setting up. Might be worth looking at a youtube video for setting up the QX7?
    Just had a quick search and found this from Project Blue Falcon (Rip). Seems like he has a series of vids on QX7.
    Thanks Ched, that is the guide I followed to setup the aux channels, I might switch to the big FlySky receiver to see if it's the Taranis or the FC!

    Sent from my TA-1033 using Tapatalk

  • #35 by Cheredanine on 15 Feb 2018
  • Actually the vid does too much, you don’t need to set up inputs and mixer on the radio, that is for more complicated aircraft than quads
    No need to set up inputs, see my inputs page:
    <br /><br /><br />free share picture<br />

    You only need your mixer page:
    <br /><br />
    And the only thing you need to set for channels 5+ is the source which you do by selecting it and then flipping the relevant switch:
    <br /><br />

    Don’t forget when the channel is 5 that is aux1 on betaflight, NOT aux 5

    Check the switches work in the reciever channel of betaflight

    That setup gives me a three position switch on aux 1 which I use for dissarm / arm / arm and air mode
    A three position switch on aux 2 for flight mode for angle, horizon and rate/acro mode
    A momentary switch on aux3 for pre arm
  • #36 by Cheredanine on 15 Feb 2018
  • Other things to do are for ruder, are and el, set the subtrim, do this connected to bf and looking at the reciever tab, adjust the values for the end points and most importantly the midpoint on the outputs tab on the radio so it is 1000-2000 with 1500 at mid stick:
    <br /><br />

    (I don’t bother with end points as you can see, just the. Mid point which is the critical thing)

    And the other thing is if you have loaded a sound pack on to an sd card you can set up audible alerts on the special functions tab;
    <br /><br />
  • #37 by Cheredanine on 15 Feb 2018
  • Pps no issues with blue falcon but I learned opentx and Frsky from painless360 you tube vid, Lee is a Brit who you can email and he is helpful, his x9d playlist is massive with loads of different episodes covering everything and it is completely applicable to qx7
  • #38 by Gavster29 on 16 Feb 2018
  • Pps no issues with blue falcon but I learned opentx and Frsky from painless360 you tube vid, Lee is a Brit who you can email and he is helpful, his x9d playlist is massive with loads of different episodes covering everything and it is completely applicable to qx7
    Thanks mate,

    I will play around again tonight and see if I can get it up and running! I will probably be back though.....

    Sent from my TA-1033 using Tapatalk

  • #39 by Gavster29 on 16 Feb 2018
  • I have just twigged that I didn't even touch mixer settings I only added inputs!

    I hope that is the issue.

    I will start looking at some YouTube videos as soon as I can, I guess this is the best way to learn, throw yourself in the deep end!
  • #40 by Cheredanine on 16 Feb 2018
  • Lol 100% the problem
  • #41 by Gavster29 on 16 Feb 2018
  • Oooops! I'll go off and hang my head in shame.

    Thanks for your help :)

    Sent from my TA-1033 using Tapatalk

  • #42 by Cheredanine on 16 Feb 2018
  • Lol opentx can appear a bit daunting at first, people will say it is brilliant once you get used to it (they did to me), I have to admit I was very sceptical. But they are right, a major part is realising it will do everything you will ever want for rc, and flying quads, that is a lot of stuff you just are not interested in.
  • #43 by Gavster29 on 16 Feb 2018
  • Ok so I need to get researching on the switches but I can confirm they work under mixer settings, however now I need to work out why the 3 way switch is only doing 2 positions, like I said time for some research!

    Thanks guys.

    Sent from my TA-1033 using Tapatalk

  • #44 by Cheredanine on 16 Feb 2018
  • What value is it sending?
  • #45 by Gavster29 on 16 Feb 2018
  • What value is it sending?
    I need to double check when I'm back in Betaflight.

    So I've been going through painless360 videos tonight and it is helping quite a bit!  I have flashed openTX 2.2.1 and actually installed a memory card, I now have sounds! Doh should have done this ages ago.....

    Anyway I will carry on working through and will have a look at Betaflight tomorrow, I can see movement on the switches when I select them on the QX7 screen.

    1 last Q, my screen seems to have a few dark lines in places depending on the angle you look at it, it's a bit annoying, is it normal or should I be looking at going back to the retailer?

    Sent from my TA-1033 using Tapatalk

  • #46 by Cheredanine on 17 Feb 2018
  • Hard to say mate tbh, you can change the display settings mind, again painless has a vid
  • #47 by Gavster29 on 17 Feb 2018
  • Ok so feeling much better about things now!

    My aerial savers arrived today, in the same green 3D printed plastic as the camera mount so it looks the same and I have to say quite cool!

    This meant that I had to move my receiver so it's now cable tied around the top standoffs on the stack in 2 directions I also used some clear heatshrink on it for protection.

    I had to move the cap so that is now cable tied to the top plate, however as a result I managed to stretch the wire enough to cause a short, so I repaired that and used hot glue to stop it pulling in a crash, whilst I had the hot glue gun out I glued the plastic nuts for the electric stack and also put a div on the dipole aerial on the VTX however I'll swap this out at some point.

    Finally I added all the screws for the motors, this time with loctite and also added loctite to the bottom plate screws.

    Sent from my TA-1033 using Tapatalk

  • #48 by Cheredanine on 17 Feb 2018
  • Good job mate, now one little suggestion:
    Switch the two antenna tube holders over so the antenna run up in front of the rear standoffs rather than out the back (if you look at mine you will see what I mean). Reasons:
    1. Antenna are supposed to be at 90 degrees to each other to maximise benefit of diversity, by running them about the back you reduce the angle. (Dipole antenna have a “blind spot along the axis of the antenna, by putting them at 90 degrees you minimise the impact of this as you can not be along the axis of both antenna without being inside the quad)
    2. Reduces the chance of prop strike in a crash

    Edit assume you are aware but prop nuts clearly not tight and get it in the air!!!
  • #49 by Gavster29 on 17 Feb 2018
  • Good job mate, now one little suggestion:
    Switch the two antenna tube holders over so the antenna run up in front of the rear standoffs rather than out the back (if you look at mine you will see what I mean). Reasons:
    1. Antenna are supposed to be at 90 degrees to each other to maximise benefit of diversity, by running them about the back you reduce the angle. (Dipole antenna have a “blind spot along the axis of the antenna, by putting them at 90 degrees you minimise the impact of this as you can not be along the axis of both antenna without being inside the quad)
    2. Reduces the chance of prop strike in a crash

    Edit assume you are aware but prop nuts clearly not tight and get it in the air!!!
    I have been out with the family so no chance of getting her airborne today :(

    I'll go make the changes now I'm back!

    I have another question and it may or may not be silly! I'm hoping I don't have to get the soldering iron out again.

    My motors, they spin in the opposite direction to the picture on Betaflight (it is set for reverse like in the guide) I assume this is wrong, can I change it in software?

    Forgot to say, prop nuts only on for pics, I'm being a good boy and not running props whilst getting setup!

  • #50 by Gavster29 on 17 Feb 2018
  • Better?

    Sent from my TA-1033 using Tapatalk

  • #51 by Cheredanine on 17 Feb 2018
  • Much better :)
    Motors -don’t recall if they updated the gui.
    In the config tab at the top left there is a run reversed motors  I always turn that on.
    With that enabled motor 1, when looking from above, should turn anti clockwise

    If it turns clockwise you can run motors normal direction or connect blhelisuite and reverse the motor direction, either way no soldering iron required
  • #52 by Gavster29 on 17 Feb 2018
  • Much better :)
    Motors -don’t recall if they updated the gui.
    In the config tab at the top left there is a run reversed motors  I always turn that on.
    With that enabled motor 1, when looking from above, should turn anti clockwise

    If it turns clockwise you can run motors normal direction or connect blhelisuite and reverse the motor direction, either way no soldering iron required
    That is such a relief!

    Thanks for the help through all this, I've learned a lot!

    Sent from my TA-1033 using Tapatalk

  • #53 by Cheredanine on 17 Feb 2018
  • No problems, we alll had to learn somewhere :)
  • #54 by Gavster29 on 18 Feb 2018
  • Phew, first actual flight today!

    So just to keep a record, I tried Betaflight in both directions but my motor 1 was going clockwise regardless of motor direction switch, got blhelisuite running and switched motor direction.

    Next was my first test with the radio and no connection to the PC, good job I wasn't using props as it went a bit mad, I pulled the battery but that would have been a nightmare with props!

    So all sorted played with Betaflight again and set up my switches, tested failsafe and took her in to the garden.

    Mistake no.1 I didn't pay attention to prop direction and she wanted to backflip, quick swap around again and straight away she was hovering!

    That's enough excitement for 1 day

    Sent from my TA-1033 using Tapatalk

  • #55 by Wyntrblue on 18 Feb 2018
  • If you flash it to betaflight 3.3 you can enable “anti taz” which means if you have the props on wrong or some thing it will disarm before it goes all taxmainian devil on you :)
  • #56 by hoverfly on 18 Feb 2018
  • My nephews daughter is called Taz,  all  that's needed  is a way to load the firmware. :laugh:
  • #57 by Gavster29 on 18 Feb 2018
  • Anti-taz quite apt I guess lol I won't make the same mistake again I hope!

    If they had an Anti-idiot mode it would never take off for me

    Sent from my TA-1033 using Tapatalk

  • #58 by mo_miah on 19 Feb 2018
  • glad to hear its up in the air, great feeling when it does the first hover, now to learn acro
  • #59 by Gavster29 on 19 Feb 2018
  • glad to hear its up in the air, great feeling when it does the first hover, now to learn acro
    You're not wrong there Mo!

    The sound of those props spinning though you can just hear and feel the power! I would not want anyone near it while I practice crashing.....

    Sent from my TA-1033 using Tapatalk

  • #60 by Gavster29 on 25 Feb 2018
  • Friday night I was over my friends place and took her out for a proper flight (LOS) just hovering and getting a feel for the Taranis and the Air-Ro, the power is just amazing!

    A bit disappointed I missed the fly up yesterday but had a few things to do at home.

    Finally Banggood emailed me today to say the battery I ordered has been returned to them so looks like I will be trying to find some more locally.

    Sent from my TA-1033 using Tapatalk

Pages:
Actions