• #1 by iCrashEdit on 17 Feb 2017
  • So I just order my taranis qx7   ::)

    But will it work with my frsky xsr as I know you have to have the transmitter on a certain setting for them to pair, does the taranis qx7 have said setting?  :crossfingers: :crossfingers:
  • #2 by Cheredanine on 17 Feb 2017
  • It will work fine, you will need to use d16 but go to painless360 YouTube channel, he has a whole playlist on the taranis, I believe the qx7 is pretty much identicle to the older model.
    The playlist has lots of stuff you don't need (setting up mixers etc etc
    Some stuff you may want to use or may not - updating seems unlikely, adding custom sounds

    And some stuff that you will want:
    Setting up models
    Binding receivers
    Setting up additional channels for multirotors
  • #3 by Hozza on 17 Feb 2017
  • Painless has started a QX7 series

  • #4 by Cheredanine on 17 Feb 2017
  • Ooo no one told him the white one is for girls!  :o
  • #5 by Boardrider on 21 Feb 2017
  • Hi,
    I'm new to this hobby and have become lost in all the info online. I need some guidance please.
    I've had my Q X7 for a couple of weeks now, and have been using it to fly on a sim.
    I bought an XSR receiver a few days ago as it ticked all the boxes, I was aware that this will only work with the D16-eu lbt, I did a little research and it seemed that this may be a good thing.
    Prior to attempting to bind the receiver, I flashed Q X7 firmware with version 2.2.0N362 (3e00d016), using  OpenTX companion. Tried to bind, setting internal rf  on X7 to D16 but no luck.
    I have since downloaded firmware from FrSky site, stuck them on the SD card and have loaded eu versions direct from Q X7. Still no luck!
    Firstly, I'm not sure if I have flashed a version of the OpenTX firmware, which is not compatible with the XSR.
    Secondly, I'm not sure if I'm setting up the transmitter to bind correctly.
    Any advice greatly received.  :smiley:
  • #6 by Cheredanine on 21 Feb 2017
  • Ok first thi to learn is open tx is the radio operating system, this talks to the internal module, which in turn is what is running the firmware that needs to be compatible with the xsr, not opentx (judging from the version what you have flashed your taranis with is the latest open tx, not the module firmware)

    Use LBT firmware, best thing to do.
    The firmware on your xsr needs to match in type and frequently version to the module, where did you buy them both from?

  • #7 by Boardrider on 22 Feb 2017
  • Thanks for your reply.

    I spent some more time on this yesterday and I came across a thread on RCGroups (Binding a Taranis Plus with a frsky XSR receiver), which I thought would be the answer.
    There are links on that thread, to eu lbt and non-eu firmware for both the XSR and the transmitter module (the Tx module for the Q X7 is the same as the X9Dplus right?).
    I've flashed the X7 Tx module and the XSR Rx with the eu lbt firmware and still no joy, I was going to try the non-eu firmware but the XSR wouldn't accept it.

    The transmitter came from banggood and the receiver (listed as eu lbt firmware) was from OrangeRX.

  • #8 by Cheredanine on 22 Feb 2017
  • So you have flashed both with the same version of firmware.
    Next question can cou detail exactly how you bind and determine it is not bound?
  • #9 by Boardrider on 22 Feb 2017
  • F**kity f**kity f**k! Think I've just blown my XSR   :angry:

    I found the XJT Tx module lbt firmware on the FrSky website and flashed that.
    Downloaded the beta firmware for the XSR from the FrSky site and (like a stupid dipstick) managed to cross connect the jumpers when setting up the receiver on the pin-outs of the X7 external module bay - went GND, +5V, S port from bottom up rather than S port, GND, +5V.

    Receiver now not accepting firmware. I hope the internal Tx module is ok?!

    In terms of binding;
    On Q X7
    I was going into page 2 of model set up menu
    Scroll to Internal RF Mode - D16
    Check Ch Range Ch1-16
    Check Rx Num
    Scroll to Bind and press centre of wheel so it starts to chirp.

    On Rx
    Press and hold button under clear heatshrink
    Apply power (+5V & GND only)
    Green & red led come on (can't remember if they flashed before I blew the board, they're on steady now)
    Power off Rx, exit menu on Tx and power Rx back up again
    Red led flashes (before I blew Rx, now red and green both steady).