User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

MultiRotorUK ShoutBox

Refresh History
  • hoverfly: you been watching... :embarrassed
    December 15, 2017, 14:16:18
  • VaNDAL_UK: grab ya TX and pretend to be flying it
    December 15, 2017, 11:22:49
  • hoverfly: Sitting looking out the window watching  a Redkite  being mobbed by a couple of crows.   3d handbrake corners , and a  visible contempt for gravity  .So not a bad morning so far.. :smiley: :smiley:
    December 15, 2017, 10:29:36
  • Icefever: At last the TX is talking to the FC...now I can get on with sorting out the next part
    December 14, 2017, 15:40:20
  • Icefever: Bad R...I have matey here..[link].
    December 12, 2017, 15:30:28
  • Bad Raven: IF/A7, a summary thread would enable more people to look and comment, its too big here!
    December 12, 2017, 07:05:40
  • Icefever: I've set the failsafe in the TX setting that's all..there's no connection between the TX and quad. at all..
    December 12, 2017, 03:40:10
  • Icefever: Andy..I've only messed with the failsafe one...but not in Beta.
    December 12, 2017, 03:38:04
  • Andy7: Ice: Is it just that it's not arming? Have you set the switch settings in betaflight?
    December 11, 2017, 21:24:23
  • Two-Six: Fixed it yet Ice?
    December 11, 2017, 15:04:23
  • hoverfly: ffs.. :rofl: :rofl:
    December 11, 2017, 14:51:15
  • Bad Raven: No, a nun falling down stairs...............
    December 11, 2017, 14:01:01
  • DarkButterfly: :laugh:
    December 11, 2017, 12:27:30
  • hoverfly: you are probably on a zebra crossing. ::)
    December 11, 2017, 09:49:42
  • Bad Raven: Everything went white, black, white, and is now mostly black again.............
    December 10, 2017, 16:55:37
  • hoverfly: everything has gone white. :shrug:
    December 10, 2017, 12:21:29
  • Icefever: Hi Andy I have a prob with the Tx.  it's bound to the rx but when I try the either gimbel nothing happens....I have a green led on the rx..when connected to beta I can run up the motors but nothing else??help
    December 10, 2017, 09:23:12
  • Andy7: Perfect day to have shaved off the beard.... :(
    December 10, 2017, 09:17:17
  • Saleem: Just dont do it facing the wind
    December 09, 2017, 19:36:25
  • hoverfly: AGHHH  yellow snow warning  :laugh:
    December 09, 2017, 18:49:57

Who's Online

Theme Selection



Forum Default

Permanently

Author Topic: Updating the Taranis 9Xd Plus with the latest firmware  (Read 2640 times)

Offline nate80

  • Site Sponsor
  • Trade Count: (0)
  • Sr. Member
  • *****
  • Posts: 891
  • Liked: 239
  • Country: gb
Updating the Taranis 9Xd Plus with the latest firmware
« on: October 12, 2016, 13:52:58 »
Hi guys,

I tried to update the Taranis firmware using the software supplied on the FrSky website.  But it turns out it';s version 2.1.6 - the same firmware as is already on the radio

So I went to the Open TX website for the most recent firmware, but according to the website OpenTX version 2.2 is only available after downloading the TX Companion in .exe format.  So I downloaded the newest Open TX companion and installed it.  But when I try to search for Open TX Companion updates, or Firmware updates I get an error message that says ';Unable to Check for Updates';.

How can I update the firmwares of the internal module, the Taranis'; OpenTX firmware (version 2.2 apparently), or the X8R receiver firmware to the newest versions?  Are the individual files available anywhere other than through the TX companion software (which can';t search for updates) or the FrSky website (which seems to provide outdated files)?

Offline MrThrust

  • Trade Count: (0)
  • Jr. Member
  • **
  • Posts: 98
  • Liked: 79
  • Country: scotland
  • Renegade Racing
    • Blog
Re: Updating the Taranis 9Xd Plus with the latest firmware
« Reply #1 on: October 12, 2016, 15:17:48 »
normally you just copy the new firmware to your Taranis SD card and flash it using the radio!

download the opentx
http://www.open-tx.org/2016/09/15/opentx-2.1.9

Upgrading Stock Taranis Firmware to OpenTX


upgrade bootloader mode!

Offline nate80

  • Site Sponsor
  • Trade Count: (0)
  • Sr. Member
  • *****
  • Posts: 891
  • Liked: 239
  • Country: gb
Re: Updating the Taranis 9Xd Plus with the latest firmware
« Reply #2 on: October 12, 2016, 19:10:51 »
Cheers for the links.  That was a great pointer in the right direction.   ~~

The OpenTX 2.2 companion software is broken and won';t connect to the online servers.  As soon as I installed the companion .exe file on the webpage that you provided the updates function worked perfectly and I was able to grab the new OpenTX firmware.

Once I had installed the new OpenTX firmware I was able to update the Bootloader, the Internal Module and the X8R receiver using the SD Card and the Taranis'; Firmware loader.  I had to make a specific data transfer cable out of a standard servo lead to successfully flash the RX, but I found a great guide for that here:

http://www.dronetrest.com/t/how-to-upgrade-firmware-for-frsky-taranis-x9d/959

Thanks again.   :beer2: