Pages:
Actions
  • #1 by Wyntrblue on 05 Jun 2018
  • Hey guys,

    I bought myself a crossfire micro and Nano Rx and have had no end of trouble with it.

    Long story short I can’t get the tx and rx to bind. After talking with tbs they said it was a faulty nano. My vendor (who’s been amazing) swapped out the nano without incident. So I connected power to the new nano  but not to a uart as I wanted to ensure that I had a proper bind without the F.C. causing a problem. Unfortunately I’m still unable to bind the 2. I only ever get opentx saying “binding” and a green flashing light on the tx module and a green flashing light on the nano.

    I can’t have 2 bad nanos in a row? Is there something in opentx2.2.1 that’s causing the bind to fail? I’m utterly stumped and it’s doing my head in.
    How long does it actually take to bind crossfire when it’s all working correctly?

    Anyone got any ideas?
  • #2 by ched999uk on 05 Jun 2018
  • I am sure someone with some knowledge will be long soon. But I assume that you have correct FW for the crossfire? Do you have to add any FW to the tx not the internal module?
  • #3 by Wyntrblue on 05 Jun 2018
  • From what I have read you need opentx 2.2 or higher. And I’m on 2.2.1. The crossfire lua seems to work as in if I tell it I want to bind the green flashing binding light comes on on the module
  • #4 by Cheredanine on 05 Jun 2018
  • Lol I went through this, you are confusing the crossfire module with the micro module.
    You do not use the taranis/Luca scripts to bind with the micro (or rather you can but it is a pain I. The bum.

    To put the crossfire micro tx into bind mode you use the push button functionality as detailed in the manual I am linking below.

    Once it has updated the rx, THEN you run the crossfire Lua, the nano rx will have appeared and you can set the pin out 1 and 2 to crsf tx and crsf rx

    https://www.team-blacksheep.com/tbs-crossfire-micro-tx-quickstart.pdf
  • #5 by Wyntrblue on 06 Jun 2018
  • Iv tried using the button and not using the lua script and it does the same thing:/
  • #6 by Cheredanine on 06 Jun 2018
  • Ok mate I definitely find it easier using the buttons, also need to have antenna aligned (parallel a few feet apart)
    And it does sometimes take a minute or two and a few attempts.

    Also have you updated the firmware on the tx?
  • #7 by Wyntrblue on 06 Jun 2018
  • iv updated the firmware to the latest on the micro tx, set the frequency to 868 and thats it. so far im finding that crossfire is more like missfire. tonight i am going to install the latest openTX nightly build and test again. but i doubt thats going to be the cause of the issue as its the module not binding to the rx thats the issue.
  • #8 by Cheredanine on 06 Jun 2018
  • Understand mate

    Take it slow, a step at a time.
    Power on tx,
    When it is powered, short press the button.
    When the light is flashing power on the rx
    Short press the bind

    Leave them for a minute or so,
    If the tx doesn’t change, shor5 press the button again

    It can be fiddly

    Ps as abovevmake sure antenna are aligned and nothing in between, I have noticed mine were not whilst waiting to bind and moved them slightly, and suddenly the thing lit up, leaving me holding the quad in mid air not daring to move whilst it updated :)

    I agree it is fiddly to set up, I only shifted to crossfire about a month ago, only built 4 quads with it and only 1 of them went smoothly, had to repeat stuff or give spurious button presses etc to get it bound and updated. But once it is there it is golden
  • #9 by Wyntrblue on 06 Jun 2018
  • Here’s what it does (the only thing it does)

  • #10 by Wyntrblue on 06 Jun 2018

  • #11 by Cheredanine on 06 Jun 2018
  • Ok mate, sorry this may be something you have already done but let’s try.
    Power on the tx.
    Press the button on the crossfire tx (don’t do anything with the taranis it’s self
    Power on the rx
    Guessing you have both doing what they have in the vid
    Give the button on the tx, one short press.
    See what it does next
  • #12 by Wyntrblue on 06 Jun 2018
  • I will give that a go tomorow as I’m out this evening. I will get a video tho
  • #13 by Wyntrblue on 06 Jun 2018
  • Ok came home due to my plans being cancelled (would have been nice to have been told) so tried this and got the same result
  • #14 by Cheredanine on 06 Jun 2018
  • So both were flashing green, you pressed the button on the tx and it made no difference?
  • #15 by Wyntrblue on 06 Jun 2018
  • If I press the button on the tx when it’s flashing green it stops and shows an orange light the sort of pulses
  • #16 by Cheredanine on 06 Jun 2018
  • To give you some assurance I have had one of mine do that, I just don’t remember how I sorted it.

    Once it is orange do another (short) press, should go back into bind mode, then pick the radio up and move it around near the quad, changing the aspect, don’t ask me why but I think that is what I did


    Did you say you changed the freq on the tx?
    May be worth changing it back and trying again
  • #17 by Wyntrblue on 06 Jun 2018
  • Ok set it back to 915mhz and tried again moving the thing round the quad at various angles and....

    Nope still just get green flashing lights on the tx and rx. Followed by a red flashing on the rx after a while
  • #18 by Cheredanine on 06 Jun 2018
  • Only real options are using the button to put it (the tx) in and out of bind mode repeatedly without powering down.
    Then try same from the lua script but the micro is supposed to be done on push button (also just in case, tx should be in bind mode before the Rx is powered up, dunno if that makes any difference)

    But otherwise tbs support, your supplier ought to have done that already, but if they haven’t you can raise a ticket directly with tbs on their site

    Edit: afterthought, may be worth trying with the tx farther away from the rx
  • #19 by Wyntrblue on 06 Jun 2018
  • i tried binding it with the quad sat at the bottom of the garden and still the same. i am currently working through each of the available firmwares to see if i can get any of them to bind
  • #20 by Wyntrblue on 06 Jun 2018
  • Now done all the available firmwares on both 868 and 915mhz and nope it’s not having any of it!
  • #21 by Cheredanine on 06 Jun 2018
  • No mate I don’t think it is the firmware.
    It is like they are not communicating.
    You haven’t dropped the transmission power of the tx dramatically have you?

    Every time I have fiddled mine into working it has been done by a combination of moving the quad, moving the radio, pressing the buttons and repowering
  • #22 by Wyntrblue on 06 Jun 2018
  • Nah not dropped the power and tried a bunch of locations around it and have given up! Gonna go see the person who I bought it from on Saturday morning now.
  • #23 by Cheredanine on 06 Jun 2018
  • Think that or direct support call with TBS showing them your vid would be the way to go
  • #24 by Wyntrblue on 06 Jun 2018
  • Im already talking to remo about it. But at least when I head in we can hopefully try an alternative tx module and see if that binds to the rx. Or something.
  • #25 by Wyntrblue on 09 Jun 2018
  • This turned out to be a duff tx module. Now all sorted :)
  • #26 by Cheredanine on 09 Jun 2018
  • Congrats mate
Pages:
Actions