Pages:
Actions
  • #1 by Mi96ke on 07 Jan 2018
  • I've gone through loads of threads and YouTube videos but still nothing,
    Trying to bind my taranis 9xd+ to x4rsb receiver;
    D16, 1-16, bind mode.
    F/s held down, power on, should get a red and green light (I know what to do or will be able to figure it out from there) but I'm only getting the solid red light on the Rx.
    I know about the different firmware versions etc and have tried new, old, EU, non EU firmware on the taranis, the x4rsb is EU, bought a month ago. Ideally I'd like a flashing green light but even if I can get it to both solid it'd be something,
    I've gone through most of the internet regarding this, anyone got any ideas on this one?
    Thanks
  • #2 by Bad Raven on 08 Jan 2018
  • There is EU and there is LBT EU. Anything bought recently will be LBT. Any possibility you have used the wrong pairing of EU firmware?   

    Need to know what version firmware your Tx is running, also if you have other Rx working.
  • #3 by Mi96ke on 08 Jan 2018
  • I've tried open tx 2.1.6 (the stock version) mode 1 and 2 EU and non EU, 2.2.1 EU and non EU on the taranis, the x4rsb I haven't touched, it's the first time using everything
  • #4 by Cheredanine on 08 Jan 2018
  • Open tx is the software on the radio, it has nothing to do with binding, that is the firmware on the internal module.
    Suggest you go the Frsky site, flash the latest firmware on the radio internal module (again not opentx) and flash the latest firmware to the xsr
    Painless360has an excellent guide or:
  • #5 by Mi96ke on 08 Jan 2018
  • I got the most recent firmware file from fryskys website, the 2.1.6 version I said about, not Open TX, my mistake, and flashed it through the taranis' own bootloader, still no joy with any of those 4 firmwares, do you think upgrading the firmware on the x4r will help? Only bought a month ago with the EU sticker on the packaging, I can't remember if it was the lbt version or not, could it be an lbt mismatch?
  • #6 by Cheredanine on 08 Jan 2018
  • The firmware on the reciever needs to match the firmware on the internal module in the radio, both in type (lbt and non-eu) and version.
    So yeah the easiest thing to do is flash both.
    That video shows you how to do both by putting both on an sd card.

    Your version numbers still smack of opentx, not Frsky, they have a lot more numbers in their version numbers
  • #7 by Cheredanine on 08 Jan 2018
  • Yeah just checked, you are using “firmware”on the taranis site, that is opentx.
    You need to use the download from firmware-xjt I believe (been a while)
    Basically take the sd card out the taranis, stick it in a pc, stick the latest firmware for the internal xjt module and the xsr on it, then stick it back in the taranis and follow instructions for both.
    The latest version number is 170317
  • #8 by Mi96ke on 08 Jan 2018
  • Thanks for your help, I'll give that a go, what's the xjt part?
  • #9 by Cheredanine on 08 Jan 2018
  • Revised above, the xjt is the transmitter.
    If you think of the radio as a computer with a special card in the back, opentx (what they call firmware is a custom version of opentx) is like the software. But to get the card to talk to what you want the card has to have the right firmware.
    Watch the video, when he choses to flash the external module, there is another option to flash the internal module, that is what you are after, that will flash the radio internal module using the firmware you have copied to the sd card
  • #10 by Cheredanine on 08 Jan 2018
  • Peter is a usefull guy, this may help understand:
  • #11 by Mi96ke on 09 Jan 2018
  • Thank you so much! Finally got it bound, just need to set it all up now. After doing more research, and a lot of looking around for the firmware (as it's the frysky page is just coming up ass 404 page not found) found the xjt firmware flash it to the internal module and Shazam! I think it was the LBT issue
Pages:
Actions