Pages:
Actions
  • #1 by Casper Round on 10 Oct 2017
  • I'm a DJI user, and very new with Pixhawk etc, chose it because it seems allot cheaper than DJI flight controllers.
    I bought a setup from here: https://www.amazon.co.uk/gp/product/B06XSBNXSD/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1
    Which comes with pretty much everything for the flight controller it seems, I've got it running with bare bones at the moment.
    Connected GPS, bat monitor, and reciever. I can connect to it in mission planner, and the Transmitter and RX work fine. Motors spin up etc, the only problem I have which might be related to the GPS is that it keeps flying forwards.

    I picked it up, carefully and span the motors at half throttle to see whats going on, I move the right stick forwards - This should make the quad tilt forwards however for some reason it keeps tilting on the front right motor. Seeming like its in a + orientation however in mission planner its set to a X frame not a + frame. The GPS and Pixhawk board are both facing forward on the flat surface of the drone. Its only a little 250 type.

    The GPS has no LED, and yes its connected correctly to the 12v power and the GPS socket on the Pixhawk board, the first time I powered up via USB the GPS blinked, after installing the firmware in the Mission Planner it no longer has an LED on the GPS. Nor can I see any GPS fix.

    Whats going on?
  • #2 by hoverfly on 10 Oct 2017
  • Hard to diagnose remotely, but I would reset level and check motor order.
  • #3 by Casper Round on 10 Oct 2017
  • I've reset the level, re-calibrated orientation, checked motor order however still no luck. Now it wont even arm, Battery is fully charged 3S 3000Mah. And it keeps displaying board voltage low??
  • #4 by DarkButterfly on 10 Oct 2017
  • There is a new firmware available which may have some bug fixes for the PX4, I suggest a full erase and re-flash. ~~
Pages:
Actions